OFFICE AUTOMATION
Course Code: DCSA 1302

Diploma in Computer Science and Application Programme

SCHOOL OF SCIENCE AND TECHNOLOGY
OFFICE AUTOMATION
Course Code: DCSA 1302

Diploma in Computer Science and Application Programme

Writer
Mohammad Shamim Hossain
School of Science and Technology
Bangladesh Open University

Sanaul Haque
Department of Computer Science and Engineering
Bangladesh University of Engineering and Technology

Gour Chandra Karmakar
Computer Division
Bangladesh Open University

Zakaria Swapon
B.Sc. Engineering (Computer Science)
Proshika, Dhaka

Co-ordinator
Dr. K. M. Rezanur Rahman
School of Science and Technology
Bangladesh Open University

Bangladesh Open University
OFFICE ATOMATION

Course Code: DCSA 1302

Print
First Print: June, 1997
Revised: January 2011

Published by:
Publishing, Printing and Distribution Division
Bangladesh Open University
Gazipur-1705.

Cover Designed by
Monirul Islam

Graphics
Abdul Malek

Computer Composed
Md. Jakir Hossain
Sabina Yesmin

Printed by
Ganim Printing & Packages
44/G, Azimpur Road, Dhaka-1205.

ISBN 984-34-4002-1

©Bangladesh Open University, Gazipur- 1705
The present edition of the book is revised. The contents of the unit-3 to unit-7 have been brought up-to date. The MS office XP has been used to describe MS Word and MS Excel. Exercises at the end of the lessons have been brought up-to date. The MS Foxpro (unit-8 to unit-11) remains unchanged for better understanding in database package. But learners are requested to study MS Access and prepare themselves for examination. The book “MS Access” has been prepared and supplied to learners separately as additional module. Appendix provides a complete list of keyboard shortcut for MS Word. At the end of each lesson, there are exercises and hands an practices.

We are grateful to our tutors and learners for their favorable appreciation of the book. Suggestions for further improvement will be highly appreciated.

Dean
School of Science and Technology
Bangladesh Open University
Preface to the First Edition

Office automation is a deliberated and widely used term in this information age. The office of today is a place for applications of information technology.

Information is the main source of an office automation system. During the past decade a tremendous development has taken place in the information technology. Recent technological changes and the information superhighways centered around computers. Communication technology revolutionized our office and society. Office automation involves the use of computer and telecommunication technologies to simplify and support office routine functions, improve communications and there by increase office productivity.

Office Automation applies a variety of technologies (e.g. e-mail, e-filing, teleconferencing, video-conferencing, Internet etc). The cost of office automation tools and technology have been falling rapidly in recent years. Executives are now more receptive to the idea of investing in office automation technology to reduce rising labor cost and improve productivity. Office automation is expected to receive a major thrust in all offices or organizations in the coming years in Bangladesh.

This book introduces the students with various facets of office automation and help them to know word-processing, spreadsheet and database operations. The course contents are organized under eleven units. A brief summary of each the unit is presented in the following sections.

Unit-1 introduces the office automation. It provides an preview of office and office automation, goals of office automation, obstacles to the growth of office automation and computer mail system.

Unit-2 presents office automation tools and technology. It describes telecommunication, word processors and their configurations, reprographics and micrographics. This unit also introduces applications of information technology such as e-mail, e-filing, facsimile transmission, teleconferencing and video conferencing.

Unit-3 describe a sample MS Word session. This unit describes how to create, open, save, close, print and locate documents.
Unit-4 introduces typing and editing features (e.g. moving insertion point, scrolling, copying and deleting text, finding and replacing text etc.) of MS Word. It also provides the tools that allow one to proof (check) documents for potential spelling, grammar and style errors.

Unit-5 controls the way, the documents look. It provides the features of character formatting, paragraph formatting and page formatting.

Unit-6 describes how to apply table and newspaper style columns to a documents.

Unit-7 introduces the concept of spreadsheet and provides fundamental knowledge of MS Excel.

Unit-8 introduces database and related topics. Foxpro menu structure, dialog box and windows. This unit describes how to create or add information to a database.

Unit-9 introduces editing, browsing, sorting or indexing and queries.

Unit-10 describes how to create, modify and print reports. This unit also describes a detail of Fox Report and Foxpro’s Report generator.

Unit-11 introduces screen builders and push buttons.

Learners are requested to study MS Access described in a separate book consisting unit-8 to unit-11 instead of above mentioned unit-8 to unit-11. The book is supplied to learners as addition module.

The end of each lesson there are exercises or hands on practices. The exercise and hands on practice are useful to check what one has learned. A learner can check his/her understanding of the lesson by answering the questions.
# Office Automation

## Contents

### Unit 1: Office Automation

- Lesson 1: Goal of Office Automation ................................................................. 1
- Lesson 2: Office and Office Automation .......................................................... 6
- Lesson 3: Computer Mail System .................................................................. 13

### Unit 2: Office Automation Tools and Technology

- Lesson 1: Telecommunication and Word Processor ....................................... 21
- Lesson 2: WP Hardware Configuration ......................................................... 29
- Lesson 3: Reprographics .............................................................................. 36
- Lesson 4: Electronic Mail and Electronic-Filing ........................................... 39
- Lesson 5: Facsimile Transmission and Micrographics .................................. 43
- Lesson 6: Voice Technology ......................................................................... 49

### Unit 3: Microsoft Word and Basics of Word Processing

- Lesson 1: Basic File Operations ..................................................................... 55
- Lesson 2: Locating and Managing Documents .............................................. 62
- Lesson 3: Previewing a Document before Printing ......................................... 68
- Lesson 4: Printing Documents ...................................................................... 72

### Unit 4: Typing and Editing

- Lesson 1: Moving Inserting Points, Scrolling and Selecting Text ..................... 77
- Lesson 2: Editing Word Art and Equation Editor ............................................. 82
- Lesson 3: Finding, Replacing and Moving Texts ............................................. 90
- Lesson 4: Proofing Documents ..................................................................... 96

### Unit 5: Formatting Text and Pages

- Lesson 1: Character and Paragraph Formatting-I ......................................... 101
- Lesson 2: Paragraph Formatting-II and Formatting List ................................... 109
- Lesson 3: Page Formatting ........................................................................... 118

### Unit 6: Tables and Newspaper

- Lesson 1: Table-I .......................................................................................... 127
- Lesson 2: Table-II ......................................................................................... 136
- Lesson 3: Newspaper Style Columns ............................................................. 146
- Lesson 4: Drawing in Word .......................................................................... 151

### Unit 7: Spreadsheet Analysis

- Lesson 1: Introduction to Spreadsheet .......................................................... 159
Lesson 2: Spreadsheet Fundamentals ................................................................. 163
Lesson 3: Entering Data ....................................................................................... 168
Lesson 4: Formulas and Functions ......................................................................... 175
Lesson 5: Advanced Editing, Alignment and Fonts .................................................. 181
Lesson 6: Formatting Numbers, Adding Borders and Shades ................................... 188
Lesson 7: Changing Cell Size and Page Setup ..................................................... 192
Lesson 8: Printing Worksheets ............................................................................ 199
Lesson 9: Creating and Modifying a Chart .......................................................... 205

Unit 8: Introduction to Database
Lesson 1: Understanding Database, Database Record, Field and Database Management System ........................................................................................................... 215
Lesson 2: Getting Acquainted with Foxpro ................................................................ 218
Lesson 3: Performing Queries .............................................................................. 230

Unit 9: Editing, Sorting/Indexing And Queries
Lesson 1: Editing and Viewing the Data .............................................................. 239
Lesson 2: Understanding Sorting and Indexing Database ......................................... 249
Lesson 3: Performing Queries .............................................................................. 261

Unit 10: Designing and Printing Reports
Lesson 1: Report-I ............................................................................................... 269
Lesson 2: Report-II ............................................................................................ 277
Lesson 3: Page Formatting .................................................................................... 287

Unit 11: Understanding the Screen Builder
Lesson 1: Creating, Generating Code and Running of a Quick Screen Layout ................................................................. 301
Lesson 2: Introduction to Screen Builder Tool box, Push Button and Rearranging, Deleting and Modifying Screen Objects .............................................................................. 308
Lesson 3: Creating and Programming for Push Button, Field and Edit Region Tool ................................................................................................. 318

Answer Key to the MCQS .................................................................................... 327

Appendix : ........................................................................................................... 329
Unit 1 : Office Automation

Introduction

Office automation is a broadly used term and it represents a new profession, a new integration of technologies and a new perception of the potential of information tools available to man. It is primarily based on two factors: computers and communication technology. The computer is moving from being an independent system to a component embedded in a whole range of office devices. Communication technology integrates these devices and people. It provides an effective communications infrastructure. So, office automation is the use of various technologies (e.g. computer and telecommunication) to simplify and support routine office functions, improve communication, increase office productivity and enhance the quality of clerical output. Many office tasks including preparation of reports and correspondence, communications, file maintenance, duplication and distribution of written materials, can be facilitated and improved through word processing and other office automation techniques.

Lesson 1 : Goals of Office Automation

Learning Objectives

On completion of this lesson you will be able to :

- know the goals of office automation
- know the advantages of office automation.

Goals of Office Automation

The goals of office automation may be expressed in terms of

- Greater efficiency,
- Better service,
- Better accuracy,
- Demanding for timeliness,
- Facility in control,
- Standardization of office routine,
- Relieves of monotony,
- Prevention of fraud,
- Better information retrieval,
- Lower operating cost,
- Reduction in paperwork,
- Improved communication environment.
Greater Efficiency

The use of computers and other office automation technologies on large scale has made prices lower by 10 to 30 percent and often much more than they would be without computers. The use of office automation technologies improves productivity i.e. the amount of goods or services that individuals and machines can produce in a given time period. These productivity gains can lead to (i) a stronger competitive position and (ii) higher levels of real income for an increased number of individuals. So, office automation brings speed and efficiency to all types of office work. Improved efficiency leads to greater profitability and at the same time creates good images in the minds of the people who deal with office.

Better Service

Offices use office automation technologies to improve the service they provide to customers, clients, patients etc. For example, Computer processing techniques and office automation tools make possible:

- shorter waiting lines at airline ticket offices and at the reservation desks of hotels, motels and car-rental agencies
- faster and more accurate answers to the inquiries of people served by the offices
- more convenient handling of purchase transactions through the use of credit cards
- more efficient customer service and control in retail outlets.

Thus, office automation provides better service and help to improve the quality of work done in the office.

Better Accuracy

If a data processing operation is strained to and beyond the capacity for which it was originally planned, inaccuracies begin to appear and the control of official activities suffers. Computer processing, becomes quite accurate if the task to be performed are properly prepared. So, office automation ensures better accuracy. Chances of errors are almost eliminated. Thus work goes on smoothly and bottlenecks and delays are eliminated.

Demanding for Timeliness

Timeliness of information is of great importance to all offices and organizations for decision making. For example, timely announcement of promotion, timely information about training opportunities, timely modification of staff lists and their addresses, timely payment to customer and so on, avoid many serious problems. For an administrator, a timely
information may help him to take timely decisions and actions and prevent undesirable consequences. Only office automation can perform these and provide timely information.

**Facility in Control**

Office automation facilitates the task of mangers. Office automation helps managers to exercise better degree of control over their subordinates. Certain office automation tools allow for minimization of fraud in the accounting department.

**Facilitates Standardization of Office Routines**

Office automation helps to facilitate standardization of office routines and procedures. Standardization of office routines facilitates better coordination of works.

**Relieving Monotony**

Office automation reduces the monotony of carrying out repetitive processes which are boring and time consuming. The office worker is thus relieved of mental tensions of going through same process again and again by using office automation tools and technologies.

**Prevention of Fraud**

Computer and office automation tools are more reliable than man. A man can deceive cheat but a computer works on its own motion. So, for the prevention of fraud, office automation is a must.

**Better Information Retrieval**

A New-York surgeon contacted a medical library when a near-term pregnant woman lapsed into a hepatic coma. He needed immediate information on exchange blood transfusion for woman. Using a computer terminal and a retrieval program, the librarian searched more than a half million medical documents in a few minutes to get information needed by the surgeon to perform an emergency blood transfusion. The patient recovered fully from hepatitis. Most information retrieval tasks obviously do not involve life or death decision; but quick computer assisted retrieval can save time and aggravation for many individuals. So, office automation ensures better information retrieval.

**Lower Operating Cost**

Operating cost per hour of work declines with the use of office automation technologies. For example, a PC can help a manager budget
and balance his check book, control his installment purchases, control his home's energy use and analyze his investment. Of course, there is no doubt that office automation technologies require a large amount of initial capital investment. However, now-a-days, office automation prove beneficial. The cost of electronic-office equipment have been falling rapidly in recent years. Executives are now more receptive to the idea of investing in new office automation technology to reduce rising labour costs and improve productivity.

**Reduction in Paper Work**

Paper based office work is certainly costly. It is not due to the increasing cost of paper but due to the procedure involved in preparing reports and letters. First, a letter is dictated (or written by hand). Then it is typed (draft), proofread and delivered to the executive. After corrections and alternations, the process is repeated again till it is approved. Office workers use to output written documents on paper - a physical medium that (i) takes space, (ii) requires postage for mailing or effort for delivering, (iii) often gets stored in file cabinets that is space consuming, (iv) requires additional work to update and destroy. So, finding no other way, managers are trying to reduce paper work to minimize the cost and improve office productivity. Only office automation provides a number of ways for accomplishing these through the use of office automation technologies such as computer processing, distributed data processing, e-mail, and teleconferencing etc.

**Improved Communication Environment**

Studies shows that a lot of office activities involve the communication of information to others. For example, more than half of a typical manager's time is spent communicating in meetings, phone calls, letters and memos. Secretaries and office staff support these communication efforts by taking messages, drafting documents, planning meetings and documenting verbal agreements. A key ingredient of office automation is the ability to communicate easily relevant data and information to every worker who needs it. It has obvious superiority in certain respects over traditional channels for business communication. The postal service can be slow, letters are sometimes lost, and the mail usually takes long time. Telephone calls require both senders and receiver to be on the line at the same time. Hand written memos depend on some internal distribution process and are easily lost in the shuffle of paper. To avoid all these drawbacks, a whole array of advanced communications, including e-mail, Internet, voice mail, facsimile transmission, local area network, teleconferencing, are now being offered by a modern automated office.
Exercise

1. Multiple choice questions

a. The use of office automation technology made prices lower by

   i) 10 to 20 percent
   ii) 10 to 30 percent
   iii) 30 to 40 percent
   iv) 45 to 65 percent.

b. Office automation facilitates the task of

   i) officers
   ii) managers
   iii) clerks
   iv) peons.

c. Operating cost per hour of work declines with the use of

   i) office automation technology
   ii) computer controlled robot
   iii) hand-made tools
   iv) electronic-mail system.

2. Analytical questions

1. Identify and discuss some of the goals of office automation.
2. Critically discuss advantages of an automated office.
3. Discuss the effect of reduction of paper work on the environment.
Lesson 2: Office and Office Automation

Learning Objectives

On completion of this lesson you will be able to:

- define office
- classify office objectives
- outline the services of an office
- know what office automation is
- identify the benefits of office automation
- find out the obstacles to the growth of office automation.

Office

The office of today represents the largest and the most exciting area for the application of information technology. Normally, office may mean a central place where some sort of paper work is performed by the clerks on their desks. But this definition, though sounds correct, is incomplete. The office can be defined as:

"A place where proper records for the purpose of control information and efficient and effective operations are prepared, handled and serviced".

- A place where professionals like physicians, lawyers, or engineers conducts their business.
- It may consists of a few tables, chairs, almirahs, typewriters, telephone, photocopier, computer and additional equipment like calculator, cyclostyle and Xerox machines.
- People in the office can be executives, secretaries, clerks and peons.

An office is primarily concerned with the records of organization - making records, using records and preserving them for future reference.

Function

The functions performed by an office may be classified as primary and secondary.

- **Primary** function of the office is to make, preserve and use records of the organization.
- The **secondary** functions may be divided into the following five categories.
i). Planning :

Another major office function is planning. Planning means scheduling the activities of the organization and lying down a course of action. Effective performance of all office work requires prior planning. Planning is necessary to avoid wastage and delay. Planning reduces overall cost of office operation.

ii). Communication :

Arranging communications between different individuals within premises of the office through interviews, telephones and conference etc and with outsiders through letters, telephones, telegrams and personal meetings etc is an important secondary function performed by the office.

iii). Compilation and Presentation of Statistics :

Compilation and presentation of data are also office work. Collection and comparison of prices, compilation of costs, analysis of sales and reckoning of payroll is also part of the office work.

iv). Systematization and Cost Reduction :

Systematization is done by analyzing the existing office routines and adopting improved ones. Office cost may be reduced by using automated technology whenever necessary. Off-line cost may also be reduced by adopting better office forms and other labour saving devices.

v). Creation and Management of Information :

All offices, irrespective of their size and kind, create and manage information that is required for making decisions or providing services to people within or outside the organization. The creation and management of information involves the following activities :

- Capturing facts and figures,
- Classifying and sorting,
- Calculating,
- Summarizing,
- Storing and retrieving,
- Reporting.
Office Automation

Services

The services of an office are as follows:

- Mailing service: Receiving, distributing and dispatching letters, notices, circulars, memoranda etc.
- Drafting, typing and duplicating services: Making arrangements for drafting typing and duplicating letters, circulars etc.
- Oral communication service: Providing all assistance for arranging interviews, conferences, meetings and receiving and making telephone calls.
- Accounting service: Recording business transactions, maintaining cost and financial accounts.
- Filing and indexing service: Maintaining, preserving and locating all office records and account books.
- Billing service: Preparing bills, passing credit and recovery of outstanding accounts.
- Statistical service: Collection, tabulation and interpretation of statistical data and preparation of charts and diagrams.

Characteristics of Office Automation System

Office automation is a widely used term today. It generally means the application of computer and communication technology to improve the productivity of "knowledge workers".

- Office automation refers to the use of sophisticated electronic equipment and communication systems to carry out the "electronic tasks". The tasks include:
  - Text processing,
  - Data processing,
  - Information storage,
  - Information retrieval and updating,
  - Message distribution,
  - Document transmission and reproduction,
  - Teleconferencing.

- Office automation is a process that involves people, procedure and technology.

- Office automation technology include word processor, telecommunication, reprographics, e-mail, e-filing, facsimile transmission, micro-graphics and voice technologies.
Office Automation

- Office automation involves the use of computers, in conjunction with other electronic equipment to automate the basic secretarial and clerical tasks of office.

- Basic office automation consist of word processors connected to one another by means of a local area network.

- Office automation should be designed as a multifunction information system to provide executives decision support tools such as:
  - On-line access to databases,
  - Model building and forecasting,
  - Risk analysis,
  - Sophisticated graphics,
  - Integration of data and text,
  - Data communication.

- Some office automation systems go far beyond the function of providing word processing on networks. PCs or workstations are connected to a network.

- Office automation supports a large number of software packages that could be used as decision support tools. Important ones are:
  - Word processor,
  - Database management systems,
  - Electronic spreadsheets,
  - Graphics packages,
  - Electronic mail systems.

- Benefits of office automation include increased productivity, greater accuracy, lower clerical cost, continuously decreasing cost, decreasing size and increasing capabilities, quality and flexibility of outputs, and ease of operations.

**Obstacles to the Growth of Office Automation**

The problems which can obstruct the growth of office automation are as follows:

- Monotonous job specialization can lead to boredom, frequent errors, high personnel turnover and high training cost.
- People may be unable to locate records in large files because the records may have been stored under a number of different classification schemes.
Office Automation

- Cost associated with storing and duplicating documents within an organization or office, as well as the cost of preparing and mailing documents are often very high.
- Wrong management approach for a particular office.
- Poor selection of equipment relative to the employee's skill levels.
- Some argue that automated office will trend to dominate our lives as a society as individuals.
- On the economic front, the pessimists argue, more people will be displaced and then unemployed as the advances in technology are accelerated.
- Some administrators have lost their job or have suffered a loss of status and prestige when office automation systems were installed, and others have suffered anxiety at being forced to give up familiar surroundings and procedures and to learn new techniques.
- Clerical employees, for example, have often been displaced by computers and production employees are being threatened (or sometimes displaced) by the rapidly increasing use of office automation technologies or computer controlled machines.
- System miscalculation have also victimized individuals.
- Individuals may temporarily feel threatened by a change and reaction may be evidenced by open opposition and even destruction. Besides these, the following symptoms may be found, these are-
  - withholding a data and information,
  - providing inaccurate information,
  - distrusting computer outputs,
  - showing lowered morale.
- The lack of control over office automation system security has resulted in:
  - economic loss, i.e. theft of money and goods,
  - misrepresentation of facts,
  - system penetration and espionage,
  - a loss of privacy for individuals,
  - inconvenience,
  - and dehumanization.
Office Automation

Exercise

1. Multiple choice questions

a. An office is primarily concerned with

i) the records of the organization
ii) the files of the organization
iii) the letters of the organization
iv) the memos of the organization.

b. The secondary functions may be divided into

i) 3 categories
ii) 4 categories
iii) 5 categories
iv) 7 categories.

c. Office automation is a process that involves

i) people, paper and procedure
ii) people, procedure and technology
iii) man, machine and management
iv) people, procedure and production.

d. Increased productivity, greater accuracy, lower clerical cost and ease of operations are the benefits of

i) offices
ii) organization
iii) office automation
iv) planning.

e. Monotonous job specialization can lead to

i) boredom, frequent errors, high personnel turnover and high training cost
ii) boredom, frequent errors, low personnel turnover and high training cost
iii) boredom, non frequent errors, high personnel turnover and low training cost
iv) boredom, frequent errors, high personnel turnover and low training cost.
Office Automation

f. Clerical employees have often been

i) displaced by computers
ii) honored by computers
iii) rewarded by computers
iv) dishonored by computers.

g. Overvalued representation could be used in

i) data manipulation
ii) criminal manipulation
iii) file manipulation
iv) record manipulation.

2. Analytical questions

a) What is an office? What are the functions of an office?
b) What do you understand by office automation?
c) Describe how administrators and employees may be harmed by the use of office automation technologies.
d) What are the problems that can obstruct the growth of office automation?
Lesson 3 : Computer Mail Systems

Learning Objectives

On completion of this lesson you will be able to:

- know voice mail systems and transmission of text
- learn what videotex is.

What is CMMS?

A computer mail/message system (CMMS) is a network that can store, transmit and deliver electronic messages avoiding the usual postal services. CMMS is gaining popularity among large organizations and offices in advanced countries mainly due to two reasons:

- The cost of sending a message over a CMMS has been continuously decreasing. It is dropping by 10 to 15 per cent every year.
- The postal service is relatively slow and messages get lost sometimes. When telephone is used to convey a message, it is not certain that the message will reach the concerned person.

Message Distribution

A written message can be keyed into the system at any time for onward transmission. The message is received and stored in the receiving system. The receiver reviews the stored message at a time convenient to him. A visual display terminal is used to review the message. The receiver can also obtain a hard copy, if required, on the printer and can send replies immediately through the keyboard. Such systems are often referred to as "electronic mail service" and the storage part of the receiving end as "electronic mail box".

Voice Mail System (VMS)

Voice mail systems function somewhat like an electronic mail box described above. However, instead of holding a recorded written message, it holds a recorded voice message. The caller establishes a connection between his/her phone and a computer and notifies the computer that he/she wants to leave a message at a particular number. The caller then leaves the message orally on the phone. The computer, in turn, converts
the caller's oral message into a digital signal and forwards it to the
concerned destination. At the receiving end, the voice message is recorded
and stored until the receiver requests for it. The receiver, at any time
convenient to him, can hear the computerized reproduction of the caller's
voice. The same voice message can be sent to many people. The procedure
for sending voice messages is shown in Fig. 1.1.

Voice mail boxes reduce/eliminate many frustrations of telephone
communications, such as busy signals, non-availability of concerned
persons and disturbances during an important meeting.

Transmission of Text

The conventional method of transmitting information in the form of text is
through the teleprinter exchange system called "telex". In this system, text
is transmitted over telecommunications lines between two terminals called
teleprinters that look like typewriters. After establishing connection with
the distant terminal, text is keyed into the keyboard of the sending-end
terminal. The text is then transmitted over the lines to the receiving-end
teleprinter which prints out the message automatically. The telex system is
extremely widespread and found in almost every office.

These terminals may also be connected to computers to extend the use of
computers to various places of work in an organization. With the
introduction of microprocessors, the teleprinter terminals that are
connected to computers are being replaced by the terminals with display
screen and processing power. The screen displays text as it is keyed in,
enabling a visual check before the input is transferred to the computer for
onward transmission. Text is displayed on the screen faster than by the
teleprinter terminals. It is a silent operation.

Videotex

Videotex refers to the transmission system that uses a TV set to display
text. The development of videotex systems have led to the use of
computer-based information services in the home. There are two kinds of
videotex systems, namely,

- teletext
- viewdata.
Fig. 1.1: Sending voice messages.
Teletext

It is the transmission of text on the normal television channels for display on TV sets. This kind of service is popular in Britain. Both the British Broadcasting Corporation (BBC) and Independent Television (ITV) provide 'pages' of information on request by the viewer. The request is made by keying in page numbers on a hand-held control unit (keypad) and within a few seconds the requested page appears on the screen. Information covers topics such as travel, weather details, financial news, stock exchange rates, consumer items, important news items and special events of the day. Elements of a teletext system are shown in Fig. 1.2.

Viewdata

It is a more versatile type of computer-based information system. This system links "viewdata terminals" to a central computer via telephone lines. The terminals are normally modified television sets which can still receive usual TV signals. A word processor can also be used as a terminal. Here again, information is transmitted as pages. A user requests for a page and gets it on a screen or printer. If a word processor is used, the message can be stored for future. The information is stored in the central viewdata computer and updated continuously. Elements of a viewdata system are shown in Fig. 1.3.
Britain and United States are among the leading countries that provide viewdata service to public. Viewdata service in Britain is popularly known as "Prestel". This service is provided by the British Telecommunications and is based on a number of regional computers situated in various parts of UK and a central computer in London. Information on Prestel is provided by independent agencies who lease space on the system. Government departments, business and industrial organizations and educational institutions are among the "Information Providers". In US, a large number of private organizations offer viewdate service. A user can register with a service company as a subscriber and can have access to the data bases maintained by the company. Subscribers can also exchange messages between themselves.

The interactive capabilities of viewdata promise a host of services to the public. It is possible to have electronic banking at home. A customer can get his bank account displayed on his television screen, make payments for goods and services and transfer money to other accounts or banks. Departmental stores use viewdata for providing "electronic shopping" service. Shoppers view merchandise on the TV screens and then place their orders through their home computers. Universities and educational institutions use viewdata for career guidance and for details of educational courses and opportunities.

Transmission of Pictures
Documents containing photographs, maps and drawings are transmitted using special machines called facsimile machines.
Office Automation

Modem

MODEM means Modulator-DEModulator unit. A device that converts data from a digital form that is compatible with data processing equipment (e.g. Computer) to analog form that is compatible with certain transmission facilities and vice versa.

Summary

Office automation is a completely new way of perceiving the interaction between technology, people and functions. It provides a mixture of potential benefits and potential hazards. In order to reap the benefits over the hazards, the technology should be carefully selected and integrated with the people. Office automation is the collective term for the various technologies that have simplified, accelerated, organized and improved the quality of tasks such as typing, filing, conferencing, message exchange and generating, and distributing documents.
Exercise

1. Multiple choice questions
   a. Videotex system are of
      i) 2 kinds
      ii) 3 kinds
      iii) 4 kinds
      iv) 5 kinds.
   b. VMS means
      i) Voice Message System
      ii) Voice Mail System
      iii) Video Message System
      iv) Voice Mail Service.
   c. Videotex refers to the transmission system that uses
      i) a CRT screen to display text
      ii) a TV set to display text
      iii) a printer to print the text
      iv) an electronic-mail box to receive the text.

2. Analytical questions
   a) Why should we use Computer Mail/Message System?
   b) What do you know about VMS? Briefly describe.
   c) What is telex? Describe the system.
   d) Describe different kinds of videotex system?
Unit 2: Office Automation Tools and Technology

Introduction

Office automation applies a variety of technologies to increase office productivity. The technologies in the automated office have made and continue to make substantial changes in the conduct of many standard office functions. In this unit, we look at office automation innovations including reprographics, e-mail, e-filing, facsimile transmission, micrographics, teleconferencing, video conferencing, computerized teleconferencing. Office automation tools include geographically separate word processors, electronic printer, OCR, dictation unit, optical page reader, standard typewriter, PABX, facsimile devices, and other equipment that communicate with one another and with remote computer systems via telecommunication and data communication links.

Lesson 1: Telecommunication and Word Processor

Learning Objectives

On completion of this lesson you will be able to:

- define telecommunication and word processor
- distinguish between word processing and data processing
- describe optical character reader (OCR), photocopying machine and electronic printer
- know the advantages of word processor over a standard electronic type writer.

Telecommunications

The transmission and reception of signals, writing, sounds, intelligence of any nature are possible by wire, radio, light beam or any other electronic means. Computer communication takes place via computer networks. Computerized telecommunication allows rapid information exchange to geographically distant sites. Data stored physically in one location may be accessed or utilized instantly and simultaneously at numerous other locations. Modern telecommunication techniques provide improved information exchange and more management control over dispersed parts of an office or organization. A local area network (LAN) is a communication system that links together the devices located in a small area such as an office building or a campus. A local area network uses...
Office Automation

special coaxial or fiber optic cables with appropriate interface units and belongs to the using organization. The transmission speed is very high and it is possible to connect together terminals, word processors and computers of different vendors. A LAN can integrate word processing and data processing and help optimize the use of costly resources such as storage devices and printers. It is also possible to link two LANs through a long-distance transmission line.

Difference Between Word processing and Data Processing

How word processing differs from data processing is as follows:

<table>
<thead>
<tr>
<th>Word processing</th>
<th>Data processing</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Done mostly on words</td>
<td>1. Done mostly on numerical data.</td>
</tr>
<tr>
<td>2. Word manipulation and formatting is performed flexibly.</td>
<td>2. Data manipulation requires careful formatting.</td>
</tr>
<tr>
<td>3. It is a qualitative process.</td>
<td>3. It is a qualitative process.</td>
</tr>
<tr>
<td>4. Errors are relatively easy to locate.</td>
<td>4. Errors are more difficult to locate.</td>
</tr>
<tr>
<td>5. Word processing concentrates on preparation of documents such as letters and reports.</td>
<td>5. Data processing is concerned with performing tasks associated with applications such as payroll, inventory control, accounts payable/receivable etc.</td>
</tr>
</tbody>
</table>

Word Processor

Word processing involves the production of letters, reports and other documents by means of electronic equipment. Once the material has been entered into this equipment it can easily be modified or corrected and additions or deletions can be made without retyping the original document.

Word processing is the process of transforming ideas into written communication quickly and accurately through the use of computer technology. The process includes creation, manipulation, storage, retrieval and printing of texts. It requires trained people and a set of office procedures to do the job effectively.
Office Automation Tools and Technology

The basic components of a word processing system is shown in Fig. 2.1.

![Diagram of a word processing system with labeled components: External storage, Input, Output, Keyboard, Processor, Printer, CRT Screen.]

Fig. 2.1: The basic components of a word processing system.

**Optical Character Reader**

Optical character readers are input devices that are used to read any printed text. They can interpret handmade marks, handwritten characters, machine printed characters and special symbols and codes. In other words, optical character reader (OCR) is the direct reading and conversion of typed or handwritten characters into computer readable form. Say, for instance, as secretary uses a conventional typewriter to type a list of employee names on a sheet of paper. He or she then places the paper into a feeder bin on an OCR device, which reads the list directly into the computer system without manual intervention and without the need for magnetic ink.

The steps in an OCR system are to prepare the document, read it, recognize characters, edit and format output, and finally output the results directly to the I/O channels or to an off-line computer tape or disk.
OCR devices have been in commercial production since the 1960s. They have become more popular in recent years as prices have dropped significantly.

OCRs scan the text optically character by character, convert them into a machine-readable code and store the text on the system's storage medium. They can read at a rate of up to 2,400 characters per second. This makes it possible for offices to reduce the input keying bottle-neck. OCR devices are expensive and are used only when there are large quantities of documents to be keyed-in. Other advantages of using an OCR are:

- It can be used to reformat preprinted or pre-typed documents by inputting through the reader and outputting on the system's printer.
- It can be used to consolidate texts from various documents into one document.
- It can serve as a link between the word processing system and the conventional typewriter.

Since OCR eliminates human element in data entry, it improves data accuracy and timeliness of output. However, if the document is poorly prepared, it can create difficulties.

OCR applications include the following:

- Banking: OCR reads check-information, either as the principal data input device or as a secondary device for checks rejected by magnetic ink character recognition equipment.
- Retail operations: OCR is used most commonly for reading bar code symbols on products in supermarkets, department stores, and other retail firms.
- Processing of credit card forms: Some large credit card issuers such as oil companies, which process millions of receipts forwarded from retail operations daily, use OCR equipment to read these receipts.
- Newspapers: Newspaper stories and advertising copy typed in draft form can be input directly to the computer by OCR devices. (In some cases editors and reporters type copy directly into a terminal without draft copies; OCR is unnecessary here.)
- Government: OCR equipment is used to read census information and portions of the massive volume of tax records into government computer systems.
- School districts: School districts often use OCR to read typed or hand printed data on student performance, attendance, schedules, and course selections.
Office Automation Tools and Technology

- Word-processing functions: Because an OCR device can read typed and/or hand printed documents, it may be part of a word-processing system, or it may be connected to a standard computer system. In the latter case, once a document is read in, it is processed by a text editor or other text-processing software.

### Photocopying Machines

Photocopying machines are fast replacing the duplicators. Photocopiers do not require the preparation of a master. They are simple to use and do not require any training to operate.

Photocopiers can produce copies in the range of 15 to 50 copies per minute automatically. The original may be a sheet, a page of a book or a 3-dimensional object. Some models can produce copies with reduction or enlargement. This is useful for producing multiple copies of large size computer outputs. We can also use "cut and paste" technique in preparing originals. Most photocopiers have the following features.

- Automatic paper feeding
- Provision for feeding different sizes of paper
- Copy selector to set for a specified number
- Copy counter.

Photocopiers are also available with attachments that can collate, staple, and stack copied documents. Copiers that can produce copies in colour are also available in the market.

### Electronic Typewriters

It is a simplified word processor offering a limited set of functions, often including automatic centering, tabulation of decimal numbers, insert and delete, and search and replace. It usually lacks a full viewing screen, so the typist must print out the text to see it. It stores 200 or fewer pages in its memory.

The advantages of a stand alone word-processor over an electronic typewriter is as follows:

- inserting text and deleting text,
- spacing, searching for and replacing portions of text,
Office Automation

- text scrolling (moving in any direction, text that will not all fit on the screen to view select portions); text arrangement (formatting with automatic centering, margins, pagination etc.),
- moving blocks of text from one location to another; production of form letters or standard documents.

The following figure shows an electronic typewriter (Fig. 2.2)

Fig 2.2 Electronic typewriter.
Exercise

1. Multiple choice questions

a. Data processing is done mostly on
i) words
ii) numerical data
iii) letters
iv) logical data.

b. Errors are relatively easy to locate in
i) data processing
ii) word processing
iii) centralized processing
iv) decentralized processing.

c. A local Area Network (LAN) is a communication system that links together the devices located in a
i) large area
ii) very large area
iii) small area
iv) wide large area.

d. Optical character readers (OCRs) scan the text optically
i) word by word
ii) page by page
iii) character by character
iv) sentence by sentence.

e. OCRs can read at a rate up to
i) 400 characters per second
ii) 1400 characters per second
iii) 2400 characters per second
iv) 2400 characters per minutes.

f. Automatic paper feeding and copy counter are the features of
i) photocopiers
ii) OCRs
iii) electronic printer
iv) duplicators.
Office Automation

g. An electronic typewriter can store

i) 100 or fewer pages in its main memory

ii) 200 or fewer pages in its main memory

iii) 300 or fewer pages in its main memory

iv) 400 or fewer pages in its main memory.

2. Analytical questions

a) What do you know about word processor and telecommunication?

b) What are the advantages of a word processor over an standard electronic type writer?

c) Point out some of the advantages of OCRs.

d) What are the features of a photocopier?

e) Compare Word Processing with Data Processing.
Lesson 2 : WP Hardware Configuration

Learning Objectives

On completion of this lesson you will be able to:

- discuss different word processor Hardware configuration
- point out some of the advantages of shared-logic systems over multiple stand-alone systems
- identify the advantages and disadvantages of time-sharing systems.

WP Hardware Configuration

A word processor consists of the following five hardware components:

- keyboard
- processor
- memory
- visual display
- printer.

Its technology is fast changing in terms of both performance and cost. Depending on the work flow, office structure and people, one can select a particular configuration of these parts. The most common word processor hardware configurations are:

- Stand-alone systems
- Shared-logic systems
- Shared-resource systems
- Distributed-logic systems
- Time-sharing systems.

Stand-alone System

A stand alone system is a self contained, single terminal systems located at one place with its own CPU, a CRT terminal, a keyboard, peripheral storage device and a printer. Since stand-alone systems are independent of other units in the office, these are relatively easy to implement in the office environment. They cost less and are most suitable for small offices. When the user's requirements exceed the capacity of one system, a second one can be added independently of the first.

Shared-Logic Systems

Shared-logic system is a word processing system that allows more than one user to work simultaneously.
A shared-logic system is composed of a central unit-including a processing unit (CPU) a CRT terminal, disk storage device(s), and printer(s) - and one or more remote CRT terminals for input/editing.

While two or more independent stand-alone systems increase reliability and flexibility of operations, storage and speed of these individual systems may not be adequate to meet certain applications. In such situation, a larger computer (usually a mini-computer) is used as a central processor and a number of keyboards with display screens are used as terminals. These remote CRT terminals do not have their own processing and storage capabilities but share the logic and storage sections of the central processor. Such terminals are often referred to as "dumb" or "non-intelligent" terminals. Fig. 2.3 illustrates a typical shared logic system that shares not only the processor and storage but also the printers.

![Shared-logic system diagram](image-url)
Office Automation Tools and Technology

The shared-logic systems possess the following advantages over multiple stand-alone systems:

- A shared-logic system is more economical. This is due to relatively low-cost dumb terminals. When load increases, an additional dumb terminal can be added without the need to duplicate the entire range of components.

- A centralized processor is more powerful and more sophisticated than individual internal processing units.

- Since a shared-logic system usually shares an external storage unit also, it is possible for many people to work simultaneously on a single document stored in the external storage.

However, the central processing unit has got two major drawbacks.

- Its failure leads to the failure of the entire system,
- Its response-time degrades as more terminals are added to it.

**Shared- Resource Systems**

Another kind of configuration that is commonly used in large offices is the "shared-resource" or "shared facility system". This is a cluster of two or more small word processing systems with their own processors and floppy drives that share certain costly components such as printers and hard disks. This also ensures the optimum use of printers and hard disks which might otherwise be under utilized. The printers of stand-alone systems are idle much of the time while the operators are busy with other tasks.
A configuration using shared-printer is shown in Fig. 2.4

Each word processor has been connected to the central printer via a switching system. Text can be transmitted to the printer with the help of software controls.

Distributed-Logic Systems

One of the major disadvantages of a shared-logic system is that if the central processor fails for any reason, all the terminals (dumb) are also down. This situation could be avoided if some processing capabilities are distributed among the terminals. This would enable many of the simple functions to be achieved on individual systems themselves.
A simplified illustration of a distributed-logic system is shown in the following Fig. 2.5. The system is basically similar to the shared-logic system except that the terminals in this case are intelligent. The distributed-logic system provides better response time and higher reliability of operations.

Dumb/non-intelligent terminal : A terminal that does not have a microprocessor to control various terminal tasks. In contrast, an intelligent terminal might allow word processing functions to be done utilizing the power of the terminal and not the CPU.
Intelligent terminal: A terminal containing own processor and memory. See dumb terminal.

**Time Sharing Systems**

Many organizations might have already installed large computers for data processing and maintaining data bases. These organizations may take another approach to word processing. They can add extra keyboard terminals and additional software to the existing main computer in time-sharing mode. This is similar to the shared-logic system except that the central processor is used for data processing also. A few advantages expected from a time-sharing system are:

- Terminals can be added at very little extra cost
- The power of the main system is available for word processing,
- Terminals can make use of the files already residing in the computer’s storage in preparing reports and documents.

Such terminals may be installed anywhere in the organization and can be used to communicate with each other. However, this approach has some drawbacks:

- Since the total system is not dedicated to word processing, the priority assigned to word processor activity may be low. In such cases, the word processor operators may be required to wait in line.
- Terminals are less "user friendly". That is, the users of terminals must follow certain procedures for using the central computer.
- The printers used for data processing applications are of poor quality. However, this can be overcome by installing a letter quality printer for word processing service.
Exercise

1. *Multiple choice questions*

a. A word processor consist of

i) 2 hardware components  
ii) 3 hardware components  
iii) 4 hardware components  
iv) 5 hardware components.

b. Which of the following hardware configurations are relatively easy to implement in the office environment.

i) shared-logic systems  
ii) stand-alone systems  
iii) shared-resource systems  
iv) time-sharing systems.

c. Better response time and higher reliability of operations are provided by

i) shared-resource systems  
ii) shared-logic systems  
iii) distributed-logic system  
iv) time-sharing system.

d. A terminal containing own processor and memory is called

i) dumb terminal  
ii) intelligent terminal  
iii) virtual terminal  
iv) CRT terminal.

2. *Analytical questions*

a. Describe stand-alone and shared-resource systems.

b. Point out some of the advantages of shared-logic system over multiple stand-alone system.

c. What are the drawbacks of a shared-logic system?

d. Describe the advantage and disadvantages of time sharing systems.

e. What do you mean by a dumb terminal and intelligent terminal?
Lesson 3: Reprographics

Learning Objectives

On completion of this lesson you will be able to learn:

- what is reprographics
- the related technology that make-up reprographics.

Reprographics

A group of technologies such as photo-composition, phototypesetting and electronic printing/intelligent copying are used for the rapid printing and copying of the output of office automation systems. Fig. 2.6 illustrates this fact.

![Reprographics Technologies Diagram]

Fig. 2.6: Reprographics technologies used in creating a sales manual.
Photo-composition

Printing a written document first involves photo-composition of text. Photo-composition is the process of giving a series of typesetting commands regarding character size, font, indentation, and tabulation; special characters; design and placement of graphics. In other words, creating documents for reproduction by means of photographic characters onto film. Photo-composition commands can be incorporated into an ordinary word-processing file. The file is then either directly transmitted to a photo typesetter electronically or transported on disk.

Phototypesetting

The next step in producing a printed document is photo typesetting. At first, we have to know what typesetting is. Typesetting is the process of creating high quality letter forms. Phototypesetting is a photographic process that imprints a document onto a printing plate. Phototypesetting was invented in the 1920s. The advantage of word-processing photo-composition plus phototypesetting include saving in time and money since they eliminate the need to go outside to produce typeset copy. In addition, the resulting copy is neater in appearance and holds about twice as much information per page, which also is an advantage on distribution and mailing cost.

Electronic Printer

The final step in producing a printed document is the actual printing itself. An electronic printer is a multiple-use device that can print directly from word processing files; transmit, receive and print electronic mail; print computer output remotely; perform standard photocopying. Electronic printers usually copy and print at medium speeds (35 to 50 pages per minute), produce medium quality printed text and is very expensive.
Exercise

1. Multiple choice questions

a. Creating documents for reproduction by means of photographic characters onto film is called

i) phototypesetting
ii) photo-composition
iii) electronic printing
iv) electronic filing.

b. Phototypesetting was invented in the

i) 1900s
ii) 1905s
iii) 1910s
iv) 1920s.

c. An electronic printer usually copy and print

i) 5 to 15 pages per minute
ii) 15 to 20 pages per minute
iii) 35 to 50 pages per minute
iv) 35 to 50 pages per second.

2. Analytical questions

a. What are the related technologies that make up reprographics? Describe in brief.
b. What are the functions of an electronic printer?
Lesson 4: Electronic Mail and Electronic-Filing

Learning Objectives

On completion of this lesson you will be able to:

- describe major advantages of electronic-mail (e-mail) over conventional communications
- know what e-mail is
- know about basic aspects of an e-mail system and its advanced features
- know what electronic-filing is
- find out the advantages of electronic-filing over conventional filing.

Electronic Mail

Electronic mail is a system that delivers messages at electronic speed. In an organization with this capability, employees can send and receive messages over long distance in minutes or seconds. Electronic mail (e-mail) is a system which allows messages to be sent between computers. A message can be sent either to an individual or to any number of individuals who have access to the same network. In recent years, e-mail systems have been used increasingly to improve the timeliness, control and effectiveness of communication in modern offices. e-mail system has occupied a pivotal place in modern information technology. It has brought revolutionized changes in official/organizational communication and is significantly replacing the traditional communication media. It has brought cognitive, affective and behavioral impact upon the members of office. Interdepartmental integration and coordination within the office is greatly facilitated by computer-based communication system. In any office, e-mail is an effective means of communicating with right person at the right time.

One major advantage of e-mail over the telephone is that receiving party does not have to be present to receive the mail; the message is stored for future retrieval. Other advantages are as follows:

- One to many communication is simple and easily achievable
- Using e-mail, people can work at home or travel while maintaining needed contact with their peers, superiors and subordinates
- It is very fast
- A message can be sent to many people at once
- It also leaves a written copy of messages that can be filed away or forwarded.
E-mail is convenience to busy executives, who are often pressed for time but need to communicate efficiently.

Early forms of e-mail include telex, telegrams and mailgrams. The current technology is in two areas, networks of communicating word processors and computerized message switching (CMS). Word processors may be interconnected through telecommunication links which allow word processing files to be transmitted to remote locations. In this case, word processors serve as a part of e-mail system.

In CMS (Computerized Message Switching) system electronic messages are sent over a computer network from a sender's standard CRT to a recipient's computer where they may be read immediately on a CRT or stored. Communicating Word processor is a stand alone word processor that is linked to another stand alone (a shared system) or a large computer through communications links.

## Basic Aspects of e-mail

Let us now briefly describe some basic aspects and services of e-mail system.

### Composition

It refers to the process of creating messages and answers-e.g. when answering a message, the mail system can extract the originator's address from incoming mail and automatically inserts it into the proper place in the reply.

### Transfer

It refers to moving messages from the originator to the recipient. The mail system should do this completely automatically, without bothering the user.

### Reporting

Reporting has to do with telling the originator what happened to the message. Was it delivered? Was it rejected? Was it lost?

### Conversion

It may be necessary to make message suitable for display on the recipients terminal or printer.

### Formatting

It pertains to the form of displayed message on the recipients terminal. If the input file were to be transmitted by e-mail it would have to be reformatted at the receiving end to give it desired appearance.
Office Automation Tools and Technology

**Decomposition**

It is the final step and concern what the recipients does with the message after receiving it. Possibilities include throwing it away immediately, reading it first then throwing it away, read it then saving it and so on.

In addition to these basic services, an e-mail system generally provide a large variety of advanced features. Let us briefly mention a few of these.

- When the people move or when they are away for some period of time. They may want their mail forwarded so the system should be able to do this automatically.
- If some one has decided to take a vacation for a few weeks, he may not want his mail forwarded. Instead, he may want the mail system to send a canned reply to the originator of each incoming message saying that he is away and telling when he will return.
- Most mail systems allow users to create mailboxes to store incoming mail.
- When a message is sent to the distribution list (a list of e-mail addresses), identical copies are delivered to every one on the list.
- Registered mail is another idea to allow the originator to know that his message has arrived. Alternatively, automatic notification of undeliverable mail may be desired.
- Other advanced features are carbon copies, high priority mail, secret encrypted mail, alternative recipients if primary one is not available and the ability for secretaries to handle their boss’s mail.

**Electronic Filing**

Electronic filing is a technology for entering and storing documents for retrieval in the future. The major advantages of electronic filing over conventional filing are that the physical space demands are reduced and retrieval is more rapid, systematic, well-indexed or orderly.

The use of electronic filing is as follows:

- The first use is to access and display customer information to reply customer inquiries.
- Another use in correspondence files, where the indexing system allows ready review of selected portions of correspondence e.g. all memos written to a particular individual during a specified time period.
Exercise

1. Multiple choice questions

a. Electronic mail is a system that delivers massages at
   i) typing speed
   ii) printing speed
   iii) electronic speed
   iv) processing speed.

b. One major advantage of e-mail over telephone is that
   i) sending party does not have to be present
   ii) receiving party does not have to be present
   iii) receiving and sending party does not have to be present
   iv) both party have to be present.

c. Registered mail is an idea to allow the originator to know that
   i) his message has not arrived
   ii) his message has arrived
   iii) his message has been received
   iv) his message has been sent.

d. What do you mean by CMS?
   i) Central Message System
   ii) Computerized Message Switching
   iii) Central Message Switching
   iv) Computerized multi-tasking System.

2. Analytical questions

a. What is the main advantages of e-mail over conventional communication?

b. Point out the advantages of e-filing over conventional-filing.

c. What are the basic aspects of e-mail system? Briefly describe.

d. What do you understand by electronic filing? Point out some of the uses of electronic filing.
Lesson 5 : Facsimile Transmission and Micrographics

Learning Objectives

On completion of this lesson you will be able to:

- know what facsimile transmission is
- describe different types of facsimile system and their uses
- describe micrographics.

Facsimile Transmission

Facsimile transmission is a technique that records an electronic picture of an entire page of a document on a facsimile unit and transmits it to another facsimile terminal at a remote location. Most often the user establishes a network connection between a facsimile transmitter and receiver by telephone dialing. Facsimile systems use synchronized scanning at the transmitter and receiver ends. The original document is placed around a drum in the facsimile machine and scanned line by line. The resulting electrical signals are transmitted over telecommunications line to the distant receiving stations. Here they are duplicated either on paper or film. This system enables a precise reproduction of the original document. There are two kinds of facsimile systems, namely analog and digital.

Analog System

In an analog system, the scanner moves across the document reading every part of it and each scanned element is converted into an electrical signal.

Digital System

In a digital system, the scanner reads only the part that contains information and does not read blank spaces. The images are converted into short, binary signals (in series of pulses). Digital facsimiles are much faster than analog systems.

Facsimile are used to transmit high resolution graphical images such as photograph and signatures. So facsimile machines are distinct from other automated technologies in that they provide exact, and high resolution reproduction. There are two types of facsimile equipment.
• Convenience unit: It is capable of sending a business letter in about one minute and it can also receive incoming documents.
• Central unit: It functions at higher speeds, transmitting a business letter in less than 30 seconds, can often send and receive documents automatically i.e. without operator intervention.

Some common uses of facsimile are the transmission of military and law enforcement communications, sales orders, business contracts, engineering drawings, internal memos, news photos, weather information (such as transmitting weather maps to ships and planes) and graphics. It may also be used for medical purposes, e.g. for cancers treatment at a group of geographically dispersed hospitals.

The use of facsimile is not new. However, computer-linked facsimile networks are new and are playing an important role in office automation.

**Micrographics**

Micrographics is the production, storage and retrieval of miniaturized information on films, referred to as microfilms. In the automated office, it serves a variety of functions and is integrated with many other technologies.

In other words, micrographics refers to the technology by which images of text are photographically reduced and stored on films. The processed outputs are often called "microforms". Large volume of information can be stored in a relatively small area. Microform readers can be used to display the information (for reading) as well as to produce printed outputs. Two kinds of microforms are popular: microfilm and microfiche. A microfilm is a continuous roll of film, either 16 mm or 35 mm. Microfiche is a sheet of film, usually 4 inches by 6 inches. The number of pages of text that can be stored in each frame of microfilm or in a microfiche depends on the degree of reduction. The reduced images are arranged in sequence in case of microfilm and in the form of rows and columns in case of microfiche as shown in Fig. 2.7.
A more recent equipment is the computer output microfilm (COM). A computer output microfilm equipment integrates computer and microfilm technologies. A document is read (or keyed) into the computer and a microfilm recorder receives the output information either directly from the computer (on-line mode) or through a tape drive (off-line mode) shown in Fig. 2.8.

The recorder displays the information as characters on a screen. A high speed camera takes a picture of the displayed information. The film is processed either in the recorder itself or in a separate automatic film developer. The COM recorder thus becomes an alternate to paper printer as a way of producing output. Film may be in the form of roll or microfiche. Film duplicators can be used to make as many copies of the developed film as needed.

The information on a film or microfiche is read by users using microfilm viewing devices either manually or with the help of a computer. In the computer assisted retrieval (CAR) the user can simply ask for a particular
page and the computer finds it and displays it on the screen. If the paper copy of the document is needed, a reader-printer is used to provide printed outputs.

Although the initial cost of such equipment is very high, the cost of film is relatively cheaper and the system provide relatively fast output. A single COM recorder can produce an output of roughly ten line printers.

Fig. 2.8 : A schematic diagram of COM production system.

One common use of micrographics is automated filing. This is accomplished with an automated microfilm reader / printer. Another uses of micrographics is as a computer output microfilm device for word processing or electronic mail.
Office Automation Tools and Technology

Exercise

1. Multiple choice questions

a. Exact and high resolution reproduction are provided by

i) e-mail
ii) micro-graphics
iii) facsimile
iv) e-filing.

b. Digital facsimiles are

i) much faster than analog systems
ii) slower than analog systems
iii) same as analog systems
iv) none of the above.

c. The facsimile equipment may be divided into

i) 2 types
ii) 3 types
iii) 4 types
iv) 5 types.

d. Central unit of facsimile equipment is capable of transmitting a business letter in

i) less than one minute
ii) less than 20 seconds
iii) less than 30 seconds
iv) more than 30 seconds.

e. Microforms are the

i) processed input
ii) processed output
iii) printed output
iv) incomplete output.
Office Automation

f. CAR stands for
   i) Computer Address Register
   ii) Computer Assisted Retrieval
   iii) Computer Aided Retrieval
   iv) Central Address Register.

g. COM stands for
   i) Computer Output Microfilm
   ii) Computer Output Microfiche
   iii) Computer Oriented Microfilm
   iv) Computer Originated Mail.

2. Analytical questions

a. What is facsimile transmission?
b. Describe different kinds of facsimile system
c. What is micrographics?
d. What do you understand by COM? Describe it briefly.
e. Draw the schematic diagram of COM reproduction system.
f. How information on film or microfiche can be read?
g. Point out some of the uses of micrographics.
Lesson 6 : Voice Technology

Learning Objectives

On completion of this lesson you be able to :

- describe distant computerized voice technology used in the automated office
- know the benefits of teleconferencing and computerized teleconferencing
- describe video conferencing.

Voice Technology

In the automated office, voice technology includes standard and centralized dictation, digital voice and teleconferencing.

Standard Dictation

Standard dictation is the recording of voice messages into a recording unit for transcription at a later time. In the automated office, transcription may involve entering the material into word processing or e-mail systems. In the future dictated message will probably be directly and automatically converted into finished products via an advanced word processing system. However, the technology to achieve this is only in the research stage at present.

Centralized Dictation

Centralized dictation is a system that can simultaneously receive dictation from a number of locations, each on a different recording unit. In large centralized systems, users can dial in from remote locations and dictate by touching the appropriate touch-tone keys and then speaking into a device. Dictation enhances the automated office by speeding the input information and by offering users an alternative way of entering information into an office automation system.

Digital Voice

Digital voice is the recording of voice messages in digital form so that they can be stored in a memory device, like any other computerized data for future uses and multiple copies of voice messages can easily be produced and sent to a number of recipients.
Teleconferencing

Teleconferencing is the use of digital technology to hold conferences that exchange digital voice and/or written information carried out on computer systems and or communicating word processors linked together into network.

Teleconferencing refers to the meeting of people who are geographically separated but are all participating in discussions through a telecommunications system. The system uses two-way voice, text or video communication equipment to allow people to interact over wide distances in real time. A number of offices/organizations are using this method to conduct important meetings with their executives scattered all over a region. For instance, a hotel in US which has a chain of branches offers a network for teleconference service. Conference speakers can go to their local branch and participate in discussions with the speakers at other branches. Participants in the teleconference can, using either digital plotters or facsimile transmitters, literally pass papers back and forth to one another as they talk, argue and debate the important points.

Although there are certain obvious advantages in face-to-face meeting, teleconference offers a number of benefits.

- Cost of travel and stay of people is eliminated
- No time is lost in travel
- No fatigue and no loss of energy
- Risk and uncertainty of public transport are avoided

Computerized Teleconferencing

A computer based teleconference is referred to as computer teleconferencing. A computer conference can be seen as something halfway between a conventional conference and a rapidly published newsletter. The system can be used by hundreds of people at diverse geographical locations. Each participant must have an access to a computer terminal connected to the conference network. Since the conference dialogue may be stored, it's not necessary for all participants to be on-line at their PCs or terminals at the same time. And, of course, it is also not necessary that they may be physically present at the same place. Instead, a person can sit at the terminal/workstation at a convenient time during the day, call up any messages/conversations, respond to questions and then sign off. Several conference participants can "talk" at the same time. Once again, interruptions of other important work can be avoided.
Office Automation Tools and Technology

The system has a database containing a large number of text messages. A message might be a letter or a conference entry and is entered by a member of the computer conference. Each member normally reads all that is written in the conference. He can freely write messages into the conference which are then made available to the other members of the conference.

The computer maintains a permanent history of all conference discussions. It therefore remembers which message each user has already seen. When a terminal is switched on, it displays all the entries which have not been seen. The user can directly write his or her own comments and messages which will be stored in the conference database.

Computer conference networks are increasingly used in developed countries. Many private and government agencies offer membership on their networks. For example, New Jersey Institute of Technology in US provides conference facilities on their network called Electronic Information Exchange System. Subscribers are grouped topic-wise such as technology, economics, etc. A subscriber may belong to more than one group. Another system known as COM designed by Stockholm University in Sweden supports two languages, Swedish and English. The Swedish-language system has more than 1000 subscribers taking part in various conferences. The English-language system has about 500 members from a dozen countries spread over three continents.

Computerized teleconferencing offers a number of advantages. Some of them are:

- A person can take part in many on-going conferences using much less time than for face-to-face meetings.
- User can read and write at a time suitable to himself or herself.
- User need not wait for a scheduled time to take up a problem. He can communicate on any day or as and when a problem comes up.
- Messages are well prepared.
- Messages of less importance can be skipped.
- An issue or a problem could be addressed to a large group of people for their comments and suggestions. It is possible to consolidate the suggestions within a day or two.
Office Automation

- Since it does not involve any travel and stay, it not only saves money but also encourages even less interested people to participate.

- People with different mother-tongues find it easier to understand written messages than spoken ones. They can take their time to read.

**Applications of Computer Conference**: There is a lot of scope for using computer conferences in government and business organizations. Typical applications could be:

- Periodic meetings of heads of branch offices or units of large organizations.

- Routine discussions among various government officials.

- Exchange of experiences between experts in a particular topic of interest, say, energy, office automation, semiconductor technology, etc.

- Collection of comments and ideas on a proposed new policy.

- Meetings of numerous committees whose members are placed in different locations.

- Company sales conferences.

- Flashing out an idea for reactions before starting serious discussions.

It is essential to note that the computer conference is not a replacement for all face-to-face meetings. Facial expressions and "body language" can convey important meanings that might be missing in computer conferencing. Further, certain tasks which might include complex negotiations and a series of question-answer sessions require face-to-face meetings for fast and immediate decisions.

**Videoconferencing**

Computer conferencing permits people to participate at different times, but an alternative to computer conferencing is **videoconferencing** - a term that refers to the electronic linking of geographically scattered people who are all participating at the same time. Facsimile devices, electronic blackboards that can cause chalk marking to be reproduced on distant TV monitors, desktop picture phones. These and other technologies allow people to meet at a common time and communicate over wide distances. Of course, there are advantages in face-to-face meetings that
videoconferencing can not replace. Facial expressions and body language can convey information that might be missed with videoconferencing. But time, energy, and money are saved when people do not have to travel long distances to attend a meeting.

**Summary**

Office automation technology today presents a variety of options to suit almost every organizational function. With the continuous reduction in processing and storage costs, office automation is expected to receive a major thrust in all organizations in the coming years. The availability of local area and public data networks will enhance the capabilities of office further and will improve the intra-organization communications. Word processing is by far the most widely used of technologies. Other more advanced and highly sophisticated office automation technologies include reprographics, e-mail, facsimile transmission, micrographics and voice technologies. To date, firms that have availed themselves of these technologies tend to be either large, research intensive, or both. This is because of the enormous volume of usage required to make the investment cost-effective. As costs decline and the equipment becomes increasingly more versatile, these technologies will inevitably be adopted in smaller organizations and offices.

A study of 26 US firms in advanced office automation environments found that 93% of their employees, in a wide range of job categories, used a computer and other automated technology on the job or expected to use in the near future. The study also found high levels of employee satisfaction with results of office automation.
Exercise

1. Multiple choice questions

a. Digital voice is the recording of voice messages in
   i) analog form
   ii) digital form
   iii) written form
   iv) printed form.

b. Centralized dictation is a system that can simultaneously
   i) send dictation
   ii) receive dictation
   iii) transform dictation
   iv) change dictation.

c. Which of the following has a database containing a large number of text messages?
   i) Teleconferencing
   ii) Computerized teleconferencing
   iii) Digital voice
   iv) Micrographics.

d. Which of the following two languages are supported by COM developed by Stockholm university?
   i) French and English
   ii) Swedish and English
   iii) Arabic and English
   iv) English and Bengali.

e. The COM system of Stockholm university using English language has about
   i) 500 members from a dozen countries
   ii) 1000 members from a dozen countries
   iii) 1500 members from a dozen countries
   iv) 2500 members from a dozen countries.

2. Analytical questions

a. What are the benefits of teleconferencing?
b. What do you know about computerized teleconferencing?
c. Point out some of the advantages of computerized teleconferencing.
d. What are the advantages of digital voice?
e. What do you know about video conferencing?
Unit 3: Microsoft Word and Basics of Word processing

Introduction

A word processor is a software package that turns your personal computer into a machine that will "process words." MS Word, Word Perfect, Word Star are the examples of word processor packages. In this unit you will know word processing using MS Word. You will also learn different topics on file management. You will learn the details of creating, opening, saving, closing documents and starting or quitting Word. You will also learn the use of "Find" file command on the File menu to locate document or preview documents before printing and to open, delete, copy, print or move several documents simultaneously in lesson 2. You will use the print preview command to preview document before printing and use print command to print your active document. You will familiar to various powerful commands and learn how to use some of their more advanced features in the last two lessons.

Lesson 1: Basic File Operations

Learning Objectives

On completion of this lesson you will be able to learn:

- how to start Microsoft Word
- how to create a new document
- how to open a file
- how to save a file document
- how to close a document
- how to exit or quit MS Word.

Starting MS Word

MS Word works under MS Windows and you can quickly start Word from the MS-DOS command prompt if you are working in MS-DOS.

1. At the command prompt, type **win** and Press ENTER.
2. From the Program Manager window, click MS Word/MS Office group icon.
3. From the MS Word/MS Office Window, double -click or use the arrow keys to select and then press ENTER.

*Note: The starting process may differ from computer to computer.*
Creating a New Document

When you start Word, a new blank document appears on your screen. Word temporarily assigns it the name Document 1. If a new document using default settings is what you want, just start typing.

a) Using File menu:
   1. From the File menu, choose New. At this time the following New dialog box will appear.

b) Using the Standard toolbar:

You can create a document quickly with the Normal template by clicking 📁

Opening Document

Here you will learn how to open (retrieve) a file.

Note: The terms file and document are two different ways of looking at the same thing. When referring to a text object on your screen, we call it a document when referring to this same text object stored on a disk we call it a file.
a) Using the file menu:

1. From the file menu, choose Open or **Click**. Then the following open dialog box will be displayed.

![Open dialog box](image)

2. Select the name of the file from the File Name box.
3. If you do not see the file then select the desired drive from the Drives list box and directory from Directories list box.
4. Choose OK button or double click on the desired file.

b) File opening short cut (short-cut method):

Word also provides a convenient file opening short-cut, it keeps track of the last four files that you worked on and displays their names at the bottom of the drop down file menu. To open one of these documents, simply choose File and click on the desired document name.
Saving a Document

When you open a document, Word copies it from the disk and displays it on your screen. Changes made to the document are stored temporarily in the computer’s memory. To keep the changes permanently, you must save the document on a disk.

a) To save a document

- From the File menu, choose Save, or click .

b) To save a new, unnamed document :

1. From the File menu, choose Save As or click . Then the following save dialog box will appear.
2. Do one of the following:

<table>
<thead>
<tr>
<th>To save the document</th>
<th>Do this</th>
</tr>
</thead>
<tbody>
<tr>
<td>On the current drive and in the current directory</td>
<td>Type a name in the File Name box.</td>
</tr>
<tr>
<td>On a different drive and in a different directory</td>
<td>Select a different drive or directory. Or type the complete location and filename in the File Name box.</td>
</tr>
</tbody>
</table>

3. Choose OK button.

c) To save all open documents:
   - From the File menu, choose Save All.

   **Note:** If any open documents have not been saved before, Word displays the Save As dialog box so that you can name them.

### Closing a Document

When you finish working on a document, close it to free up memory. You can quit Word when you finish working on documents.

a) Using the File menu
   - From the File menu, choose Close.

   **Note:** If a document has changes that you have not saved, Word asks if you want to save the changes before closing. See the following dialog box.
If you choose the Yes button but have not named the document, Word displays the Save As dialog box, type file name, choose OK. If you choose the No button the document will be closed without saving the document.

b) Using the mouse

You can double-click the document control-menu box in the upper-left corner of the document window to close a document. See the following figure.

Quitting Word

When you quit word, Word closes all documents. If you have not saved changes to one or more of the open documents Word asks if you want to save the documents before quitting.

To Quit Word:
Double click the Word control menu box or choose Exit from the file menu.
Hands on Practice

1. a) Start MS Word.
   
   b) Create a document with Normal template and type the following:

   School of science and Technology offers Diploma and Advanced Diploma in Computer Applications. The aims of the Diploma programs are to train personnel to meet the recent increasing demand in the computer field. The objective of the programs are to develop skills in:

   o computer and its areas of application

   o computers for office automation, DTP, computer programming and software development.

   c) Save the document as Bou.doc.

   d) Close the Bou.doc.

   e) Exit from MS Word.

Practice the Following

1. a) Open a file using short-cut method.

   b) Close a document using the mouse.
Lesson 2 : Locating and Managing Documents

Learning Objectives

On completion of this lesson you will be able to learn

- how to search documents
- how to view and edit information
- how to manage files with find file commands.

Searching for Documents

The Find File command on the File menu helps you locate documents by searching a disk, directories, or folders for filenames or for specific words or phrases in the documents.

To search for documents:

1. From the File menu, choose Search.
   Word does one of the following:

   a) The first time you use search, Word displays the Search dialog box, as shown below:
b) If you've used search at least once before, Word uses the last search criteria you specified. Choose the Search button.

2. Type a file name or select a type of file.
3. Select the drive, type desired paths in the Location box,
4. Select the Include sub-directories check box, to search all sub-directories of the selected directory.
5. Choose the OK button.
6. Choose the Close button.

*Note:* For specifying more complex criteria, choose the advanced search button.

To search for documents by using advanced search criteria:
1. From the File menu, choose Find File.
2. In the Find File dialog box, choose the Search button.
3. Choose the Advanced Search button, and then do one or more of the following:
   
a) To search by location, select the Location tab. To search by filename, type the name in the File Name box. To search by file type in the File Name box. To search a directory that is not listed in the Search In box, select the directory in the Directories box, and then choose the Add button. To delete a directory from the Search In box, select it and then choose the Remove button. To remove all directories from the Search In box, choose the Remove All button. To search all sub-directories of the selected directories, select the Include Sub-directories check box.

b) To search by summary information or content, select the Summary tab. Type the summary desired information.

c) To search for the date a file was created or last saved, select the Timestamp tab. Type the range of dates during which the file was created or last saved. In the by box, type the name of the person who created or saved the file.

4. Choose the OK button.

5. In the Search dialog box, choose the OK button.

6. Choose the Close button.

Chatbot: Previewing Documents and Viewing

You can preview the contents of documents or view information about a document such as its size, last modification date and its summary information.

To view and edit summary information:

1. From the File menu, choose Find File.

2. In the Listed Files box, select the file whose summary information you want to view.

3. In the View box, select Summary.

   a) For editing, choose Command button
b) Choose Summary  
c) Choose the OK button  
4. When you finish viewing or editing summary information and choose the Close button.

**Note:** For viewing file information or previewing a file follow the procedure described above, except step3, select file info or preview.

To select multiple files in the Find File dialog box:
1. From the File menu, choose Find File.  
2. In the Listed Files box, click the first filename you want to select.  
3. While holding down CTRL click each additional filename you want to select.

**Note:** To remove a filename from the selection, hold down CTRL and then click the filename.

**Managing Documents with Find File**

With the help of you can easily open, copy, print, and delete several files simultaneously without having to leave Word. To manage documents by
using the Find File command, first find the files you want to work with by specifying the appropriate search criteria. When Word displays the list of files, select the files you want to work with, and then select the appropriate options in the Find File dialog box.

To manage files with the Find File command:

1. From the File menu, choose Find File.

2. In the Find File dialog box, select the desired file or files.

3. To open the files normally, choose the Open button. To perform other tasks, choose the Commands button, and then choose the appropriate command to do one or more of the following:

<table>
<thead>
<tr>
<th>To do</th>
<th>Do this</th>
</tr>
</thead>
<tbody>
<tr>
<td>Open a file as read only</td>
<td>Choose Open Read Only.</td>
</tr>
<tr>
<td>Print a file</td>
<td>Choose Print, select the desired options and then choose the OK button.</td>
</tr>
<tr>
<td>View and edit summary</td>
<td>Choose Summary, and then choose the Statistics button to view statistics.</td>
</tr>
<tr>
<td>information and statistics</td>
<td></td>
</tr>
<tr>
<td>Delete a file</td>
<td>Choose Delete.</td>
</tr>
<tr>
<td>Copy a file</td>
<td>Choose Copy. In the Directories and Drives boxes, select the desired location. Then choose the OK button.</td>
</tr>
<tr>
<td>Sort files</td>
<td>Choose Sorting, and then select the option desired.</td>
</tr>
<tr>
<td>Create a new directory or folder</td>
<td>Choose Copy, and then choose. The New directory button.</td>
</tr>
</tbody>
</table>

Hands on Practice

1. a) Open Bou.doc [Hands on Practice: Lesson 1, Unit 3]  
   b) Create a new sub directory named SST.  
   c) Save Bou.doc to SST sub-directory  
   d) Search win.exe  
   e) Search autoexec.bat.  
   f) Search findvirus.exe  
   g) Search Bou.doc  
   h) Save Bou.doc as Bou1.doc.

2. a) View the summary information of Bou.doc  
   b) Preview Bou.doc

3. a) Sort all the files in SST sub-directory.  
   b) Copy Bou.doc to a floppy diskette.  
   c) Delete Bou1.doc  
   d) Select all the files in SST sub-directory.

Practice the Following:

- Search for documents by using advanced search criteria.
Lesson 3: Previewing a Document Before Printing

Learning Objectives

On completion of this lesson you will be able to learn

- how to preview a document before printing
- how to edit text in print preview
- how to move margins in print preview.

Previewing a Document Before Printing

Print preview provides a miniature view of how a document will look when it is printed. You can use print preview to examine and adjust the layout of a document before actually printing it. You can edit text, control the placement of text on the page by changing the margins, print active document & view two or more pages at a time.

Print Preview Toolbar.

To preview a document before printing:

1. From the File menu, choose Print Preview or Click . Then the following figure will appear.

   ![Print Preview Toolbar]

   ![Previewing a Document]

   ![Previewing a Document]

   Note: Word repaginates the document so that the page numbers are correct, and then it displays one or more pages, including the page that contains the insertion point.
2. To view different pages in the document, do any operation you desire from the view Table.

3. Click  to print the document or click the Close button to exit print preview.

<table>
<thead>
<tr>
<th>To</th>
<th>Do this</th>
</tr>
</thead>
<tbody>
<tr>
<td>Display one page at a time.</td>
<td>Click [Image]</td>
</tr>
<tr>
<td>Display two or more pages at a time.</td>
<td>Click [Image] and then drag over the grid to select the number and configuration of pages.</td>
</tr>
<tr>
<td>View a magnified area of the document.</td>
<td>Move the mouse pointer to the location you want to view and then click the mouse button. To return to the original magnification, click the mouse button on the toolbar.</td>
</tr>
<tr>
<td>Reduce or enlarge the page(s) displayed.</td>
<td>Click the down arrow next to the Zoom Control box, and select a magnification or type a percentage.</td>
</tr>
<tr>
<td>Hide all screen elements except the displayed page(s) and the Print Preview toolbar.</td>
<td>Click [Image]. To return the hidden elements to the screen, click the button again, or press ESC.</td>
</tr>
</tbody>
</table>

Table : View

Editing Text in Print Preview

To edit text in print preview:
1. In print preview, display the desired page.
2. Move the mouse pointer over the document.
   
   Note: If the pointer does not resemble a magnifying glass, click the left mouse button.
3. Click the desired location in the document.
4. Click \[ \text{I-beam pointer} \] to restore the I-beam pointer, and then edit the document.

5. Click \[ \text{original magnification} \] and then click in the document, to return to the original magnification or click \[ \text{print document} \], to print the document or click the Close button to exit print preview.

Moving Margins in Print Preview

To move margins in print preview:

1. Click \[ \text{rulers} \] if the rulers are not displayed.
2. Do one of the following:

<table>
<thead>
<tr>
<th>To</th>
<th>Do this</th>
</tr>
</thead>
<tbody>
<tr>
<td>Move the left or right page margin.</td>
<td>Drag [ \text{horizontal ruler} ]</td>
</tr>
<tr>
<td>Move the top or bottom page margin.</td>
<td>Drag [ \text{vertical ruler} ]</td>
</tr>
</tbody>
</table>

3. Choose \[ \text{print document} \] to print the document or choose the Close button to exit print preview.
Office Automation

**Hands on Practice**

1. a) Preview a document.  
   b) Display two pages at a time.  
   c) Reduce or enlarge the page(s).  
   d) Return to single page view.

2. a) Move the Left margin to 1.5" position.  
   b) Move the Right margin to 6.5" position.  
   c) Move the top margin to 1".  
   d) Close the print preview window.
Lesson 4 : Printing Documents

Learning Objectives

On completion of this lesson you will be able to learn

- how to select the printer
- how to control the printing of your documents
- how to create and print envelope.

Selecting the Printer

To select the printer :

1. From the File menu, choose Print
2. From the Print dialog box, choose Printer button. Then the following Print Setup dialog box will appear.
3. Select a printer from the list in the Printers box.
4. Click the Set As Default Printer button.
5. Click the Close button.

Controlling the Printing of your Documents :

The Print command controls how a document is printed. Before using this command, you must install and select a printer.

To Control the printing of your documents :

1. Select the file or text to be printed.
2. From the file menu, choose Print. See print dialog box.

3. Choose the desired Print options from print option table.
4. Choose OK button.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Printer</td>
<td>Displays the name of the active printer and the printer connection.</td>
</tr>
<tr>
<td>Print What</td>
<td>Select the type of information you want to print. Default choice is the current document.</td>
</tr>
<tr>
<td>Copies</td>
<td>Type or select the number of copies you want to print.</td>
</tr>
<tr>
<td>Page Range</td>
<td><strong>Specify the pages you want to print.</strong></td>
</tr>
<tr>
<td>All</td>
<td>Print the entire document.</td>
</tr>
<tr>
<td>Current Page</td>
<td>Print the selected page or the page containing the insertion point.</td>
</tr>
<tr>
<td>Selection</td>
<td>Print only the selected text.</td>
</tr>
<tr>
<td>Pages</td>
<td>Print specified pages and type page numbers separated by commas, or a range of pages with a hyphen between the page numbers. For example, to print pages 2, 4, 5, 6, and 8, type 2,4-6,8.</td>
</tr>
<tr>
<td>Print</td>
<td>Select the order in which you want the pages to be printed.</td>
</tr>
<tr>
<td>Print To File</td>
<td>Prints a document to a new file on the drive you specify instead of routing it directly to a printer.</td>
</tr>
<tr>
<td>Collate Copies</td>
<td>Organizes pages when you print multiple copies. Word prints a complete copy of the first document before it begins to print the first page of the second document.</td>
</tr>
<tr>
<td>Printer Options</td>
<td>Select a printer and a printer connection.</td>
</tr>
<tr>
<td>Options</td>
<td>Select additional printing options.</td>
</tr>
</tbody>
</table>

Table: Print options.
Creating and Printing an Envelope

Use the following procedure to print an address directly onto an envelope or to store an address in your document for printing later.

To create and print an envelope:

1. Select the desired delivery address, if the document contains more than one address.
2. From the Tools menu, choose Envelopes And Labels. Then the following Envelopes And Labels dialog box will be displayed.
3. Select the Envelopes tab.
4. In the Delivery Address box, accept the proposed delivery address or type the address to which you want to send the letter.
5. Accept the proposed return address in the return Address box or type an address, to print a return address or select the omit check box, if you do not want to print a return address.
6. Choose Options button. Then the following Envelope options dialog box will be found.
7. Select an envelope size from the Envelope size box.
8. Select Printing options tab from the Envelope options dialog box and select Feed method. See the following dialog box.

9. Choose OK button
10. Do one of the following:

<table>
<thead>
<tr>
<th>To</th>
<th>Do this</th>
</tr>
</thead>
<tbody>
<tr>
<td>Print the envelope</td>
<td>Insert the envelope in the printer as shown in the Feed box, and then choose the Print button.</td>
</tr>
<tr>
<td>Add the envelope as a separate section at the beginning of the document</td>
<td>Choose the Add To Document button.</td>
</tr>
</tbody>
</table>
Microsoft Word and Basics of Word Processing

document.

*Note:* On the Printing Options tab, make sure the selected feed method options are those recommended by your printer’s manufacturer.
Office Automation

**Hands on Practice**

1. a) Display the Print dialog box.
   b) Print Current page of a document.
   c) Print from page 2 through page 4 of a document.
   d) Print two Copies of the current page of a document.

2. a) Display Envelopes and labels dialog box.
   b) Type the following delivery address and Return Address:

   **Delivery Address:**
   To
   Douglas Hard
   Texas University
   Austin, USA.

   **Return Address:**
   From
   Professor T. H. Khan
   School of Science and Technology
   Bangladesh Open University.

   c) Select the envelope size as size 11.
   d) Print the envelope.

Unit 4 : Typing and Editing

Introduction

Typing and editing is the most important and powerful topics of MS Word. The more comfortable you feel moving around within a document, the more you will be able to concentrate on the contents of the document itself. This can be accomplished with the help of navigational techniques (moving insertion points, scrolling etc.). You will learn the navigational techniques and sophisticated ways of selecting text in first lesson. You will learn the Word's powerful editing features such as moving, copying, deleting text and the handy way of undo/redo in the 2nd Lesson. With Word Art you can create interesting text effects to enhance documents. With the help of Equation Editor, you can add fractions, exponents, integrals and other mathematical elements to a Word document. You will learn Word Art and Equation Editor also in the 2nd lesson. In the next lesson, we shall introduce you to Word's more advanced editing techniques such as (Finding and Replacing text, going to specific place etc.). Misspelling and grammatical mistakes can severely undermine the credibility of documents. The 3rd Lesson will introduce the tools that allow you to proof (check) your documents for potential spelling, grammar and style errors.

Lesson 1 : Moving Insertion Point, Scrolling and Selecting Text

Learning Object

On completion of this lesson you will be able to learn:

- how to move insertion point
- how to scroll through a document
- how to select text and graphics
- how to cancel the selection.

Moving the Insertion Point

The insertion point marks the location where the text will be inserted. The simplest way to move the insertion point is to use the mouse to position the I-beam pointer, and then click. The following figure clears what insertion point is?
Office Automation

a) To move the insertion point using the mouse:

1. Using the scroll bars, scroll until you reach the desired location.
2. Click the location where you want to position the insertion point.

b) To move the insertion point using the keyboard:

- See appendix.

Scrolling Through a Document

You can use the scroll bars at the right and bottom edges of the window to scroll through your document.

For Scrolling, you can do any one of the following:

<table>
<thead>
<tr>
<th>To</th>
<th>Mouse</th>
<th>Keyboard</th>
</tr>
</thead>
<tbody>
<tr>
<td>Scroll up one line</td>
<td>Click</td>
<td>UP ARROW</td>
</tr>
<tr>
<td>Scroll up one screen</td>
<td>Click above the scroll box in the scroll bar</td>
<td>PAGE UP</td>
</tr>
<tr>
<td>Move to an approximate location in the document</td>
<td>Drag</td>
<td>Not available</td>
</tr>
<tr>
<td>Scroll down one line</td>
<td>Click</td>
<td>DOWN ARROW</td>
</tr>
<tr>
<td>Scroll down one screen</td>
<td>Click below the scroll box in the scroll bar</td>
<td>PAGE DOWN</td>
</tr>
<tr>
<td>In page layout view, move to the same position on the previous page</td>
<td>Click</td>
<td>Not available</td>
</tr>
<tr>
<td>In page layout view, move to the same position on the next page</td>
<td>Click</td>
<td>Not available</td>
</tr>
</tbody>
</table>
Typing and Editing

<table>
<thead>
<tr>
<th>In normal view, scroll into the left margin, beyond the text area</th>
<th>SHIFT+</th>
<th>Not available</th>
</tr>
</thead>
<tbody>
<tr>
<td>Scroll left</td>
<td>Click</td>
<td>LEFT ARROW</td>
</tr>
<tr>
<td>Scroll right</td>
<td>Click</td>
<td>RIGHT ARROW</td>
</tr>
</tbody>
</table>

Selecting Text and Graphics

Before you can move, format, delete, or otherwise change text or a graphic you must select (block) the item. You can select using the mouse or keyboard; selected text or graphics are highlighted.

a) To select text and graphics using the mouse:
   do any one of the following:

<table>
<thead>
<tr>
<th>To select</th>
<th>Do this</th>
</tr>
</thead>
<tbody>
<tr>
<td>Any item or amount of text</td>
<td>Drag over the text you to select.</td>
</tr>
<tr>
<td>A word</td>
<td>Double-click the word.</td>
</tr>
<tr>
<td>A graphic</td>
<td>Click the graphic.</td>
</tr>
<tr>
<td>A line of text</td>
<td>Click in the selection bar to the left of the line.</td>
</tr>
<tr>
<td>Multiple lines of text</td>
<td>Drag in the selection bar to the left of the lines.</td>
</tr>
<tr>
<td>A sentence</td>
<td>Hold down CTRL and click anywhere in the sentence.</td>
</tr>
<tr>
<td>A paragraph</td>
<td>Double-click in the selection bar next to the paragraph, or triple-click anywhere in the paragraph.</td>
</tr>
<tr>
<td>Multiple paragraphs</td>
<td>Drag in the selection bar.</td>
</tr>
<tr>
<td>An entire document</td>
<td>Triple-click in the selection bar.</td>
</tr>
<tr>
<td>A vertical block of text (except within a table cell)</td>
<td>Hold down ALT, and then drag.</td>
</tr>
<tr>
<td>Extend an existing selection</td>
<td>Hold shift and click the existing beyond selection.</td>
</tr>
<tr>
<td>Shorten an existing selection</td>
<td>Hold Shift and click inside the existing selection.</td>
</tr>
</tbody>
</table>

b) To select text and graphics using key board.
   - See appendix
Office Automation

**Canceling a Selection**

For canceling a selection, you can do one of the following:

- Using the mouse, click anywhere in the document window.
- Using the keyboard, press any arrow key.
- Pressing the ESC key.
Typing and Editing

**Hands on Practice**

1. a) Open the file 'Bou.doc' [Hands on Practice: Lesson 1, Unit 3].
   b) Move the insertion point after the word "Diploma" using the mouse.
   c) Move the insertion point to the beginning of the document.
   d) Go to the end of the document.
   e) Move to one word left and right.
   d) Move to the end of the line.

2. a) Scroll up one line.
   b) Scroll down 2 lines.
   c) Scroll to the bottom of the document.
   d) Drag the vertical scroll box to scroll to the bottom of the document.
   e) Scroll to the same position of the previous page.
   f) Scroll to left one character at a time.

3. a) Open Bou.doc Hands on Practice: Lesson 1, Unit 3]
   b) Select 'science'.
   c) Point to left of the a in 'aims', select aims.
   d) Select the sentence containing aims.
   e) Select the first paragraph.
   f) Select the line beginning with 'School'.
   g) Select the entire document.
   h) Extend the selection to include first 2 lines. Shorten the selection to include the first 3 words.
   i) Select vertically to format the first letter of the document.
   j) Cancel the selection.
Lesson 2: Editing, Word Art and Equation Editor

Learning Objectives

On completion of this lesson you will be able to learn:

- how to delete text
- how to undo/redo your last operation
- how to move/copy text
- how to insert symbol in this text
- how to create a text effect with Word Art
- how to create an equation with Equation Editor.

Deleting

To correct simple typing mistakes, press BACKSPACE or DELETE. Depending on your computer, the key will delete either the text preceding or following the insertion point. To delete more than a few characters, it’s faster to select the text you want to delete and then press BACKSPACE or DELETE, or to choose Clear from the Edit menu.

To delete text and graphic, do one of the following:

<table>
<thead>
<tr>
<th>To delete</th>
<th>Do this</th>
</tr>
</thead>
<tbody>
<tr>
<td>Selected Text</td>
<td>Click ✂️, or press BACKSPACE or DELETE</td>
</tr>
<tr>
<td>Characters before the insertion point</td>
<td>Press BACKSPACE</td>
</tr>
<tr>
<td>Characters after the insertion point</td>
<td>Press DELETE</td>
</tr>
<tr>
<td>A word before the insertion point</td>
<td>CTRL+BACKSPACE</td>
</tr>
<tr>
<td>A word after the insertion point</td>
<td>CTRL+DELETE</td>
</tr>
</tbody>
</table>

Note: To restore deleted text:

- Click 🔄.
Typing and Editing

 Undoing Mistakes

If you make a mistake in Word, you can use 'Undo' / 'Redo' the command but can't Undo/Redo certain actions such as printing or saving a document.

To Undo / Redo your last operation:

a) To undo or redo the most recent action, click Undo or Redo button.

b) To undo or redo the multiple action, click the down arrow next to either Undo or Redo, and then select the actions you want to undo or redo. See the following figure.

![Undo and Redo buttons](image)

Note that multiple actions must be undone or redone in sequence.

Moving and Copying Text

You can move or copy any element in a document, whether that element is text, graphics, or an item you inserted from another application. ‘Moving’ means to remove (cut) the selected text from one location and insert it in another location. ‘Copying’ means to make a copy of the selected text and insert it in another location, leaving the original unchanged.

Drag-and-drop editing is the easiest way to move or copy a selection a short distance, but to move or copy a selection a longer distance, the Cut, Copy, and Paste commands are often more convenient.
Office Automation

a) Using drag-and-drop editing

To move text using drag-and-drop editing:

1. Select the text and graphics you want to move.
2. Point to the selected text.
3. Hold down the mouse button, when appears.
4. Drag the dotted insertion point to the New location.
5. Release the mouse button.

To copy text and graphics using drag-and-drop editing:

1. Select the text.
2. Hold down the CTRL key.
3. Point to the selected text and graphics.
4. Drag the dotted insertion point to the new location.

b) Using the standard toolbar

To move text using the Standard toolbar:

1. Select the text.
2. Click.
3. Position the insertion point in the new location.
4. Click.

To copy text using the Standard toolbar:

1. Select the text.
2. Click.
3. Position the insertion point in the new location.
4. Click.

Clipboard

Windows provides a temporary storage area called the clipboard for those times when you move/copy text. When selected text is cut (removed) or copied, it is placed on the clipboard. Pasting inserts a copy of the clipboard contents before insertion point. You will notice that paste button, resembles a clipboard. Entries remain on the clipboard, either until you cut or copy another entry to it or until you exit from windows.
Typing and Editing

c) Using Keyboard Shortcuts for Moving and Copying:

- See Appendix

**Inserting Symbols**

To insert symbols with symbol command:

1. Position the insertion point.
2. From the Insert menu, choose Symbol.
3. Select the font you want.
4. Double click the desired symbol.
5. To insert another symbol, position the insertion point in the document and repeat step 2.
6. Choose the close button.

**WordArt**

With WordArt, you can create interesting text effects to enhance documents. You can fit text into a variety of shapes, create unusual alignments, add 3-D effects, and so on.

**Creating or Editing a Text Effect with WordArt**

After starting WordArt in Windows, a text entry box and toolbar appear in the document window. You can use the text entry box to type or edit the text you want to include in the text effect. The toolbar contains options to change the appearance of the text effect.

To create a special text effect with WordArt:

1. Position the insertion point to add a special text effect.
2. From the Insert menu, choose Picture-> WordArt.
3. Choose the OK button.

Note: Word displays the WordArt toolbar, text entry box, and menu bar.

Menu bar

Tool bar

Text Entry

4. In the text entry box, type the text you want to format.
5. Select the text effect options you want from the WordArt menus and toolbar.
6. Choose the Update Display button to view the changes to the text effect in the document.
7. Click in Word document window to return to word or double click to edit the text.

Equation Editor

With the help of Equation Editor you can add fractions, exponents, integrals and other mathematical elements to a Word document. Equation editor applies most of the formatting for you, it applies superscript
Typing and Editing

format, reduces the font size of exponents, formats variables in italic, and adjusts spacing between elements. Let's look how to create an equation with equation editor

To create an equation with Equation Editor:

1. Position the insertion point where you want to insert an equation.
2. From the Insert menu, choose Object.
3. Under Object Type, select Microsoft Equation 2.0.
4. Choose the OK button.

Word displays the Equation Editor toolbar and menu bar. See the following:

5. Type text and choose symbols, operators and templates from the Equation Editor toolbar and menus.
6. Click in the Word document to return to word or double-click to edit the equation.
Hands on Practice

1. Type the following:

Clipboard

Windows provides a temporary storage area called the clipboard for those times when you move/copy text. When selected text is Cut (removed) or copied; it is placed on the Clipboard. Pasting inserts a copy of the clipboard contents before insertion point. You will notice that paste button, resembles a clipboard. Entries remain on the clipboard, either until you cut or copy another entry to it or until you exit from Windows.

2. a) Select "School of Science and Technology".
   b) Delete "School of Science and Technology".
   c) Restore the deleted text by clicking Undo button.
   d) Move the text beginning with 'School' to before 'Entries remain on the clipboard'.
   e) Copy the text of the entire document to the 2nd page of the document.
   f) Save the document as Emdad.doc.

3. a) Copy the Content of the Clipboard Paragraph to the end of the document using drag and drop editing.
   b) Move and Copy content of the 'Clipboard' to the top of page1 using the standard toolbar.
   c) Close the document.
   d) Save the document as Science.doc.

4. Create Special text effect as

a) SST
   b) SST
   c) Diploma in Computer
   d) Diploma in Computer
5. Create the following equation

a) \[ x = \frac{-b \pm \sqrt{b^2 - 4ac}}{2a} \]

b) \[ x = a \oplus b.c \]

c) \[ x = \begin{pmatrix} a & b & c \\ b & c & e \\ c & f & g \end{pmatrix} + \begin{pmatrix} 1 & 2 & 3 \\ 3 & 4 & 5 \\ 1 & 6 & 7 \end{pmatrix} \]

d) \[ \cos^2 \alpha + \sin^2 \alpha = 1 \]

e) \[ x = \sum_{i=1}^{n} X_i Y_i \]
Lesson 3 : Finding, Replacing and Moving Texts

Learning Objectives

On completion of this lesson you will be able to learn:

- how to find text in a document
- how to replace text in a document
- how to move in a document.

Finding Text and Formatting

You can use the Find command on the Edit menu to search for text, format such as bold and indents, special characters, and other elements such as footnotes, graphics, and fields. To search for and replace these items, you can use the Replace command. You can move directly to a specific place in a document, such as a particular page or bookmark, with the Go To command.

To find text and formatting:

1. From the Edit menu, choose Find. See the Find Dialog Box
Typing and Editing
2. In the Find What box, do one of the following from the find table:
3. Select any option in the search box from search table, if necessary.
4. Choose the Find Next button.
5. Choose the Cancel button or press ESC.

<table>
<thead>
<tr>
<th>To find</th>
<th>Do this</th>
</tr>
</thead>
<tbody>
<tr>
<td>Text without formatting</td>
<td>Type the text. If formats appear under the Find What box, choose the No Formatting button.</td>
</tr>
<tr>
<td>Text with formatting</td>
<td>Type the text. Choose the Format button, and then choose Font, Paragraph, Language, or Style. The formats you want, and then choose the OK button.</td>
</tr>
<tr>
<td>Formatting only</td>
<td>Delete any text in the Find What box. Position the insertion point in the Find What box, choose the Format button, and then choose Font, Paragraph, Language, or Style. Select the formats you want, and then choose the OK button.</td>
</tr>
</tbody>
</table>

Table: Find

<table>
<thead>
<tr>
<th>To search</th>
<th>select</th>
</tr>
</thead>
<tbody>
<tr>
<td>Search the main document, annotations, footnotes, endnotes, headers, and footers</td>
<td>All in the Search box (the default)</td>
</tr>
<tr>
<td>Search the main document only, up to the beginning or down to the end of the document from the insertion point</td>
<td>Up or Down in the Search box</td>
</tr>
<tr>
<td>Search part of a document</td>
<td>The part of the document you want to search</td>
</tr>
<tr>
<td>Find text with the same capitalization as the text in the Find What box</td>
<td>Match Case check box</td>
</tr>
<tr>
<td>Find whole words, not parts of words</td>
<td>Find Whole Words Only check box</td>
</tr>
<tr>
<td>Find text using multiple search criteria e.g. if c?t are given in find what box,</td>
<td>Use Pattern Matching check box</td>
</tr>
</tbody>
</table>
Typing and Editing

then cot, cat, cut, CST will be found.

Find words that sound the same as the search text but are spelled differently, such as ‘Katly’ and ‘Cathy’, and ‘colour’ and ‘colour’.

Table: Search

Replacing text

To replace text and formatting:

1. From the Edit menu, choose Replace. See Replace dialog box.

2. In the Find What box, type the desired text.

Note: You can also click the down arrow next to the Find What or Replace With box and select from the last four entries for which you searched.

3. In the Replace With box, type the replacement text.

4. Select any option in the search box from search table, if necessary.

5. Choose the Find Next button.
6. Do one of the following:

<table>
<thead>
<tr>
<th>To</th>
<th>Choose</th>
</tr>
</thead>
<tbody>
<tr>
<td>Replace the text or formatting and find next occurrence</td>
<td>The Replace button</td>
</tr>
<tr>
<td>Change all occurrences without confirmation</td>
<td>The Replace All button</td>
</tr>
<tr>
<td>Leave the text or formatting unchanged and search for the next occurrence</td>
<td>The Find Next button</td>
</tr>
</tbody>
</table>

7. Choose the Cancel or Close button, or press ESC.

Moving in a document

*(Go to a Page, Bookmark, Footnote, Table, Graphic, or other Location)*

To go to a page or specific place:

1. From the Edit menu, choose Go To. See Go to dialog box.

2. In the Go To What box, select the type of item.
Typing and Editing

3. Do any one of the following:

<table>
<thead>
<tr>
<th>To</th>
<th>Do this</th>
</tr>
</thead>
<tbody>
<tr>
<td>Location</td>
<td>Type the name or number of the item in the Enter box, and choose the Go To button</td>
</tr>
<tr>
<td>Move to the next or previous occurrence of the item.</td>
<td>Leave the Enter box empty, and then choose the Next or Previous button.</td>
</tr>
</tbody>
</table>

5. Choose the Close button or ESC.

*Note:* You can also display the Go To dialog box by double-clicking the page area of the status bar or by pressing the F5 key.
Hands on Practice

1. a) Open Science.doc [Hands on Practice: Lesson 2, Unit 4]
   b) Go to the top of page 2 and Type
      "The color of the cat is black. Rahim's cot is not good. Water has no colour".
   c) Bold the word Computer.
   d) Save the document as Obaed.doc.

2. a) Move the top of the page 1 by pressing F5 key.
    b) Close the Go To dialog box.

3. a) Open Obaed.doc.
    b) Open the Find dialog box.
    c) Find the word Computer through all the document.
    d) Check Use Pattern Matching option.
    e) Check Sounds Like option and Find Whole Words option.

4. a) Find the word 'Diploma'
    b) Replace Diploma with Bachelors.
Lesson 4: Proofing Documents

Learning Objectives

On completion of this lesson you will be able to learn:

- how to check spelling
- how to check grammar
- how to look up words in the thesaurus.

Checking and Correcting Spelling

Word provides a spelling checker that you can use to proof the spelling of your document. The spelling checker checks each word in a document against the words in its own internal dictionary and highlights the words it does not recognize. When you check spelling, Word checks your entire document, starting at the insertion point, but word checks only the text you have selected, if you select text.

To check spelling:

1. From the Tools menu, choose Spelling or click .

See the Spelling dialog box.
Office Automation

2. For each word that is displayed in the Not In Dictionary box, select the options you want from the spelling table.
   3. Choose the OK button.

<table>
<thead>
<tr>
<th>To</th>
<th>Choose</th>
</tr>
</thead>
<tbody>
<tr>
<td>Accept the spelling in the Change To box, replace the misspelled word with another selection in the Suggestions box, or replace the misspelled word with the spelling you type in the Change To box.</td>
<td>The Change button</td>
</tr>
<tr>
<td>Replace all instances of the word</td>
<td>The Change All button</td>
</tr>
<tr>
<td>Add the word to the custom dictionary selected in the Add Words To box</td>
<td>The Add button</td>
</tr>
<tr>
<td>Display a list of proposed words</td>
<td>The Suggest button</td>
</tr>
<tr>
<td>Leave the word unchanged</td>
<td>The Ignore button</td>
</tr>
<tr>
<td>Leave the word unchanged in all documents until you restart Word</td>
<td>The Ignore All button</td>
</tr>
<tr>
<td>Add the misspelled word and its correction to the Auto Correct list</td>
<td>The Auto Correct button</td>
</tr>
<tr>
<td>Customize spelling checks.</td>
<td>The Options button.</td>
</tr>
</tbody>
</table>

Table: Spelling.

éra brada

Checking Grammar

During grammar check, word identify sentences that contain possible grammatical or stylistic errors and suggests improvement.

To check grammar:

1. From the Tools menu, Choose Grammar. See the Grammar dialog box.
2. When a potential grammar or style error is found, the dialog box displays the questionable sentence in the sentence box. At this point, select the options from grammar table.
3. Choose OK button.

<table>
<thead>
<tr>
<th>To</th>
<th>Do this</th>
</tr>
</thead>
<tbody>
<tr>
<td>Accept the suggested change or edit</td>
<td>Choose the Change button.</td>
</tr>
<tr>
<td>Edit the sentence</td>
<td>Edit the sentence in the sentence box.</td>
</tr>
<tr>
<td>Ignore the grammar or style rule for the rest of the current grammar check</td>
<td>Choose the Ignore Rule button.</td>
</tr>
<tr>
<td>Ignore the suggestion</td>
<td>Choose the Ignore button.</td>
</tr>
<tr>
<td>Resume the grammar check with the next sentence</td>
<td>Choose the Next Sentence button.</td>
</tr>
<tr>
<td>Reverse the most recent grammar change</td>
<td>Choose the Undo Last button.</td>
</tr>
<tr>
<td>Get details on the applied grammar rule.</td>
<td>Choose the Explain button.</td>
</tr>
</tbody>
</table>
Office Automation

Table: Grammar
Typing and Editing

Looking up Words in the Thesaurus

You can use Word's internal thesaurus to look up vocabulary alternatives in your documents or to improve the precision and variety of your writing. You can quickly find synonyms (words with the same meaning) and antonyms (words with opposite meanings) and related words.

To look up words in the thesaurus:

1. Select or type the desired word or simply place the insertion point anywhere within the word.
2. From the Tools menu, choose Thesaurus, (or press Shift+F7). See the Thesaurus dialog box.

3. Do one of the following:

<table>
<thead>
<tr>
<th>To</th>
<th>Do this</th>
</tr>
</thead>
<tbody>
<tr>
<td>Look up synonyms</td>
<td>Select a word in the Meanings box to display synonyms in the Replace With Synonym box and choose the Look Up button.</td>
</tr>
<tr>
<td>Replace the word with a synonym</td>
<td>Select a word in either the Meanings or Replace With Synonym box, and then choose the Replace button.</td>
</tr>
<tr>
<td>Look up antonyms</td>
<td>Select Antonyms in the Meanings box.</td>
</tr>
<tr>
<td>Replace the word with an antonym</td>
<td>Select Antonyms in the Meanings box, and then select a word in the Replace With Antonym box. Choose the Replace button.</td>
</tr>
<tr>
<td>Return to the previous word looked up</td>
<td>Choose the Previous button.</td>
</tr>
</tbody>
</table>
Hands on Practice

1. a) Open Emdad.doc [Hands on Practice: Lesson 2, Unit 4]
   b) Open the Spelling dialog box.
   c) Find and correct spelling errors.
   d) Close the Spelling dialog box.

2. What is helpful aspect of Grammar checking option?

3. a) Place the insertion point to beginning with 'School'.
   b) Open the Thesaurus dialog box.
   c) In the Meaning list box, select Antonyms to display a list of antonym.
   d) Close the dialog box.
   e) Look up Synonyms.
Unit 5 : Formatting Texts and Pages

Introduction

The overall effectiveness of a document is directly related to the way it looks. This unit is devoted to formatting and controlling the way your documents look. In this unit, you will learn the basics of character formatting, paragraph formatting and the basics of page formatting. Many important document layout features are controlled at the paragraph level including tab stops, indents, text alignments, line spacing etc. Mastering paragraph formatting will greatly assist you in presenting professionally laid out, attractive documents. In first two lessons, you will learn about the basics of character formatting and paragraph formatting. In the last lesson of this unit we will introduce you to Word’s final level of formatting - Page formatting; many powerful formatting features are controlled at the page level, including headers and footers, paper size and orientation margins, page breaks, page numbers, etc.

Lesson 1 : Character and Paragraph Formatting- I

Learning Objectives

On completion of this lesson you will be able to learn

- how to change font and point sizes
- how to apply or remove font styles
- how to apply or remove shadows
- how to center or align texts
- how to indent paragraphs
- how to create/set hanging indents
- how to set, clear or move tab stops.

Applying Character Formats

You can apply character formats to selected text by using the Formatting toolbar (formerly called the ribbon), shortcut keys (see appendix), or the Font command on the Format menu.

Changing fonts and point sizes:

You can change the shape and size of your selected text by changing text's font and point size. The font determines the shape (type style) of the text
and the point size determines the size of the font (one point equals 1/72 of an inch).
Formatting Texts and Pages

a) Using formatting toolbar:

1. Select the desired text or position the insertion point where you want to begin typing text.
2. Click on the down arrow of the font or font size list boxes
3. Select a font name or point size in the Font box or the Font Size box.

b) Using menu:

1. Select the desired text
2. From the Format menu, choose Font.
3. Select Font tab.
4. Select the desired font and or point size in the Font and or Size box
5. Click on OK.

Applying Font Styles

a) Using menu:

1. Select the desired text.
2. From the Format menu, choose Font.
3. Select Font tab
4. Select desired font style options from the Font Style box.
5. Click on OK.
Office Automation

b) Using formatting toolbar:

1. Select the desired text
2. Click on Bold, Italic or Underline, button to add or remove font style

   ![Bold, Italic and Underline button]

   **Removing Character Formatting and Font Styles**

To remove character formatting:

1. Select the desired text
2. Click on the button of the font styles you wish to remove or press CTRL + SPACEBAR.

To remove font styles:

1. Select desired text
2. From the Format menu, choose Font.
3. Select the Regular from Font Style box.
4. Choose OK.

**Creating and Removing Shadow**

To Create Shadow:

1. Select the desired text
2. From the Font dialog box, select Color.
3. Select Lt Gray
4. Choose OK button.

To Remove Shadow:

1. Select the desired text
2. From the Font dialog box, choose Color.
3. Select Auto or select another color.
4. Choose OK button/Press enter.
5. Press any arrow key for returning to document.
Paragraph Formatting

Many important document layout features are controlled at the paragraph level, including tab stops, indents, text alignment and line spacing. You can click buttons on the Formatting toolbar and drag items on the ruler to indent paragraphs, align text between the margins, and set tab stops. You can also apply many paragraph formats with shortcut keys, shown in the appendix. To make finer adjustments or to change several formats at the same time, use the Paragraph command on the Format menu.

Centering and Aligning Text

Paragraph alignment determines how text is positioned between the left and right indents. Word is preset to align text flush left with the left margin, leaving a ragged right edge (left justified). The alignment you select affects all text in the selected paragraphs.

To center or align text:

1. Select the desired paragraphs.
2. On the Formatting toolbar, click the button for the alignment you want.

<table>
<thead>
<tr>
<th>To align text</th>
<th>Click</th>
</tr>
</thead>
<tbody>
<tr>
<td>At the left indent</td>
<td></td>
</tr>
<tr>
<td>Centered between indents</td>
<td></td>
</tr>
<tr>
<td>At the right indent</td>
<td></td>
</tr>
<tr>
<td>At both the left and right indents (justified)</td>
<td></td>
</tr>
</tbody>
</table>

*Note:* Before centering or aligning a paragraph relative to the left and right margins, make sure that the paragraph is not indented.

Indenting Text

Indents define the left and right boundaries of the selected paragraphs within a document.
Indenting Text

a) Using Increase and Decrease Indent button:

1. Select the desired paragraphs.
2. On the Formatting toolbar, do one of the following:

<table>
<thead>
<tr>
<th>To indent a paragraph</th>
<th>Click</th>
</tr>
</thead>
<tbody>
<tr>
<td>To the next tab stop</td>
<td><img src="image" alt="Next Tab Stop" /></td>
</tr>
<tr>
<td>To the previous tab stop</td>
<td><img src="image" alt="Previous Tab Stop" /></td>
</tr>
</tbody>
</table>

b) Using the ruler:

The ruler provides indents markers. See figure.

![Ruler Diagram](image)

Drag the small box to move the left and first-line indent markers.

To indent paragraph using the ruler follow the following step:

1. Select the desired paragraph.
2. Drag the indent markers on the ruler to desired new location from the indent table.

<table>
<thead>
<tr>
<th>To set</th>
<th>Drag</th>
</tr>
</thead>
<tbody>
<tr>
<td>The first line indent</td>
<td><img src="image" alt="First Line Indent" /></td>
</tr>
<tr>
<td>The left indent</td>
<td><img src="image" alt="Left Indent" /></td>
</tr>
<tr>
<td>The first line and left indents</td>
<td><img src="image" alt="Both Indents" /></td>
</tr>
<tr>
<td>The right indent</td>
<td><img src="image" alt="Right Indent" /></td>
</tr>
</tbody>
</table>
Formatting Texts and Pages

**Note:** To scroll into the left margin, hold down shift, while you click the left scroll arrow on the horizontal scrollbar.

c) Using the Menu:

You can set exact indent position by using the Format menu.

### Setting Hanging Indents

The term hanging indent is used to describe a format in which a paragraph's first line in left indented less than all of its subsequent lines i.e. the first line hangs over the rest. Hanging indents are commonly used for the paragraphs in bulleted or numbered lists.

To create a hanging indent:

1. Select the desired paragraphs(s)
2. Drag the first line indent marker to the desired position
3. Drag the left indent marker to the desired position.

### Setting and Clearing Tab Stops

Tab stops are already set for you at 0.5 inch intervals from the left margin. Just press TAB to move the insertion point to the next tab stop in the current paragraph. There are four types of tab stops e.g. left aligned, centered, right aligned and decimal aligned.

To set tab stops:

1. Select the desired paragraphs.
2. Click the Tab Alignment button at the left of the tab ruler until the desired tab types is displayed.

<table>
<thead>
<tr>
<th>To select</th>
<th>Click the Tab Alignment button to display</th>
</tr>
</thead>
<tbody>
<tr>
<td>Left-aligned tab stops</td>
<td>![Left-Aligned Tab Stop]</td>
</tr>
<tr>
<td>Centered tab stops</td>
<td>![Centered Tab Stop]</td>
</tr>
<tr>
<td>Right-aligned tab stops</td>
<td>![Right-Aligned Tab Stop]</td>
</tr>
<tr>
<td>Decimal tab stops</td>
<td>![Decimal Tab Stop]</td>
</tr>
</tbody>
</table>

3. Click on the ruler, where you want to set a tab stop.
Office Automation

To set tab stops with leader characters:

1. Select the desired paragraphs.
2. From the Format menu, choose Tabs. See Tabs dialog box.

3. In the Tab Stop Position box, type the position for a new tab, or select an existing tab stop to which you want to add leader characters.
4. Under Alignment, select the alignment for text typed at the tab stop.
5. Under Leader, select the desired leader character and choose the Set button.

6. Choose the OK button.

To clear or move a tab stop:

1. Select the paragraphs clear Tab Stop.
2. Do one of the following:

<table>
<thead>
<tr>
<th>To</th>
<th>Do this</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
</tr>
</tbody>
</table>
Clea
r a tab stop
Move a tab stop
Drag the tab marker off the ruler
Drag the tab marker to the right or left on the ruler.

**Hands on Practice**

1. a) Open Science. Doc [Hands on Practice: Lesson 2, Unit 4].
   b) Select School of Science & Technology.
   c) Bold the selected text.
   d) Remove the font styles.
   e) Italicize the text.
   f) Underline the text.
   g) Change the point size to 16.

2. a) Select Clipboard.
   b) Bold and italicize the text.
   c) Center the text.

3. a) Select the paragraph containing clipboard.
   b) Left align the paragraph.
   c) Format the paragraph beginning with clipboard with hanging indents at 0. 5" and a right indent at 5.5".
   d) Save the document as Shely. doc.

4. a) Select the paragraph beginning with using and ending with development.
   b) Indent the paragraph to the 4 previous tab stops.
   c) Indent the paragraph to the 2 next tab stops.
   d) Save the document as Indent. doc.

5. a) Select the paragraph containing Introduction
   b) Set left aligned tab stop at 0.5".
   c) Set right-aligned tab stop at 2.5".
   d) Set center tab stop at 2.5".
   e) Clear the tab stops.

**Practice the following :**

1. Setting tab stops with leader character.
Lesson 2: Paragraph Formatting-II and Formatting List

Learning Objectives

On completion of this lesson you will be able to learn:

- how to change the spacing between tab stops
- how to change line spacing
- how to create new line within paragraph
- how to apply or remove borders
- how to apply or remove shading
- how to create or remove large initial, or dropped, capital letters
- how to add/remove bullets and number
- how to create bullets, numbers in list and multilevel list
- how to interrupt a list
- how to modify list formatting.

Changing the Spacing Between Default Tab Stops

To change the spacing between default tab stops:

1. From the Format menu, choose Tabs.
2. In the Default Tab Stops box, type or select the distance you want between tab stops.
3. Choose the OK button.

Line Spacing

To change line spacing:

1. Select the desired paragraphs.
2. From the Format menu, choose Paragraph. See the following dialog box.
3. Select the Indents And Spacing tab.
4. In the Line Spacing box, select the type of line spacing that are described in setting line spacing options.

5. Choose the OK button.

**Setting line Spacing Options**

Line Spacing is the vertical distances between a lines of text. Word provides six line spacing options:

- **Single** (default setting) sets the line spacing to one single line.
- **1.5 lines** sets the line spacing to a line and half.
- **At least** allows you to specify a custom minimum line spacing.
- **Double lines** sets the line spacing to two lines.
- **Exactly** allows you to specify exact line spacing that will not adjust according to font size.
- **Multiple** sets the line spacing to accommodate more than one line, the default is three lines.

**Creating New Line within Paragraph**
When you press Enter to create a new line in a document, you also create a new paragraph. At times, this way may be undesirable. For example, let's say that you created to insert a new line in the middle of a list within a hanging paragraph. If you pressed Enter to create the new line you would lose your indent. To remedy this problem, word allows you to use Shift + Enter to create a new line without creating a new paragraph.
Formatting Texts and Pages

To create New line within paragraph:
1. Place the insertion point where you want to end the current line and create a new line.
2. Press Shift + Enter, word inserts a new line character (....) and creates a new line without creating a new paragraph.

Adding Borders and Shading

You can add borders, or rules, to any side of a paragraph, and you can add background shading. You can add borders and shading to ordinary text and to paragraphs in table cells and frames.

To apply or remove borders:
1. Select the desired paragraphs, table cells, or frames.
2. Click Borders.
   Word displays the Borders toolbar.
3. Select the desired line style in the Line Style box.
4. Do one or more of the following:

<table>
<thead>
<tr>
<th>To</th>
<th>Click</th>
</tr>
</thead>
<tbody>
<tr>
<td>Add a border to the top of a paragraph, cell,</td>
<td><img src="image" alt="Add Top Border" /></td>
</tr>
<tr>
<td>or frame</td>
<td></td>
</tr>
<tr>
<td>Add a border to the bottom of a paragraph, cell,</td>
<td><img src="image" alt="Add Bottom Border" /></td>
</tr>
<tr>
<td>or frame</td>
<td></td>
</tr>
<tr>
<td>Add a border to the left side of a paragraph, cell,</td>
<td><img src="image" alt="Add Left Border" /></td>
</tr>
<tr>
<td>or frame</td>
<td></td>
</tr>
<tr>
<td>Add a border to the right side of a paragraph, cell,</td>
<td><img src="image" alt="Add Right Border" /></td>
</tr>
<tr>
<td>or frame</td>
<td></td>
</tr>
<tr>
<td>Add a border between paragraphs or cells of a table</td>
<td><img src="image" alt="Add Between Paragraphs Border" /></td>
</tr>
<tr>
<td>Add a box border to selected paragraphs, cells or a frame</td>
<td><img src="image" alt="Add Box Border" /></td>
</tr>
<tr>
<td>Remove all borders</td>
<td><img src="image" alt="Remove All Borders" /></td>
</tr>
</tbody>
</table>

To apply or remove shading:
1. Select the desired paragraphs, table cells or frames.
2. From the Format menu, click the Borders and Shading.
3. Select Shading. See the Borders and Shading dialog box.
4. Select the shading pattern from the Shading box or select Clear to remove shading.
5. Choose OK button.
Creating or Removing a Dropped Capital Letter

You can format a paragraph to have a large initial, or dropped, capital letter or a large first word, as in the following illustrations.

To create large initial, or dropped, capital letters:

1. Position the insertion point in the paragraph or select the text you want to drop.
2. From the Format menu, choose Drop Cap. Please See Figure below.
Formatting Texts and Pages

![Drop Cap dialog box](image)

- **Position:**
  - None
  - Dropped
  - In Margin

- **Font:** Times New Roman

- **Lines to Drop:**

- **Distance from Text:**

![OK, Cancel, Help buttons](image)
Office Automation

3. Select either Dropped or In Margin Under Position.
4. Type or select the font, in the Font box.
5. Type or select the number of lines, in the Lines To Drop box.
6. Type or select the amount of space, in the Distance From Text box.
7. Choose the OK button.

To remove large initial, or dropped, capital letters:

1. Click in the paragraph containing the dropped capital letter.
2. From the format menu, choose Drop Cap.
3. Select None under position box.
4. Choose the OK button.

Formatting List

You can also format a list by using the Bullets And Numbering Command on the Format menu. Use this command to customize the appearance of a list. You can also interrupt a list to create several shorter lists or to insert headings or other text. In Word, multilevel lists can have up to nine levels, and you can have bullets or numbers on any level. Word comes with six predefined multilevel formats.

To create bullets, Number in list or create a multilevel list:

1. Select the desired item
2. From the Format menu, choose Bullets And Numbering. Please See the following dialog box
3. Do one of the following

<table>
<thead>
<tr>
<th>To create</th>
<th>Do this</th>
</tr>
</thead>
<tbody>
<tr>
<td>Bullets in a list</td>
<td>Select Bulleted tab</td>
</tr>
<tr>
<td>Numbers in a list</td>
<td>Numbered tab</td>
</tr>
<tr>
<td>Multilevel list</td>
<td>Select Multilevel tab</td>
</tr>
</tbody>
</table>

4. Select the list format you want
5. Choose the OK Button.

Note: [For multilevel list.] To demote or subordinate selected items, click the Increase Indent button on the Formatting toolbar. To promote selected items or remove indents, click the Decrease Indent button.

Interrupting a List

You can interrupt a list to create several shorter lists or to insert headings or other text between parts of the list. If you break a list into multiple parts, Word restarts the numbering at 1 for each of the shorter lists.

To interrupt a list:

1. Position the insertion point.
2. Click the right mouse button. See the following figure.
3. Choose Stop Numbering

Adding or Removing Bullets and Number in a List

To add or remove bullets and number in a list by using bullets and numbering button.

1. Select the desired items.
Formatting Texts and Pages

2. Do one of the following:

<table>
<thead>
<tr>
<th>To add / remove</th>
<th>Click</th>
</tr>
</thead>
<tbody>
<tr>
<td>Bullets</td>
<td><img src="image" alt="Bullets" /></td>
</tr>
<tr>
<td>Numbers</td>
<td><img src="image" alt="Numbers" /></td>
</tr>
</tbody>
</table>

**Modifying List Formatting**

You can modify the appearance of bulleted, multilevel or numbered lists by the following steps.

To modify bullet or number formats:

1. Select the desired text.
2. From the Format menu, choose Bullets and Numbering.
3. Select the desired tab.
4. Choose the Modify button. See the following dialog box.
5. Do one or more of the following:

<table>
<thead>
<tr>
<th>To modify</th>
<th>Do this</th>
</tr>
</thead>
<tbody>
<tr>
<td>A particular level in a multilevel list.</td>
<td>Select the level by scrolling in the Level box.</td>
</tr>
<tr>
<td>Text that appears before or after a number.</td>
<td>Type the text in the Text Before box or the Text After box.</td>
</tr>
<tr>
<td>The bullet or number format.</td>
<td>Select a bullet or number format under Bullet Character, Number Format, or Bullet Or Number.</td>
</tr>
<tr>
<td>The font of a number, and the font of the text before or after a number.</td>
<td>Choose the Font button, and then select the desired font.</td>
</tr>
<tr>
<td>The alignment of the bullet or number.</td>
<td>Select either Left, Centered, or Right in the Alignment of List Text box.</td>
</tr>
<tr>
<td>The amount of horizontal space between levels in the list.</td>
<td>Type or select a measurement in the Distance From Indent To Text box.</td>
</tr>
<tr>
<td>The space between a bullet or number and the list item that follows it.</td>
<td>Type or select a measurement in the Distance From Bullet To Text or the Distance From Number To Text box.</td>
</tr>
</tbody>
</table>

6. To include hanging indents, select the Hanging Indent check box.
7. Choose the OK button.
Hands on Practice

1. a) Open Indent.doc [Hands on Practice: Lesson 1, Unit 5].
   b) Select paragraph containing clipboard.
   c) Double space the paragraph.
   d) Deselect the paragraph.

2. a) Place the insertion point to before 'Pasting'.
   b) Create a new line.
   c) Apply borders to the top and bottom of the paragraph.

3. a) Select the heading "Introduction", and 'Clipboard'.
   b) Add shading.

4. a) Open Bou. doc.[Hands on Practice: Lesson 1, Unit 3].
   b) Place the insertion point of the left of 'School'.
   c) Apply dropped Capital letter.

5. a) Open Indent .doc. [Hands on Practice: Lesson 1, Unit 5].
   b) Select the paragraph beginning with using and ending with 'development'.
   c) Add bullets to Selected text.
   d) Convert bullets to Numbers.

Practice the Following

6. a) Interrupt a list.
   b) Modify list formatting.
Lesson 3 : Page Formatting

Learning Objectives

On completion of this lesson you will be able to learn

- how to set paper size and page orientation
- how to set margin
- how to create or delete header or footer
- how to insert or remove page Numbers
- how to use page breaks to paginate a document
- how to work in page layout view.

Setting the Paper Size and Page Orientation

You can use the Page Setup command on the File menu to specify a paper size. Pages can be oriented vertically (portrait) or horizontally (landscape). The following figure shows the paper size (margin) and page orientation.

![Figure: Orientation and Margins](image)

To select the paper size and page orientation:

1. Select the desired text or position the insertion point in the section you want to change.
2. From the File menu, choose Page Setup.
3. Select the Paper Size tab. See the following page setup dialog box.
4. Select the paper size from the Paper Size and the page orientation from the Orientation box.
5. In the Apply To box, select how much of the document you want to print.
6. Choose the OK button.

**Setting Margin**

Margins determines the space between the four edges of the page and text of the document. **Figure: Orientation and Margins** shows the default margin settings-top and bottom margins are set to 1" and left and right margins are set to 1.25". You can set margins either from print preview window or in Normal / Page layout view.

To set margin by using page setup dialog box:

1. Select the text whose margins you want to change, or position the insertion point in the section whose margins you want to change.
2. From the File menu, choose Page Setup.
3. Select the margins tab. See figure.
4. Type or select the desired measurement for the margin to adjust in the top, Bottom, Left, or Right box.

5. In the Apply To box, select how much of the document apply the new margin settings to.

6. Choose the OK button.

**Note:** To set margins with the ruler. See [Unit 3, lesson 3]

### Creating Headers and Footers

A header or footer is text or graphics that is usually printed at the top or bottom of every page in a document. A header is printed in the top margin; a footer is printed in the bottom margin. Headers and Footers are used extensively to do such things as page number on each page in a document, place the current date on each page, print the document title and/or another name on each page and so on.
To create a header or footer:

1. From the View menu, choose Header And Footer. See Figure

2. Click to move to the header or footer area.
3. Do one or more of the following:

<table>
<thead>
<tr>
<th>To insert</th>
<th>Do this</th>
</tr>
</thead>
<tbody>
<tr>
<td>Text</td>
<td>Type the text within the dashed line that surrounds the header or footer area.</td>
</tr>
<tr>
<td>Page numbers</td>
<td>Click</td>
</tr>
<tr>
<td>The current date</td>
<td>Click</td>
</tr>
<tr>
<td>The current time</td>
<td>Click</td>
</tr>
</tbody>
</table>

4. Choose the Close button.

Deleting Header or Footer

To delete a header or footer:

1. Position the insertion point in the desired section.
2. From the View menu, choose Header And Footer.
3. Select the header or footer you want to delete,
4. Press BACKSPACE or DELETE.
5. Choose the Close button.

Note: If you have different headers or footers in other sections of the document, click or to find the next header or footer you want to delete.

Inserting or Removing Page Numbers

When you insert a page number, Word puts it in the header or footer in the top or bottom margin, and aligns it in the position you specify (left, right, or center).
Office Automation

To insert page numbers:

1. Position the insertion point.
2. Choose Page Numbers From the Insert menu, See Page Numbers dialog box.

3. Select a location in the Position box, and an alignment in the Alignment box.
4. To change the page number format (1,2,3), choose the Format button. See figure:

5. Select the format from the Number Format box.
6. Choose the OK button.
Formatting Texts and Pages

To remove page Numbers :

1. Position the insertion point.
2. From the view menu, choose Header and Footer.
3. Select a page Number
4. Press Backspace or Delete
5. Choose Close button.

Note : You can also remove page numbers from the Insert menu by clearing show Number on First page check box of page Number dialog box.

Creating a New Section

You use the Break command on the Insert menu to create a new section. In normal view, Word displays a double dotted line to indicate a section break. The line is not printed.

To insert a section break :

1. Position the insertion point.
2. From the Insert menu, choose Break.
3. Under section Breaks, select the option.
4. Choose the OK button.

To delete a section break :

1. In normal view, select the section break.
2. Press BACKSPACE or DELETE.

Using Page Breaks To Paginate A Document

Pagination is the process of separating a document's text into pages. The separations between pages are called page breaks.

There are two types of page breaks in Word.

Automatic page breaks, which Word automatically inserts into a document. An automatic page break appears as loosely spaced dotted line across the text area.

Manual page breaks, which you insert into the document. A manual page break appears as a tightly spaced dotted line with the words Page Break in
the center of the line.

**Inserting a Manual Page Break**

a) Using Insert menu:

1. Place the insertion point immediately to the left of the first character that you want on the new page.
2. From the Insert menu, choose Break.
3. Choose page Break. See the following dialog box.

```
Break

Break types
- Page break
- Column break
- Text wrapping break

Section break types
- Next page
- Continuous
- Even page
- Odd page

OK Cancel
```

4. Click on OK.

To delete a manual page break:

1. Move the mouse pointer into the selection bar.
2. Select the page break.
3. Press Del/Backspace.

b) Using keyboard:

- Simply press CTRL+ENTER.

*Note: You cannot delete automatic page break. However, if you insert a manual page break above an automatic page break, Word will remove the automatic page break.*
Formatting Texts and Pages

## Working in Page Layout View

Word's page layout view allows you to all page areas, including headers, footers and margins. Page layout view is like a cross between Normal view (where you can edit and format body text, but can't view headers and footers) and print preview (where you can see headers and footers but can't edit text). In page layout view you can do any drawing works.

To enter page layout view:

- From the view menu, select Page Layout.

To return to Normal view:

- From the view menu, choose Normal.
Hands on Practice

1. Set the paper size as Legal $\frac{1}{2} \times 14$ in and page orientation as Landscape.

2. a) Set left margin and right margin as 1.25".
   b) Verify that the top and bottom margins are set to 1.5".

3. a) Display the Header and Footer toolbar
    b) Open the Header area.
    c) Insert current date and time.
    d) Type School of Science and Technology.
    e) Open the footer area.
    f) Insert page Number.
    g) Go to the next header.
    h) Delete the header.

4. a) Open Science.doc [Unit 4, Lesson 2].
    b) Insert page Number in the following format.

   ![Page Number Example]

    c) Remove page number.

5. a) Open Bou.doc. [Unit 3, Lesson 1].
    b) Create section from the line containing 'the aims'.
    c) Delete section break.
    d) Insert manual page break from the paragraph containing clipboard.

6. a) Move to page - layout view.
    b) Move to Normal view.

7. Analytical Questions

   a) What do you understand by pagination?
   b) How many types of page breaks are there in the Word?
Unit 6: Tables and Newspaper - Style Columns

Introduction

With tables, you can arrange columns of numbers and text in a document without using tabs. Tables also provide a convenient way to present text in side-by-side paragraphs, as in a resume, or to arrange text beside graphics. This unit also introduces the ways of formatting text into newspaper style columns. Newspaper style column are useful in creating documents such as newsletter, brochures and reports. You can format all or part of your document with newspaper-style columns in which text flows from the bottom of one column to the top of the text.

Lesson 1: Table-I

Learning Objectives

On completion of this lesson you will be able to learn:

- how to create a table
- how to convert text to or from a table
- how to select cells, rows and columns
- how to insert cells, rows and columns
- how to delete cells, rows and columns.

Creating a Table

a) Using standard toolbar:

1. Position the insertion point where you want to create a table.
2. On the Standard toolbar, click.
3. Drag over the grid to select the number of rows and columns
4. Release the mouse button

A table is a grid of rows and columns marked by dotted gridlines. Each box in the grid is a cell. If you do not see the gridlines, choose Gridlines from the Table menu. To add printable borders, select the cells, choose Borders And Shading from the Format menu, and then select the type of borders you want.
b) Using menu:

1. Position the insertion point.
2. From the Table menu, choose Insert Table. See the following dialog box.

3. Specify the number of columns and rows in the Number of Column and Rows box.
4. Select Column Width, if necessary
5. Choose OK.

Moving Around in a Table

Within a cell, you can move the insertion point and select text just as you do in the rest of your document - by using the mouse, the TAB key, or the arrow keys.
Tables and Newspaper - Style Columns

a) Using the mouse :

- Click in the cell you want to move to.

b) Using the keyboard :

- See appendix

Note: If you use the arrow keys on the numeric key pad Numlock must be turned off.

Converting Text to or from a Table

Word enables you to convert text separated by paragraph marks, commas, or tab characters into cells in a table. You can convert a table to ordinary text paragraphs.

To convert text to table :

1. Select the text you want to convert.
2. Click
3. From the Table menu, choose Convert Text to Table,
Office Automation

4. Do the following:

<table>
<thead>
<tr>
<th>To</th>
<th>Do this</th>
</tr>
</thead>
<tbody>
<tr>
<td>Specify a different number of columns.</td>
<td>Type or select a number in the Number of Columns box.</td>
</tr>
<tr>
<td>Specify an exact column width.</td>
<td>Type or select the width in the Column Width box.</td>
</tr>
<tr>
<td>Specify a different separator character.</td>
<td>Under Separate Text At, select any option.</td>
</tr>
<tr>
<td>Apply a predesigned set of formats to the table.</td>
<td>Choose the Autoformat button, and then select formatting options.</td>
</tr>
</tbody>
</table>

5. Choose the OK button.

Note: If the text isn’t converted the way you want, immediately click .

To convert a table to text paragraphs:

1. Select desired the rows.
2. From the Table menu, choose Convert Table To Text. See dialog box.
3. Under Separate Text With, select the desired character.
4. Choose the OK button.
Selecting Cells, Rows, and Columns

You can use the mouse or the keyboard to select cells, rows, and columns quickly. To select text inside a single cell, drag over the text.

a) Using the mouse:

- Do one of the following:

<table>
<thead>
<tr>
<th>Desired selection</th>
<th>Do this</th>
</tr>
</thead>
<tbody>
<tr>
<td>A cell</td>
<td>Click the cell selection bar.</td>
</tr>
<tr>
<td>A row</td>
<td>Click the row selection bar.</td>
</tr>
<tr>
<td>A column</td>
<td>Click the column’s top gridlines or border.</td>
</tr>
<tr>
<td>Multiple cells, rows, or columns.</td>
<td>Drag across the cell, row, or column; or select a single cell, row, or column, and hold down the SHIFT key while you click in another cell, row, or column.</td>
</tr>
</tbody>
</table>

b) Using the Table menu:

You can also select rows, columns, or the entire table by positioning the insertion point in the table and choosing the Select Row, Select, Column, or Select Table command from the Table menu.

c) Using the keyboard:

- See Appendix

Inserting Cells, Rows, and Columns

Before inserting a new cell, row, or column, you must first select an existing cell, row, or column. Word inserts a new row above the selected row, a new column to the left or the selected column, or a new cell at the desired location.

Adding Cells to a Table
Office Automation

To add cells to a table:

1. Select a desired cell or cells.
2. From the Table menu, choose Insert Cells or click . See Insert Cells dialog box:

3. Do one of the following:

<table>
<thead>
<tr>
<th>To</th>
<th>Select this option button</th>
</tr>
</thead>
<tbody>
<tr>
<td>Insert new cells to the left of the selected cells.</td>
<td>Shift Cells Right.</td>
</tr>
<tr>
<td>Insert new cells above the selected cells.</td>
<td>Shift Cells Down.</td>
</tr>
<tr>
<td>Insert a row or rows.</td>
<td>Insert Entire Row.</td>
</tr>
<tr>
<td>Insert a column or columns.</td>
<td>Insert Entire Column.</td>
</tr>
</tbody>
</table>

4. Choose the OK button.

Adding Rows, Columns to a Table

To add row/column to a table:

1. Select the desired row/rows or column/columns.
2. Do one of the following:
Tables and Newspaper - Style Columns

<table>
<thead>
<tr>
<th>To insert</th>
<th>Do this</th>
</tr>
</thead>
<tbody>
<tr>
<td>Rows</td>
<td>From the Table menu, choose Insert rows or Click</td>
</tr>
<tr>
<td>Column</td>
<td>From the Table menu, choose insert column or Click</td>
</tr>
</tbody>
</table>

**Note 1**: To add a single row to a table, position the insertion point outside the table at the end of a row, and then press ENTER. To add a row at the end of a table, position the insertion point in the last cell of the last row and then press the TAB key.

**Note 2**: To add a column to the right of a table, position the insertion point just outside the last column. Choose Select Column from the Table menu, and then click | [Image 3] |

### Deleting Cells, Rows or Columns

To delete rows or columns from a table:

1. Select the rows or columns you want to delete.
2. From the Table menu, do one of the following:

<table>
<thead>
<tr>
<th>To Delete</th>
<th>Choose</th>
</tr>
</thead>
<tbody>
<tr>
<td>Rows</td>
<td>Delete rows</td>
</tr>
<tr>
<td>Columns</td>
<td>Delete Column</td>
</tr>
</tbody>
</table>

**Note**: You can also delete a row or a column by using the Cut button on the standard toolbar or the Cut command on the Edit menu.

To delete cells in a table:

1. Select the desired cell or cells.
2. From the Table menu, choose Delete Cells. See delete cells dialog box.
3. Do one of the following:

<table>
<thead>
<tr>
<th>To</th>
<th>Select this option button</th>
</tr>
</thead>
<tbody>
<tr>
<td>Shift cells left after you delete the selected cells</td>
<td>Shift Cells Left</td>
</tr>
<tr>
<td>Move cells up after you delete the selected cells</td>
<td>Shift Cells Up</td>
</tr>
<tr>
<td>Delete the row or rows</td>
<td>Delete Entire Row</td>
</tr>
<tr>
<td>Delete the column or columns</td>
<td>Delete Entire Column</td>
</tr>
</tbody>
</table>

4. Choose the OK button.
**Hands on Practice**

1. a) Create a table containing 3 columns and 5 rows.
   b) At first cell type Name, Press tab and type Roll, Press tab and type Marks.
   c) Move the insertion point to the first column in the 2nd row and type Zaker.
   d) Move the insertion point to the 2nd column of the 2nd row and type 01.
   e) Move the insertion point to the 3rd column of the 2nd row and type 676.
   d) Move down one row and type Shaker in the 1st column, 14 in the 2nd column and 690 in the 3rd column.
   e) Place the insertion point in the first cell of the table.
   f) Save the document as Tab1.doc.

2. a) Open Tab1.doc.
   b) Select the 1st row.
   c) Deselect the row.
   d) Select the 2nd column.
   e) Deselect the column.
   f) Select entire table.
   g) Print preview the table.

3. a) Move the insertion point to the last cell of the table.
   b) Select the row.
   c) Insert a row above the selected row.
   d) Type Kalim and press Tab key.
   e) Type 750.
   f) Select the 3rd column.
   g) Insert a column to the right of the selected column.
   h) Type class.
   i) Move down one row and Type ix.
   j) Save the document as Tab2.doc.

4. a) Open Tab2.doc.
   b) Delete the 4th column of the Table.
   c) Delete the 3rd row.

5. a) Open Tab1.doc.
   b) Convert the Table to Text.
Lesson 2 : Table - II

Learning Objectives

On completion of this lesson you will be able to learn

- how to move or copy cells, rows or columns in a table
- how to change column width
- how to change the space between columns
- how to change the height of a row
- how to split a table
- how to center a table and change row alignment
- how to merge and split cells
- how to repeat table headings
- how to add borders and shading to a table.

Moving and Copying Cells, Rows and Columns

To move or copy cells, rows, or columns in a table :

1. Select the desired cells, rows, or columns.
2. Position the mouse pointer over the selection.
3. When the arrow points to the left, do one of the following :

<table>
<thead>
<tr>
<th>To</th>
<th>Do this</th>
</tr>
</thead>
<tbody>
<tr>
<td>Move the selection</td>
<td>Drag it to the new location.</td>
</tr>
<tr>
<td>Copy the selection</td>
<td>Hold down the CTRL key while you drag the selection.</td>
</tr>
</tbody>
</table>

Changing Column Width Manually

You can change the width of selected cells and entire columns by dragging the table column markers on the ruler, or by dragging the column boundaries, or using the Cell Height And Width command on the Table menu to specify exact measurements for columns.
Tables and Newspaper - Style Columns

The mouse pointer changes when it is positioned over a column boundary.

When you drag a column boundary... Columns to the right are resized proportionately; the overall table width does not change.

When you hold down SHIFT and drag a column boundary Only the column to the right is resized; the overall table width doesn't change.

When you hold down CTRL+SHIFT (Windows) and drag a column boundary Columns to the right retain their sizes, and the overall table width changes.

If you hold down CTRL or and drag a column boundary, all columns to the right become the same width.

You can also drag these markers on the horizontal ruler to change the width of a column.

<table>
<thead>
<tr>
<th>BANGLADESH</th>
<th>100</th>
<th>465</th>
<th>876</th>
</tr>
</thead>
<tbody>
<tr>
<td>BUTAN</td>
<td>456</td>
<td>876</td>
<td>876</td>
</tr>
<tr>
<td>NAFAL</td>
<td>786</td>
<td>876</td>
<td>908</td>
</tr>
<tr>
<td>INDIA</td>
<td>908</td>
<td>987</td>
<td>987</td>
</tr>
</tbody>
</table>
Changing Column Width

a) By dragging Column boundaries:

1. Point to the column boundary on vertical gridlines that you want to move.
2. Press and hold the mouse button.
3. Drag the column boundary to the desired location by following the adjusting column options.
4. Release the mouse button.

b) By using the ruler:

1. Point to the column marker on the ruler that you want to move.
2. Press and hold mouse button.
3. Drag the column marker to the desired location by following the adjusting column options.
4. Release the mouse button.

Note: Whether you drag a gridlines or a column marker, all columns to the right are resized in proportion to their original width, and the overall width of the table does not change.

Adjusting column options:

<table>
<thead>
<tr>
<th>To adjust the current column</th>
<th>Do this</th>
</tr>
</thead>
<tbody>
<tr>
<td>And one column to the right (table width does not change)</td>
<td>Hold down SHIFT while you drag</td>
</tr>
<tr>
<td>And make all columns to the right equal (table width does not change)</td>
<td>Hold down CTRL while you drag</td>
</tr>
<tr>
<td>Without changing other columns (table width change).</td>
<td>Hold down CTRL+SHIFT while you drag.</td>
</tr>
</tbody>
</table>

Table: Adjusting Column

c) By Using Menu:

1. Select the desired column.
2. From the Table menu, Cell Height and Width. See Cell Height And Width dialog box.
3. Click on the column Tab.
4. Type desired width in the Width of Column box.
5. Click on OK.

Changing the Spacing Between Columns

You can add blank space between columns to enhance a table’s readability, especially if you do not want to add borders to the table.

To change the space between columns:

1. Position the insertion point in the table.
2. From the Table menu, choose table properties.
3. Select the Option button.
4. Click allows spacing between cells, type or select a measurement.
5. Choose the OK button.
Changing the Height of a Row

To change the height of a row:

1. Select the desired row or rows.
2. From the Table menu select table properties. See table properties box.
3. Click on the Row tab and do one of the following:

<table>
<thead>
<tr>
<th>To</th>
<th>Select (under delete Height of Row)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Adjust the row’s height to fit text or graphics inserted in any cell of the row.</td>
<td>Auto.</td>
</tr>
<tr>
<td>Specify a minimum row height.</td>
<td>At Least.</td>
</tr>
<tr>
<td>Specify a fixed row height.</td>
<td>Exactly.</td>
</tr>
</tbody>
</table>

4. In the Specify height, type or select the height.
5. If you want to prevent selected rows from splitting across a page break, clear the Allow Row to Break across Pages check box.
6. Choose the OK button.

Splitting a table

To split a table:
1. Position the insertion point in the row.
2. From the Table menu, choose Split Table.

Centering a Table and Aligning Rows

You can center a table between the margins or align rows in the table with other text.

To center a table or change row alignment:
1. Select the entire table or rows to be aligned.
2. From the Table menu, choose Cell Height And Width.
3. Select the Row tab.
4. Do one of the following:

<table>
<thead>
<tr>
<th>To</th>
<th>Do this</th>
</tr>
</thead>
<tbody>
<tr>
<td>Center the table.</td>
<td>Under Alignment, select the Center option button.</td>
</tr>
<tr>
<td>Set an exact amount of indentation from the left margin.</td>
<td>Type or select a number in the Indent from Left box.</td>
</tr>
<tr>
<td>Set the alignment in relation to the page margins.</td>
<td>Under Alignment, select the Left, Center, or Right option button.</td>
</tr>
</tbody>
</table>

5. Choose the OK button.

Merging and Splitting Cells

The following procedures explain how to merge two or more cells within a row and how to split one or more cells.

To merge cells in the same row of a table:
1. Select the desired.
2. From the Table menu, choose Merge Cells.
To split cells:

1. Select the desired cells.
2. From the Table menu, choose Split Cells.
3. In the Split Cells dialog box, select the number of columns. See Split Cells dialog box.

![Split Cells dialog box](image)

4. Choose the OK button.

**Repeating Table Headings on Each Page**

You can repeat table headings when a table is split between pages. Word automatically repeats table headings only for tables that are split by “soft” page breaks. If you insert a “hard” page break within a table or split the table using the Split Table command, the heading is not automatically repeated. Repeated table headings are not displayed in normal view. To see them, go to page layout view.

To repeat table headings:

1. Select the row or rows of text, you want to use as table headings.
2. From the Table menu, choose Headings.

**Adding Borders and Shading**

Word does not print the gridlines. To print vertical and horizontal lines between cells, you must apply borders to the table. For a more finished look, you can also apply shading.
a) Using Table menu:

1. Position the insertion point in the table.
2. From the Table menu, choose Table Auto Format. See Table Auto Format dialog box.
3. In the Formats list, select the desired design.

*Note*: To remove all formats, select None.

4. Under Formats to Apply and Apply Special Formats to, select the desired check boxes as you want to apply to the table.
5. Choose the OK button.
b) Using the Format menu:

1. Select table, Column, Row or Cell around which you want to add a border.
2. From the format menu, Choose Borders, and Shading and click on the borders tab.
3. Under Presets, click on the desired border type.
4. Under Line select a line style from the Style list box.
5. Click on OK.
Hands on Practice

1. a) Open Tab2.doc [Hands on Practice: Lesson 1, Unit 6]
   b) Move the contents of 2nd row to the 1st row
   c) Copy the contents of 2nd row to the 4th row
   d) Decrease the with of the 2nd column.

2. a) Open Tab2.doc [Hands on Practice: Lesson 1, Unit 6]
   b) Left align all the information in 1st column
   c) Center the table on the page
   d) Save the document as tab3.doc.

3. a) Open tab3.doc
   b) Apply borders to the table
   c) Split the table into two table
   d) Merge the 1st cell and 2nd cell of the 1st row
   e) Split the merged cell into previous one.

4. Practice the following :
   a) Repeat table headings.
   b) Change the height of a row.
Lesson 3 : Newspaper Style Column

Learning Objectives

On completion of this lesson you will be able to learn :

- how to view multiple columns
- how to create columns of equal width
- how to create column of unequal width
- how to create banner headline
- how to change column width and spacing
- how to add vertical lines between columns
- how to insert or delete column break
- how to balance column lengths on a page.

Viewing Multiple Columns

To view multiple columns on the screen, switch to page layout view by clicking on the horizontal scroll bar or on the Standard toolbar. Normal view displays the text in a single column or section break.

Creating Multiple Columns

To create columns of equal width :

1. Position the insertion point where you want the columns begin.
2. Click .
3. Drag to the right to select the number of columns.
4. Release the mouse button.

Note: Click on the first (left most) miniature column to specify a single column format, click on the second column to specify two columns, click on the third column to specify three columns or click on fourth (right most) to specify four columns.
Tables and Newspaper - Style Columns

To create columns of unequal width:

1. Position the insertion point where you want the columns begin.
2. From the Format menu, choose Columns.

![Columns dialog box]

3. Specify the desired number of column in the Number of columns box, or click on one of the predefined column formats under presets.
4. Clear the Equal Column Width check box, if you want columns of unequal width.
5. Under Width and Spacing, type or select a measurement in the Width box or Spacing box for each column.
6. Choose the OK button.

Creating a Banner Headline

To Creating a banner head line:

1. Type the headline text above the left-hand column, and the press ENTER.
2. Select the headline text.
3. Click the Columns button.
4. Drag to select a single column.

Note: While the text is still selected, center it and apply the font and font size that you want for the headline, or apply a heading style.
Changing Column Width and the Space Between Columns

To modify the width of columns and the space between columns, drag the column markers on the ruler. If columns are of equal width, changing the width of one column changes the width of all columns. If columns are of unequal width, only the column whose marker you drag changes.

a) Using column marker:

- In page layout view, drag a column marker on the horizontal ruler to adjust the column width or the space between columns.

b) Using the Columns command:

1. Place the insertion point in the desired section.
2. From the Format menu, choose Columns.
3. Specify the desired width, in the Spacing box.
4. Click on OK button.

Adding Vertical Lines Between Columns

To add vertical lines between columns:

1. Position the insertion point in the desired section.
2. From the Format menu, choose Columns.
3. Select the Line Between check box.
4. Choose the OK button.

Inserting or Deleting Column Break

To insert a column break

1. Position the insertion point,
2. From the Insert menu, choose Break. See the following dialog box,
3. Select Column Break.
4. Choose the OK button.

Note: Alternatively by Pressing CTRL+SHIFT+ENTER, you can insert a column break.

To delete Column break:
1. In Normal view, Position the cursor to column break.
2. Press Del Key.

Balancing Column Lengths on a Page

To balance column lengths on a page:
1. In page layout view, position the insertion point at the end of the text in the columns you want to balance.
2. From the Insert menu, choose Break.
3. Under Section Breaks, select the Continuous option button.
4. Choose the OK button.
Hands on Practice

1. a) Create Columns of equal width containing two columns.
   b) Type the following:

**Self-Study Workbooks**

The open University term for a self-study workbook is a Study Unit. Expressly written and designed for self study, the workbooks are the main teaching vehicle for an Open University course. Their unique features include:

- Clear structure to take students step-by-step through to specific learning targets
- Easily digestible modules, each with clear learning objectives
- Self-assessment questions and activities with model answers, to engage, to engage the student in active learning.

The Open University is the world leader in distance learning with some 170,000 students already having achieved Open University qualifications since its inception 28 years ago. This gives some indication of the quality of materials. With the move to more resource-based learning and the increasing diversity of student intake, Open University teaching materials are now also invaluable in face-to-face teaching institutions.

c) Add a banner head line to the multi column document
d) Decrease the space between columns to .04"
e) Add vertical lines between the columns
f) Print preview the document.
Lesson 4 : Drawing in Word

Learning Objectives

On completion of this lesson you will be able to learn:

- how to create or delete drawing objects
- how to copy a drawing object
- how to create a text box
- how to adjust space between a text box and the text it
- how to select drawing object
- how to resize a drawing objects
- how to move or position a drawing object
- how to change the layering order of drawing objects.

Word provides you with powerful tools for drawing. By using the tool you can create drawing objects such as squares rectangles, polygons, lines, and ellipses. You can also add callout to graphics. You can combine shapes drawn in Word to create organization charts, flowcharts, maps, and other line drawings.

Creating and Deleting Drawing Objects

To create a drawing object:

1. Click \[ \text{button} \] to display the Drawing toolbar.
2. Do one of the following:

<table>
<thead>
<tr>
<th>To draw</th>
<th>Click this button</th>
</tr>
</thead>
<tbody>
<tr>
<td>A straight line.</td>
<td></td>
</tr>
<tr>
<td>A square or rectangle.</td>
<td></td>
</tr>
<tr>
<td>A circle or ellipse.</td>
<td></td>
</tr>
<tr>
<td>An arc.</td>
<td></td>
</tr>
<tr>
<td>A freeform shape (polyline).</td>
<td></td>
</tr>
</tbody>
</table>
3. Do one of the following:

<table>
<thead>
<tr>
<th>To create</th>
<th>Do this</th>
</tr>
</thead>
<tbody>
<tr>
<td>A Line, a rectangle, an ellipse,</td>
<td>Drag</td>
</tr>
<tr>
<td>or an arc</td>
<td></td>
</tr>
<tr>
<td>A square or a circle</td>
<td>Hold down SHIFT as you drag</td>
</tr>
<tr>
<td>A freeform shape</td>
<td>Click to create straight line segments, and</td>
</tr>
<tr>
<td>A closed freeform shape</td>
<td>drag</td>
</tr>
<tr>
<td>An open shape.</td>
<td>Click the starting point</td>
</tr>
<tr>
<td></td>
<td>Double click the last point, or press ESC.</td>
</tr>
</tbody>
</table>

Note: To draw rectangles, squares, arcs, ellipses, and circles from the center of the graphic outward, hold down CTRL as you drag.

To cancel dragging:

- Press ESC

To delete a drawing object:

1. Click the drawing object.
2. Press DEL or choose Clear from the Edit menu.

To make a copy of a drawing object:

- Hold down CTRL as you drag a drawing object.

Deleting drawing objects

Creating a Text Box and Adjusting the Space between Text Box and the Text inside it

You can use a text box instead of a frame to position text on a page. Use a text box when you want to position text behind or in front of the main text layer in the document, because a text box can also contain an imported graphic, you can use it to position a graphic behind text on a page.
Tables and Newspaper - Style Columns

To create a text box:

1. Click \( \text{Click} \) to display the Drawing toolbar.
2. Click \( \text{Click} \).
3. Drag to specify the size of the text box.
4. Type the text in the text box or use the Picture command from the Insert menu to place an imported graphic into the text box.

Selecting Drawing Objects & Canceling the Selection

You have to select a drawing object before changing or moving it. A selected line, square, or rectangle displays handles. A selected circle, ellipse, arc, or freeform shape is enclosed in a bounding box with handles.

To select drawing objects:

1. Click \( \text{Click} \).
2. Do one of the following:

<table>
<thead>
<tr>
<th>To Select</th>
<th>Do this</th>
</tr>
</thead>
<tbody>
<tr>
<td>A drawing object or group of objects located in front of text.</td>
<td>Position the pointer on the object.</td>
</tr>
<tr>
<td>A drawing object or group of objects located behind text.</td>
<td>Click ( \text{Click} ).</td>
</tr>
</tbody>
</table>

3. Do one of the following:

<table>
<thead>
<tr>
<th>To Select</th>
<th>Do this</th>
</tr>
</thead>
<tbody>
<tr>
<td>A single drawing object or group.</td>
<td>Click the object or group.</td>
</tr>
<tr>
<td>Several drawing object at the same time.</td>
<td>Hold down SHIFT while you click each of the</td>
</tr>
<tr>
<td></td>
<td>drawing objects you want to select.</td>
</tr>
<tr>
<td>Select all of the individual line segments that compose a freeform shape.</td>
<td>Click the shape to select it, and then click</td>
</tr>
</tbody>
</table>

**Note**: To cancel a selection, hold down SHIFT and click on a drawing object.
To cancel the selection of drawing objects:

Do one of the following:

<table>
<thead>
<tr>
<th>To Cancel</th>
<th>Do this</th>
</tr>
</thead>
<tbody>
<tr>
<td>All selected drawing objects or groups of objects.</td>
<td>Click anywhere in the document outside of the selected objects, or press ESC.</td>
</tr>
<tr>
<td>Some selected drawing objects or groups of objects.</td>
<td>Hold down SHIFT and click the object(s) you want to deselect.</td>
</tr>
</tbody>
</table>

**Resizing Drawing Objects**

Drag a handle to change the size or shape of a drawing object. Hold down SHIFT as you drag a corner handle if you want to maintain the original height-to-width ratio of the drawing object.

To resize a drawing object:

1. Click 
2. Select the drawing object.
3. Do one of the following:

   - To resize the drawing object and keep its original proportions, drag a corner handle while holding down SHIFT.
   - To resize the drawing object without keeping its original proportions, drag a handle.
   - To resize from the center, hold down CTRL or CTRL+SHIFT as you drag the handle.
Moving and Positioning Drawing Objects

For moving a drawing object, select it and then drag it. For positioning the object precisely on a page, type measurements in the Drawing Object dialog box. You can also nudge a drawing object one pixel at a time or one grid space at a time by using the arrow keys.

To move a drawing object:

1. Select the drawing object.
2. Position the pointer on the object and then drag the object to the new location.

*Note:* If the object is not filled, be sure to position the pointer on one of its borders. To specify an exact location for a drawing object choose Drawing object from the format menu & select size & position tab.

To nudge a drawing object:

1. In page layout view, select the drawing object.
2. Do one of the following:

<table>
<thead>
<tr>
<th>To move the object</th>
<th>Do</th>
</tr>
</thead>
<tbody>
<tr>
<td>One pixel at a time.</td>
<td>Hold down CTRL or OPTION and press the arrow key for the desired direction.</td>
</tr>
<tr>
<td>To the next grid line.</td>
<td>Press the arrow key for the direction desired.</td>
</tr>
</tbody>
</table>

3. Click outside the drawing object.
Layering Drawing Object:

Suppose in a document as having three layers: the text layer, the layer behind the text, and the layer in front of the text. When you create a drawing object by using the tools on the Drawing toolbar, the object is initially placed in the layer that is in front of the text. You can use the buttons on the Drawing toolbar to move the drawing object behind the text.

To change the layering order of drawing objects:

1. On the Standard toolbar, click 
2. Select a drawing object.
3. Do one or more of the following:

<table>
<thead>
<tr>
<th>To</th>
<th>Click this button</th>
</tr>
</thead>
<tbody>
<tr>
<td>Bring the object to the front of a stack of objects.</td>
<td><img src="image" alt="button" /></td>
</tr>
<tr>
<td>Send the object to the back of a stack of objects.</td>
<td><img src="image" alt="button" /></td>
</tr>
<tr>
<td>Bring the object in front of the text layer.</td>
<td><img src="image" alt="button" /></td>
</tr>
<tr>
<td>Send the object behind the text layer.</td>
<td><img src="image" alt="button" /></td>
</tr>
</tbody>
</table>

Changing layering order
**Hands on Practice**

1)  a) Create a rectangle, a circle and a line.
    b) Delete the line.
    c) Make a copy of a rectangle.
    d) Create a text box. Write square in that box, and position that box under the rectangle (a).
    e) Select the circle.
    f) Select the circle and rectangle.
    d) Deselect the circle and rectangle.

2.  a) Select rectangle.
    b) Resize the rectangle.
    c) Move the rectangle.

3.  a) Draw a line.
    b) Nudge the line to the next two grid line.
Unit 7 : Spreadsheet Analysis

Lesson 1 : Introduction to the Spreadsheet

Learning Objectives

On completion of this lesson you will be able to learn :

- what a spreadsheet is
- a brief history of spreadsheet
- what the spreadsheet is for
- the names of few available spreadsheets package.

The majority of application software developed for business is designed to meet the information needs of management. Besides decisions are commonly based on numerical information.

You may be a business person, a student or a teacher, or perhaps you are an accountant, lawyer, physician, financial analyst, or real estate investor. In many situations, you have a bunch of numerical data which you need to organise to assist you in making a decision. You usually know what formulas to use and you can organise them with pencil, paper and a pocket calculator. Sometimes this is very tedious and a change in one data will require a complete recalculation.

Did you ever wonder if you could afford to buy a computer? If you save 100 taka a month this year and increase the amount by 5% each year, how much can you save in 5 years? What if you increase the amount by 8% instead? What if you start with 150 taka a month? This work involves many hours of tedious calculations and recalculations.

This is where an electronic spreadsheet program comes in. It lets the computer be the pencil, the sheet of paper, and the calculator.

Spreadsheet software has three advantages over pencil, paper and calculator. First, the speed and accuracy at which the computer can perform calculations enables the user to review data trends much sooner than if done by hand. Second, the electronic spreadsheet has built into it all the basic financial, mathematical, statistical, and scientific formulas. This greatly enhances the efficiency of the user. Finally, if any of the data is modified, the electronic spreadsheet recomputes the entire spreadsheet automatically and almost instantly. Any thing that can be done with a pencil, a pad of paper, and a calculator can be done faster and far more accurately with an electronic spreadsheet.
A Brief History

Two Harvard Business School students, Daniel Bricklin and Robert Frankston, developed the first electronic spreadsheet program in 1978. They named it VisiCalc. It was initially written for Apple II personal computer, but it has since been converted to run virtually on any micro.

The demand for additional features and sophistication led to the development of a new generation of spreadsheet software. This generation was born with the introduction of Lotus 1-2-3 in 1982. It was written explicitly for the IBM PC.

Since 1-2-3, another generation of spreadsheets has been introduced. This includes a word processor, increased the spreadsheet capability, more graphic functions and a network communication capability. Framework and Symphony are two of the more popular third generation spreadsheet programs.

Enable, QuattroPro, Multiplan, PeachCalc, pfs:plan, Smart Spreadsheet, SuperCalc3, -Microsoft Excel are other examples of spreadsheet software available. Of all these, Lotus 1-2-3 and Excel are most widely used in our country.

What the spreadsheet is for

Nowadays electronic spreadsheets are a multifaceted tool. Though they are mainly intended for business accounting purposes, yet scientific and engineering, presentation graphics, database management applications are very common. Here a number of possible applications are described.

Spreadsheets can be used to help automate financial statements, business forecasting, transaction registers, inventory control, accounts receivable, accounts payable etc.

Financial models can be created that let you play what-if. By changing one or more variables, the model recalculates, and a new set of results can be presented in tabular and/or graphical format.

Electronic spreadsheet (also called worksheets) provides many built-in statistical, analytical, and scientific formulas. Thus it can be used in many scientific and engineering environments to crunch numbers and present findings.

Nowadays spreadsheets support powerful, flexible graphical presentations. Worksheets can include charts and graphs, and can be formatted for high impact presentations.

Spreadsheets can also be used as a database management tool. Here database manipulation is simple. You can perform many database
Spreadsheet Analysis

requirements very quickly though it lack certain features found in typical database management programs.

Electronic spreadsheets can also be used as a powerful application development tool. You may create serious large scale custom applications using them.
Exercise

1. **Multiple Choice Questions**:
   a. Which spreadsheet program was developed first?
      i) Lotus 1-2-3
      ii) PeachCalc
      iii) VisiCalc
      iv) Microsoft Excel.
   b. Which pair of individuals is most closely associated with the development of the first spreadsheet?
      i) Woznick and Jobs
      ii) Bricklin and Frankston
      iii) Burns and Allen
      iv) Boole and Babbage.
   c. An electronic spreadsheet is superior to manual calculations because:
      i) The spreadsheet computes faster
      ii) The spreadsheet computes its results more accurately
      iii) The spreadsheet automatically recalculates whenever any data are changed
      iv) all of the above.

2. **Analytical questions**
   a. Who are the probable users of spreadsheet software?
   b. Name a few spreadsheet software currently available in the software marketplace.
   c. What are the advantages of spreadsheet software over pencil, paper and calculator?
   d. Name a few practical problems that you may solve using spreadsheet software.

*If you cannot answer these questions correctly and confidently, go through this lesson once again before proceeding to the text.*
Lesson 2 : Spreadsheet Fundamentals

Learning Objectives

On completion of this lesson you will be able to learn:

- how to start Microsoft Excel
- how to see its layout and window
- how to move around the worksheet
- how to exit Excel.

Microsoft Excel is a powerful spreadsheet application that you can use for analysing and charting your data and effective presentations.

Starting Microsoft Excel

To start Ms Excel:

1. At the system prompt (such as C:\), type `excel` and press Enter.
2. From the Microsoft Excel/Office window, double click on the Microsoft Excel program icon.

*Note: This process may differ slightly from machine to machine.*

The Spreadsheet Window

Before proceeding any further, you should be familiarised with the spreadsheet window. Refer to figure 2.1. When you have loaded Microsoft Excel, your computer screen should look like this.

The largest part of the window is called the worksheet. The worksheet appears as a rectangular grid of rows and columns. Excel worksheets are 256 columns wide and 16,384 rows deep. Columns are identified by letters and rows are identified by numbers. Thus columns are assigned labels from A to Z, then continue from AA to AZ, and then BA to BZ and so on, until the last column IV is reached. Rows are identified by a number from 1 to 16384. You can see the column labels and row numbers at the top and to the left of the worksheet.

The boxes created by the intersection of columns and rows are called cells. Each cell is identified by an address. The address of a cell is the letter of its column followed by the number of its row. For example, the cell in the extreme upper left corner of the worksheet is addressed A1. Similarly, the cell at the intersection of column D and row 12 is addressed D12.
You will always find a cell surrounded by a bold border. This is the active cell. Whatever entry you make, it always goes to the active cell. You can make any cell active at any time. The currently active cell address always appears in the reference area of the formula bar.

*Formula bar* is the line just above the worksheet. When you select a cell (i.e., make it active), the formula bar displays the contents of that cell. When you make a new entry or edit an existing cell data, the formula bar becomes active and you can see the entry or modifications in it.

Formula bar also includes an *enter box* (√) and a *cancel box* (×). You can complete a cell entry or an edit you have made to an entry by clicking this enter box as well as by pressing the ENTER key. You can cancel an entry or edit by clicking the cancel box or by pressing the ESC key.

The leftmost part of the formula bar is the *reference area*. It always displays the address of the active cell. Later when you learn to select a range of cells, you will see the reference area show the size of the selected range.

The top two lines of the spreadsheet window are for the *menu bar* and the *tool bar*. The menu bar contains menus and the menus contain commands. In Microsoft Excel, the menu bar changes slightly depending on what type of document you are working on. For example, when you are working with a chart, the menu bar contains a Chart menu and a Gallery menu.

When you open a menu, it displays a list of available commands. Some commands have shortcut key combination listed to the right of the command name. These shortcut keys can be used to activate a command without first going through the main menu.
Spreadsheet Analysis

Some of the command names may appear dimmed. This indicates that these commands can not be activated at the current situation.

Note: The toolbar consists of a series of buttons for the most frequently used spreadsheet commands. Excel supplies a number of toolbars serving different needs of the user. You can make any or all of the toolbars visible at all times, if required.

Moving Around the Worksheet

In total a worksheet contains more than 4 million available cells. The portion you can see is a very small part of the whole. You can easily access the other parts of the worksheet by using the scroll bars.

The Table 2.1 gives the keys or key combinations that you can use to navigate the worksheet.

<table>
<thead>
<tr>
<th>Keys to press</th>
<th>Active cell moves to</th>
</tr>
</thead>
<tbody>
<tr>
<td>Arrow keys</td>
<td>to right, left, up or down one cell at a time.</td>
</tr>
<tr>
<td>Ctrl+Arrow keys</td>
<td>To right, left, up or down to the edge of the current data region.</td>
</tr>
<tr>
<td>PgUp, PgDn</td>
<td>up or down one window</td>
</tr>
<tr>
<td>Home</td>
<td>to the beginning of current row</td>
</tr>
<tr>
<td>Ctrl+Home</td>
<td>to cell A1</td>
</tr>
<tr>
<td>Ctrl+End</td>
<td>to the lower right corner of the worksheet</td>
</tr>
<tr>
<td>End+Arrow keys</td>
<td>by one block of data, within the current row or column</td>
</tr>
<tr>
<td>End+Enter</td>
<td>to the last cell in current row</td>
</tr>
<tr>
<td>End*</td>
<td>to lower right corner of the window</td>
</tr>
<tr>
<td>Home*</td>
<td>to upper left corner of the window</td>
</tr>
</tbody>
</table>

*when Scroll Lock is on

Table 2.1: Keys key combinations

In addition to the above keys, you can also use the mouse to move the active cell pointer. Several things you may do.

- Type the desired address in the reference area in the formula bar and press Enter.
- If the desired cell is visible in the window, click the cell in the worksheet. If not visible, use the scroll bar to make the cell visible and then select the cell.
Office Automation

- Select Goto option from the Edit menu or press F5. Type the cell address and press Enter.

**Quitting Excel**

To terminate an Excel session:

- From the File menu, choose Exit.

Excel will give you an opportunity to save any previously unsaved work before you quit.
Spreadsheet Analysis

Exercises

1. Multiple Choice Questions :

a. Which of the following is not a part of the Excel window?

   i) Toolbar
   ii) Chart
   iii) Worksheet
   iv) Cell.

b. The Excel worksheet size is

   i) 256 row × 8192 column
   ii) 256 column × 8192 row
   iii) 256 row × 16384 column
   iv) 256 column × 16384 row.

c. The column number of the 35th column is

   i) Z9
   ii) A35
   iii) AI
   iv) None of the above.

Hands on Practice

To get more familiarised with Excel and the topics covered in this lesson, perform the following:

1. Start Excel.
2. Identify the various components of Excel window.
3. Move the cell pointer to the following cells.
   - D5, G35, AD122, H52, A1, IV16384, L384, A384
   - Try as many key combinations as possible to perform the above movements.
4. Navigate through the Excel menu and see the commands available.
5. Exit from Excel.
Lesson 3: Entering Data

Learning Objectives

On completion of this lesson you will be able to learn:

- how to enter data in a worksheet
- how to cancel an entry
- how to know what kind of data you can enter
- how to fill several cells with a single command
- how to save worksheet
- how to open an existing worksheet.

Entering and Editing Data

Worksheet applications are made by organizing information in a meaningful manner. The spreadsheet is developed one cell at a time by entering different types of information into the individual cells.

To develop your own spreadsheet, you will need to make entries into the cells of the worksheet. Entering data into cells is simple. Simply move the cell pointer to where you want to enter the data and type in. You will see the entry appear in the formula bar. When you finished typing, lock the entry by pressing the [ENTER] key. The cell pointer will automatically move to the cell below. You may use any of the following keys at the end of your entry.

<table>
<thead>
<tr>
<th>key(s)</th>
<th>What will happen</th>
</tr>
</thead>
<tbody>
<tr>
<td>[ENTER]</td>
<td>locks and cell pointer moves to the cell below.</td>
</tr>
<tr>
<td>[SHIFT]+[ENTER]</td>
<td>locks and cell pointer moves to the cell above.</td>
</tr>
<tr>
<td>[TAB]</td>
<td>locks and cell pointer moves to the cell right.</td>
</tr>
<tr>
<td>[SHIFT]+[TAB]</td>
<td>locks and cell pointer moves to the cell left.</td>
</tr>
</tbody>
</table>

Table 3.1: Entering and editing data.

Sometimes you may wish to cancel an entry. To abandon an entry, you have three methods. These are:

- To cancel an entry before it is locked, press the [ESC] key.
- If you have just locked it, choose the Undo Entry option in the Edit menu before doing anything else.
- If you have already initiated some other action after an entry or an edit, you cannot undo in the above manner. For situations like this, you may remove an entry from a cell by selecting the cell and choosing the Clear command from the Edit menu.
Spreadsheet Analysis

Sometimes you need to modify an entry in a cell. You may change an entry by typing a new entry over the old one. Simply select the cell and type the new value you want. The old value will be erased and the new value will be inserted. If you press the Esc key in the middle of such a re-entry process, Excel will abandon the new entry and the old data will remain. You may also recover the old one by selecting the Undo Entry option from the Edit menu provided you did not initiate a new action. If you initiated, then, in no way, you can recover the old entry.

In case of minor modifications in long and complex entries, it is wise to edit it rather than retyping.

To edit the existing one:

1. Select the cell.
2. Activate the formula bar by pressing F2 key or clicking in the formula bar.
3. Make necessary modifications using standard editing keys.
4. Lock entry by pressing Enter or click the Enter box.

Excel Data Types

The entry in every cell in a spreadsheet falls into one of the two classes: a Constant or a Formula.

A Constant value is data that you type directly into a cell; it can be a numeric value, including currency, percentage, fraction or scientific notation, or it can be text. Constant values do not change unless you select the cell and edit the value yourself.

A Formula is a sequence of values, cell references, functions or operators that produces a new value from existing values. Formulas always begin with an equal (=) sign. A value that is produced as the result of a formula can change when other values in the worksheet change. We shall learn more about formulas in module 4.

To enter a number as a constant value, select the cell and type the number. Numbers can include numeric digits (0 through 9) and the following special characters.
<table>
<thead>
<tr>
<th>Character</th>
<th>Function</th>
<th>Examples</th>
</tr>
</thead>
<tbody>
<tr>
<td>0 through 9</td>
<td>Any combination of these numerals</td>
<td>1234567890</td>
</tr>
<tr>
<td>+</td>
<td>used with E or e to indicate positive exponents</td>
<td>+758, 1.286E+5</td>
</tr>
<tr>
<td>-</td>
<td>indicates negative number</td>
<td>-758, 1.286E-5</td>
</tr>
<tr>
<td>( )</td>
<td>indicates negative numbers</td>
<td>(758)</td>
</tr>
<tr>
<td>, (comma)</td>
<td>Thousands marker</td>
<td>10,000,000</td>
</tr>
<tr>
<td>/</td>
<td>fraction indicator</td>
<td>3 1/2</td>
</tr>
<tr>
<td>$</td>
<td>currency indicator</td>
<td>$19.95</td>
</tr>
<tr>
<td>%</td>
<td>percentage indicator</td>
<td>10%</td>
</tr>
<tr>
<td>, (period)</td>
<td>decimal indicator</td>
<td>3.1415</td>
</tr>
<tr>
<td>E or e</td>
<td>Exponent indicator</td>
<td>1.286E+5, 3.52e-6</td>
</tr>
</tbody>
</table>

Table 3.2: Characters allowed for numeric entries

You can include commas in numbers, such as 1,000,000. A single period (.) in a numeric entry is treated as a decimal point. Plus sign (+) entered before numbers are ignored. Precede negative numbers with a minus sign (-) or enclose them within parentheses.

The number displayed in a cell may differ from what is entered. Based on the cell format, the number may be rounded, but Excel stores the original data up to 15 digits of accuracy. Excel always uses the stored data in calculation no matter how it is displayed on the screen. You can always change the way a number is displayed. You will learn more about formatting cells in module.

If a number is too long to be displayed in a cell, Excel displays a series of number signs (####). If you widen the column enough to accommodate the width of the number, the number will be displayed in the cell.

Text entries are used as labels to identify/clarify data in the worksheet. Any entry that starts with a non-numeric character is treated as text. It can be characters only or any combination of characters and numbers. In fact, any entry that is not a number or formula to Excel is a text. A text entry can be at most 255 characters long. Text are generally aligned to the left of the cell. If you wish to enter a number as a text, precede it with an apostrophe (’).

If a text exceeds the width of the cell it is entered, it will overlap into adjacent cells, provided those cells are empty. Otherwise it will be truncated for display. This truncation will not affect the actual content of
the cell. You may see the actual entry in the formula bar when you select the cell.

Saving the Worksheet

Worksheets created using electronic spreadsheet reside in the computer’s RAM. RAM offers instant availability of information stored in it. Changes, additions and deletions to information stored in RAM can be accomplished very quickly. The disadvantage of using RAM storage is that it gets erased when the computer is turned off.

In most occasions, you will be working on a worksheet for several sessions. You must save your worksheet as a file in a disk. Disk files are permanent storage of all information.

a). To save a document:

- From the file menu, choose save or click [icon].

b). To save a new, unnamed document:

1. From the file menu, choose Save As or click [icon].

Then the following dialog box will be displayed:

Fig. 3.1: The Save As dialog box
2. Do one of the following:

<table>
<thead>
<tr>
<th>To save the document</th>
<th>Do this</th>
</tr>
</thead>
<tbody>
<tr>
<td>On the current drive and current directory.</td>
<td>Type a name in File Name box.</td>
</tr>
<tr>
<td>On a different drive and in a different directory.</td>
<td>Select a different drive or directory, or type the complete location and file name in the File Name box.</td>
</tr>
</tbody>
</table>

3. Choose OK button.

*Note*: If any open documents have not been saved before word displays the Save As dialog box so that you can name then.

### Opening Existing Worksheet

If you want to work on a worksheet that you previously saved, you must open it first.

1. From the File menu choose Open or click ![Open Button]. Then the following Open dialog box will be displayed.
2. In the Open dialog box, type or select the file you want to open and click OK.

3. If the file is not in the current directory, then select the desired drive from the Drives list box and directory from the Directories list box.

4. Click OK.
Spreadsheet Analysis

Exercise

1. Analytical questions

a. What are the Excel data types? Explain them briefly.
b. Describe briefly how you will save a worksheet.

Hands on Practice

2. a) Load Microsoft Excel.
b) Make the following entries in the assigned cells.

c) Save the worksheet as Bou.xls
d) Exit Excel.

*If you cannot answer these questions correctly and confidently, go through this lesson once again before proceeding to the next.*
Lesson 4: Formulas and Functions

Learning Objectives

On completion of this lesson you will be able to learn:

- what is a formula
- what operators you may use, their function
- how to write valid formulas
- what a function is
- advantages of using built-in functions
- available functions from Excel
- how you can specify a block of data.

Formula

Formulas are entries that enable you to make calculations based on the numbers and text in the worksheet. With a formula, you can perform operations, such as addition, multiplication, comparison etc. on worksheet values. A formula always begins with an equal sign (=).

For example, if you enter =2*5+10/8-3 in a cell, the spreadsheet will calculate and then display 8.25 in the cell. This capacity to compute makes our work with the spreadsheet much simpler.

A simple formula combines constant values with various operators. These operators fall broadly into three categories:

- Arithmetic operator,
- Comparison operator,
- Text operator.

Arithmetic operators perform basic mathematical operations like addition, subtraction etc. They combine numeric values and produce a numeric result. For example, the formula =20^2*15% raises 20 to the power of 2 and multiply the result by 0.15 (15% = 0.15) to produce a result of 60. Similarly, =(2+7)*25 will result in 225.

Comparison operators compare two values and produce the logical value TRUE or FALSE based on the comparison done. For example, the formula =7<25 produces the value TRUE, whereas =5>7 produces FALSE.

Text operator joins two or more text values in a single combined text value.
Text Operator

<table>
<thead>
<tr>
<th>Operator</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>&amp;</td>
<td>Concatenates two text values</td>
</tr>
</tbody>
</table>

Arithmetic Operators

<table>
<thead>
<tr>
<th>Operator</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>+</td>
<td>Addition</td>
</tr>
<tr>
<td>-</td>
<td>Subtraction</td>
</tr>
<tr>
<td>*</td>
<td>Multiplication</td>
</tr>
<tr>
<td>/</td>
<td>Division</td>
</tr>
</tbody>
</table>

Comparison Operators

<table>
<thead>
<tr>
<th>Operator</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>=</td>
<td>Equal to</td>
</tr>
<tr>
<td>&gt;</td>
<td>Greater than</td>
</tr>
<tr>
<td>&lt;</td>
<td>Less than</td>
</tr>
<tr>
<td>&gt;=</td>
<td>Greater than or equal to</td>
</tr>
<tr>
<td>&lt;=</td>
<td>Less than or equal to</td>
</tr>
<tr>
<td>&lt;&gt;</td>
<td>Not equal to</td>
</tr>
</tbody>
</table>

You may combine several operators in a single formula. In these cases, Excel perform the operations in the following order.

<table>
<thead>
<tr>
<th>Operator</th>
<th>Function</th>
<th>Precedence</th>
</tr>
</thead>
<tbody>
<tr>
<td>-</td>
<td>Negation</td>
<td>Highest</td>
</tr>
<tr>
<td>%</td>
<td>Percent</td>
<td></td>
</tr>
<tr>
<td>^</td>
<td>Exponentiation</td>
<td></td>
</tr>
<tr>
<td>* , /</td>
<td>Multiplication, Division</td>
<td></td>
</tr>
<tr>
<td>+ , -</td>
<td>Addition, Subtraction</td>
<td></td>
</tr>
<tr>
<td>&amp;</td>
<td>Concatenation</td>
<td></td>
</tr>
<tr>
<td>= , &gt; , &lt; , &gt;= , &lt;= , &lt;&gt;</td>
<td>Logical operations</td>
<td>Lowest</td>
</tr>
</tbody>
</table>

Operations and its function

We can easily alter this order of evaluation by using parentheses to group expressions in the formula. You may use as many parentheses as you wish, but there must be a closing parenthesis for each opening parenthesis.

Of course, it will not be of much use if you can operate only on numeric and text constants. Fortunately, Excel allows entering cell references/addresses in formulas. For example, the formula =B2+B3+B4 will add the contents of the cells B2, B3, B4 and stores the sum in the cell where the formula has been entered. The most interesting part in using cell references in the formula is that if any of the entries in the cells B2, B3, B4 are changed, the spreadsheet will recalculate the sum automatically. You can use data located in different areas in one formula and one cell’s value in several formulas.

In lesson 3, you have learned that formulas consist of numeric/text constants, operators and cell references. Another component that can be included in a formula is the function.
A function is a special prewritten formula that takes a value or a set of values, performs an operation, and returns a value. Assume your worksheet has numbers in cells B5 through B12, and you need their sum. From your knowledge of formulas you may enter =B5+B6+B7+B8+B9+B10+B11+B12. This method is tiresome when summing eight cells, but becomes impossible if hundreds of cells need to be added. Excel relieves us by providing the SUM function. The same result can be achieved using =SUM(B5:B12).

Functions can be used alone or as building blocks in large formulas. Functions even be nested. That is one function may serve as an argument for another function.

Since functions are formulas and these formulas are designed and tested, you can have instant reliability when you include them in your worksheet.

Microsoft Excel comes with hundreds of functions. Table 4.1 lists some of the functions from Excel.

<table>
<thead>
<tr>
<th>Function</th>
<th>What it does</th>
</tr>
</thead>
<tbody>
<tr>
<td>SUM(list)</td>
<td>returns the sum of its arguments</td>
</tr>
<tr>
<td>POWER(value,index)</td>
<td>returns the result of a number raised to a power</td>
</tr>
<tr>
<td>ABS(number)</td>
<td>absolute value of the argument</td>
</tr>
<tr>
<td>AVERAGE(list)</td>
<td>returns the average of its arguments</td>
</tr>
<tr>
<td>EXP(list)</td>
<td>returns e raised to the power of a given number</td>
</tr>
<tr>
<td>FACT(number)</td>
<td>returns the factorial of a number</td>
</tr>
<tr>
<td>INT(number)</td>
<td>returns a number down to the nearest integer</td>
</tr>
<tr>
<td>SQRT(number)</td>
<td>returns a positive square root</td>
</tr>
<tr>
<td>SIN(number), COS(number), TAN(number)</td>
<td>returns sine/cosine/tangent of a number</td>
</tr>
<tr>
<td>LN(number), LOG10(number)</td>
<td>returns natural logarithm/base-10 logarithm of a number</td>
</tr>
<tr>
<td>MAX(list), MIN(list)</td>
<td>returns the maximum/minimum value in a list of arguments</td>
</tr>
<tr>
<td>MOD(number,divisor)</td>
<td>returns the remainder from integer division</td>
</tr>
<tr>
<td>PI()</td>
<td>returns the value of π</td>
</tr>
<tr>
<td>Function</td>
<td>What it does</td>
</tr>
<tr>
<td>---------------------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>FV(rate,nper,pmt,pv,type)</td>
<td>returns future value of an investment</td>
</tr>
<tr>
<td>IPMT(rate,per,nper,pv,fv,type)</td>
<td>returns the interest payment for an investment for a given period</td>
</tr>
<tr>
<td>IRR(values,guess)</td>
<td>returns internal rate of return for a series of cash flows</td>
</tr>
<tr>
<td>NPV(rate,val1,val2,...)</td>
<td>returns the net present value of an investment on the basis of a series of periodic cash flows and a discount rate</td>
</tr>
<tr>
<td>ISBLANK(value),</td>
<td>returns TRUE if the value is blank/number/text/cell address/logical</td>
</tr>
<tr>
<td>ISNUMBER(value),</td>
<td></td>
</tr>
<tr>
<td>ISTEXT(value),</td>
<td></td>
</tr>
<tr>
<td>ISLOGICAL(value)</td>
<td></td>
</tr>
<tr>
<td>IF(condition,value if TRUE,value if FALSE)</td>
<td>specifies a logical test to perform</td>
</tr>
<tr>
<td>CORREL(list1,list2)</td>
<td>returns the correlation coefficient between two data sets</td>
</tr>
<tr>
<td>DDB(cost,salvage value,life,period, factor)</td>
<td>returns depreciation of an asset for a specified period using double declining balance method</td>
</tr>
<tr>
<td>NOW()</td>
<td>returns current date and time.</td>
</tr>
</tbody>
</table>

Table 4.1 : Lists of the functions from Excel

In many functions you are required to specify a list of arguments. These arguments may be constants or cell references separated by commas. If the arguments are in adjacent cells, you may specify them as TOP LEFT CELL ADDRESS : BOTTOM RIGHT CELL ADDRESS. For example, cells B3,B4,B5,C3,C4,C5,D3,D4,D5 can be specified as a range by B3:D5.
Exercises

1. Multiple Choice Questions

a. A formula begins with

i) =
ii) ×
iii) +
iv) −.

b. Arithmetic operators perform basic

i) mathematical operations
ii) logical operation
iii) boolean operation
iv) none of the above.

c. Fill up the gaps:

i) A function is a special prewritten -------- that takes a value or a set ----- ----- -----, performs ---- ---- and ---- a value.

2. Analytical questions

a. Describe an arithmetic operator
b. Describe a comparison operator
c. Describe a text operator
d. Briefly describe a function
e. Write the names of the function and outline their job.
f. How you can specify a block of data?

Hands on Practice

3. Load Excel
a) Open the worksheet you saved in Lesson 3.
b) Enter the following formulas in the assigned cells.

<table>
<thead>
<tr>
<th>Cell</th>
<th>Formula</th>
<th>Cell</th>
<th>Formula</th>
</tr>
</thead>
<tbody>
<tr>
<td>D1</td>
<td>=SUM(A2:A9)</td>
<td>E2</td>
<td>=MIN(A2:A9)</td>
</tr>
<tr>
<td>D2</td>
<td>=AVERAGE(A2:A9)</td>
<td>E3</td>
<td>=MOD(611,8)</td>
</tr>
<tr>
<td>D3</td>
<td>=NOW()</td>
<td>E5</td>
<td>=PI()</td>
</tr>
<tr>
<td>D4</td>
<td>=ISTEXT(x)</td>
<td>E6</td>
<td>=FACT(3)</td>
</tr>
<tr>
<td>D5</td>
<td>=ISNUMBER(x)</td>
<td>E7</td>
<td>=SQRT(3)</td>
</tr>
<tr>
<td>D6</td>
<td>=ISNUMBER(10)</td>
<td>E8</td>
<td>=LN(3)</td>
</tr>
</tbody>
</table>
Spreadsheet Analysis

<p>| | | | | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>D7</td>
<td>=POWER(2,3)</td>
<td>A10</td>
<td>=SUM(A2:A9)</td>
<td></td>
</tr>
<tr>
<td>D8</td>
<td>=MAX(A2:A9)</td>
<td>B10</td>
<td>=SUM(B2:B9)</td>
<td></td>
</tr>
<tr>
<td>D9</td>
<td>=MAX(B2:B9)</td>
<td>C10</td>
<td>=SUM(C2:C9)</td>
<td></td>
</tr>
<tr>
<td>D10</td>
<td>=MIN(B2:B9)</td>
<td>E9</td>
<td>=SUM(A2:C9)</td>
<td></td>
</tr>
<tr>
<td>D11</td>
<td>=COS(40)</td>
<td>E10</td>
<td>=SUM(A3:C3)</td>
<td></td>
</tr>
</tbody>
</table>

c) Save the worksheet Bou1.xls.
d) Exit Excel.

*If you cannot answer these questions correctly and confidently, go through this lesson once again before proceeding to the next.*
Lesson 5 : Advanced Editing, Alignment and Fonts

Learning Objectives

On completion of this lesson you will be able to learn:

- how to copy a block data
- how to move a block of data from one place to another
- how to erase a block of data
- how to insert new rows or columns
- how to align data
- how to change fonts.

Copying Data From one Area to Another

While building a worksheet, you often run into the problem of having to retype formulas or data that you have already entered on another part of a worksheet. By copying, you may eliminate this tedious retyping. You may copy a single cell or a group of cells across the worksheet.

a). Using edit menu or standard toolbar.

To copy a single cell across to several cells:

1. Move to the cell you want to copy.
2. From the Edit menu, choose Copy or click .
3. Select the region where you want it to be copied.
4. From the Edit menu choose the Paste or click .

To copy a group of cells to a different location:

1. Select the cell(s) to copy.
2. From the Edit menu, choose Copy or click .
3. Select the upper left corner cell of the region where the cells will be copied.
4. Click the Paste tool.
b). Using drag-and-drop editing:

To copy cell(s) by dragging:

1. Select the cells to be moved.
2. Hold down the Ctrl key.
3. Point to any of the borders of the selected range and the mouse pointer will change to an arrowhead.
4. Hold down the left mouse button, drag to the new location, then release the mouse button.

Moving Data From one Area to Another

Moving data from one region to another will erase the cell contents from the original location and produce a duplicate in the new location. To move:

a). Using edit menu or standard toolbox:

1. Select the cell(s) you want to move.
2. From the edit menu, choose Cut or click \[\text{cut} \]
3. Select the region where you want it to be moved.
4. From the edit menu, choose the Paste or click the \[\text{paste} \]

b). Using drag-and-drop editing:

To drag the cell to its new location:

1. Select the cells to be moved.
2. Point to any of the borders of the selected range and the mouse pointer will change to an arrowhead.
3. Hold down the left mouse button and drag the cells to a new location.
4. Release the mouse button.

Inserting Rows or Columns

When you insert cells, rows, or columns, Microsoft Excel adjusts references to the shifted cells to reflect their new locations.

To insert rows:

1. Select the desired number of row(s) immediately below where you want the new row(s).
2. From the Insert menu, click Rows.
Office Automation

To insert column:

1. Select the desired number of column(s) immediately to right of where you want the new column(s).
2. From the Insert menu, click Columns.

Delete Rows and Columns

When you delete cells, rows, or columns, Microsoft Excel adjusts references to the shifted cells to reflect their new locations.

To delete rows and columns:

1. Select a row or column.
2. From the Edit menu, click Delete.

Erasing Cell Contents

Cells are either blank or contain values. You can either delete cells or clear the contents of cells. When you clear cells, you remove the cell contents, formats, or notes but leave the blank cells on the worksheet.

Clearing a cell removes the contents (formulas and data), formats, notes, or all three from a cell.

To erase cell contents:

1. Select the desired cells.
2. From the Edit menu, select Clear.
3. Click All, Contents, Formats, or Notes.

Note: Pressing DEL clears contents only.

Aligning Cell Entries

Microsoft Excel automatically aligns text to the left and numbers to the right. You can change this default alignment of text, numbers, and dates.

a). Using standard toolbar:

To align cell entries:
Spreadsheet Analysis

1. Select the cell or cell range.
2. Click one of the following alignment button for the desired alignment.

<table>
<thead>
<tr>
<th>To</th>
<th>Click</th>
</tr>
</thead>
<tbody>
<tr>
<td>Align text</td>
<td></td>
</tr>
<tr>
<td>Centre</td>
<td></td>
</tr>
<tr>
<td>Align Right</td>
<td></td>
</tr>
<tr>
<td>Centre Across Column</td>
<td></td>
</tr>
</tbody>
</table>

To align cell entries:

1. Select cell or cells.
2. From the Format menu, choose the Cells command.
3. Click on the Alignment tab.
4. Choose the desired horizontal and vertical alignment and text orientation options.

The General option button, which is the default, aligns text to the left and numbers to the right. The Left, Centre, Right, Justify, and Centre Across Selection option buttons work just
Office Automation

like the alignment tools. The Fill option button repeats the characters in a cell to fill the entire cell.

If you select the Wrap Text option, text is wrapped within the cell so that all the text can be displayed in a narrower column width.

5. Click OK.

Changing Fonts

Font refers to the design of the characters in which text and numbers are displayed on the screen and printed by a printer. Each font has a name and comes in various sizes and styles.

You can apply fonts to cells so that all of the characters within the cell have the same font characteristics. For this

a). Using the format menu:

To change Fonts:

1. Select cell(s).

2. From the Format menu, choose Cells.
Spreadsheet Analysis

3. Select the Font tab.

4. Select Font, Style, Size and special effects you like.

5. Click OK.

b). Using standard toolbar:

Alternatively, you may select font, size and style from the toolbar.

In cells containing text, individual characters can use different fonts.

To format characters within a cell:

1. Double click the cell or click in the formula bar
2. Select the characters you wish to change font
3. Change the font by using font toolbar.
Office Automation

**Hands on practice**

1. a) Open Bou2.xls  
   b) Copy the contents of B1  
   c) Erase B1  
   d) Select A1  
   e) Bold the selected text  
   f) Change the point size to 16.

2. a) Select the cell contents [from B2 to B10]  
   b) Centre the cell contents  
   c) Copy all data to the next page.  
   c) Save Bou.xls as Bou2.xls.
Lesson 6: Formatting Numbers, Adding Borders and Shades

Learning Objectives

On completion of this lesson you will be able to learn:

- how to assign a built-in numeric format
- how to add/remove borders
- how to add shading patterns and colours.

Formatting Numbers

Number formats control how numbers, including date and time, are displayed. Excel provides many built-in number formats for your convenience.

To assign a built-in numeric format

1. Select cell or cells.
2. From the Format menu, choose Cells command.

Number format dialog box
3. Select the Number tab.
4. Select a Category of formats.
   This will narrow the search for formatting codes.
5. Select a Format Code.
6. Click OK.

You may also create custom formats, but this is beyond the scope of this course.

Adding Borders and Shades

You can use borders and shades to create presentation quality worksheets. In addition, borders and shades help emphasise important data. Microsoft Excel offers a wide variety of border types and widths, patterns, and colours that you can use to create more attractive as well as effective worksheets.

Adding Borders

You can add seven types of borders to a cell or range of cells and add a shading pattern (1 of 18 available patterns) to selected cells. To add borders.

To add borders:

1. Select cell(s).
2. From the Format menu, choose Cells.
3. Select the Border tab to display the Border dialog box.
Spreadsheet Analysis

**Border dialog Box**

4. From the Style options, select the line style.
5. Under Border, select one or more of the options.
6. Click the OK button.

**Removing Borders**

To remove borders:

1. Select the cell or cells,
2. From the Format menu, choose Cells.
3. Click on the Border tab.
4. In the Border dialog box, clear one or more options under Border. Adjoining cells share borders. For example, putting a bottom border on one cell produces the same effect as putting a top border on the cell below it. Sometimes when you remove a border, the border doesn’t disappear from the cell. This happens because there are two borders applied to the gridline, and you must remove both.

**Adding Shades and Colours**

To add shades and patterns:

1. Select the cell or cells
2. From the Format menu, choose Cells.

Patterns dialog box

3. Select the Patterns tab.
4. Select the background colour.
5. Select a pattern and its colour from the Pattern drop down box.
6. Click OK.
Spreadsheet Analysis

**Hands on Practice:**

1. a) Select the Format Code under Currency Tk #,##0 and type 4896.3478  
   b) Select the Format Code under Currency #,##0.00 and type 8973.3395.

2. a) Select the Format Code under Number 0.00 and type 385.  
   b) Select the Format Code under Number as ###0.00 and type 8592.

3. a) Open Bou3.xls [unit 7, lesson 5]  
   b) Select the cells A, B, C, D.  
   c) Apply Border  
   d) Select A1 and C1  
   e) Apply pattern and color.
Lesson 7 : Changing Cell Size and Page Setup

Learning Objectives

On completion of this lesson you will be able to learn :

- how to change column width
- how to change row height
- how to define paper size, paper orientation
- how to set margins
- how to add/remove header and footers.

You can format your worksheet by increasing or decreasing the column width and row height of selected rows. It is specially important when the cell contents are too large or too small for the default cell size. You have already seen that text entries are truncated when they do not fit in the cell and adjacent cells are not empty. Similarly, a series of #### signs are shown when a numeric entry do not fit in the cell. To avoid this dilemma, you will have to change the cell size.

Changing Column Width

You may manually set the width or ask Excel to widen the cell(s) so that all entries in that column fit within their respective cells.

To change column width automatically :

1. Select at least one cell in each column you want to change the width.
2. From the Format menu, choose the Column.
3. Choose the Autofit Selection option or double-click the column boundary to the right of the column heading.

To fix up the column width manually, do either of the following :

a) Using format menu

1. Select the column.
2. From the Format menu, choose Column.
3. Select Width.
4. Type the desired width.
5. Click OK.

Note : Widths are specified in number of characters and you can specify a width from 0 to 255 characters.
Spreadsheet Analysis

b) By using mouse

1. Point to the column boundary to the right of the column heading,
2. Drag it to the width you want.

*Note: The mouse pointer will change to | when you point to the boundary.*

Changing the Row Height

To fix the height of a row automatically

To change row width automatically:

1. Select at least one cell in each row you want to change the width.
2. From the Format menu, choose the Row.
3. Choose the Autofit Selection option or double-click the row boundary to the right of the row heading.

To change the Height manually, do either of the following.

a) Using format menu

1. Select the row(s).
2. From the Format menu, choose Row.
3. Select Height.
4. Type the desired height.
5. Click OK.

*Note: In this case the heights are specified in points instead of characters. (72 points = 1 inch).*

b) By using mouse

1. Point to the column boundary to the right of the column heading,
2. Drag it to the width you want.

*Note: The mouse pointer will change to | when you point to the boundary.*

Page Setup

You use the Page Setup to change printer settings for a single document. In this way, you can add headers and footers, change margins, etc. You can also specify settings such as paper orientation and paper size.
The Page Setup command in the File menu displays a tabbed dialog box which provides access to most print related settings. The Four tabs are: Page, Margins, Header/Footer, and Sheet.

To define paper size and paper orientation:

1. Position the insertion font.
2. From the file menu, choose Page Setup.
3. Select Page tab.
4. Select the paper size from the Paper Size and paper orientation from the Orientation box.
5. Select Scaling option and/or First Page Number, if necessary.
6. Click OK.
Setting margins

To set margin by using Page Setup dialog box.

1. Select the text or position the insertion point.
2. From the File menu, choose Page Setup.
3. Select margins tab.
4. Type or select the measurement for margin to adjust in the Top, Bottom, Left, Right box.
5. Specify the Header/Footer position in the From Edge option.

   **Note**: This value should be less than top/bottom margin.

6. Check the Horizontally/Vertically checkbox to position the printout centred on page.
7. Click OK.

You can specify headers or footers to print at the top or bottom of your document. The Header/Footer tab is where page headers and page footers are entered and formatted. Headers and footers work exactly alike -- you may choose a built in header/footer, or define a custom one.
To use a built-in header/footer:

1. From the Page Setup dialog box, select Header/Footer tab.
2. Select from a variety of headers and footers using the two drop-down lists.
3. Click OK.

**Creating a Custom Header/Footer**

The custom header/footer window contains three sections. The left section is left justified, the centre section is centred on the page and the right section is right justified.

To create a Custom Header/Footer:

1. From the Page Setup dialog box, select Header/Footer tab.
2. Select Custom Header or Custom Footer.
Creating a custom header / footer
3. Click on the desired section (Left, Centre, or Right)
4. Type text or press Alt + Enter for a new line, if necessary.
5. Do one or more of the following and click OK.

<table>
<thead>
<tr>
<th>To</th>
<th>Click</th>
</tr>
</thead>
<tbody>
<tr>
<td>Insert Text</td>
<td>![Icon]</td>
</tr>
<tr>
<td>Insert Page Number</td>
<td>![Icon]</td>
</tr>
<tr>
<td>Insert Total Number of Page</td>
<td>![Icon]</td>
</tr>
<tr>
<td>Insert Date</td>
<td>![Icon]</td>
</tr>
<tr>
<td>Insert Time</td>
<td>![Icon]</td>
</tr>
<tr>
<td>Insert File Name</td>
<td>![Icon]</td>
</tr>
<tr>
<td>Insert Tab Name</td>
<td>![Icon]</td>
</tr>
</tbody>
</table>

6. Click OK.
Exercise

A. Multiple choice questions

a. The Custom Header/Footer window contains
   i) 2 sections
   ii) 3 sections
   iii) 4 sections
   iv) none of the above.

b. Which of the following are shown when a numeric entry do not fit in the cell?
   i) a series of $ $ $
   ii) a series of # # #
   iii) a series of % % %
   iv) none of the above.

B. Hands on practice

1. 
   a) Open Bou.xls.
   b) Copy all data to the next page.
   c) Set paper size as letter \( 8 \frac{1}{2} \times 11 \) in and page orientation as landscape.

2. 
   a) Set left and right margin as 1.5”.
   b) Set top and bottom margins as 1”.

3. 
   a) Display custom header dialog box.
   b) Type Bangladesh Open University.
   c) Format the typed text.
   d) Insert page Number as the following format.
   e) Display custom Footer dialog box.
   f) Insert Filename and Date.
   g) Close Bou.xls.

4. 
   a) Open Bou.xls.
   b) Set column width as 20,8.
   c) Set row height as 6,5.
Lesson 8 : Printing a Worksheet

Learning Objectives

On completion of this lesson you will be able to learn:

- how to select a printer
- how to print part of a worksheet
- how to remove gridlines, include row column headings in the printout
- how to insert/remove manual page breaks.

Printing a worksheet involves the following steps:

- Page setup
- Printer selection and setup
- Print Preview
- Print.

You have already learned how to define paper size, margins etc. in your last lesson. We shall learn the remaining steps involved in printing in this lesson.

Printer Selection

To select the printer:

1. Choose the Print command from the File menu.
2. In the Print dialog box, click the Printer Setup button.
3. Select a printer from the list in the Printer Setup dialog box.
4. Click OK.

If you do not find the printer you want in the list, you will have to use the Microsoft Windows Control Panel to install the printer first. Once installed, you will find the printer listed in the above dialog box.
Print Preview

By previewing your sheet, you can see each page exactly as it will print, with the correct margins and page breaks, and the headers and footers in place. Previewing a sheet can save you time and printer life.

To preview your sheet:

1. From the File menu, choose Print Preview.
2. Do one or more of following:

<table>
<thead>
<tr>
<th>To</th>
<th>Do this</th>
</tr>
</thead>
<tbody>
<tr>
<td>Display next page</td>
<td>Click Next</td>
</tr>
<tr>
<td>Display the Previous page</td>
<td>Click Previous</td>
</tr>
<tr>
<td>Switch between a magnified view and a full-page view of a sheet</td>
<td>Click Zoom click on display sheet</td>
</tr>
<tr>
<td>Set Printing options to print selected sheet</td>
<td>Click Print</td>
</tr>
<tr>
<td>Set options that control the appearance of printed sheet</td>
<td>Click Setup</td>
</tr>
</tbody>
</table>

3. Click the close button.

Print

Before printing, you may specify how the worksheet will be printed, what part of the sheet to print, whether gridlines and row/column heading are to be printed etc. The Sheet tab in the Page Setup dialog box allows you to specify a print area, print titles, and several of these print options.

To Print from Page Setup dialog box of File menu:

1. From the Page Setup dialog box, choose Sheet tab.
2. Do one or more of the following from the option table, if necessary:

<table>
<thead>
<tr>
<th>To</th>
<th>Do this</th>
</tr>
</thead>
<tbody>
<tr>
<td>Set Print area.</td>
<td>Type or specify a range of cells in the Print Area edit box. Select rows and columns under Print Titles options.</td>
</tr>
<tr>
<td>Print titles for the selected</td>
<td>Specify the print order under page data is numbered. Select corresponding the check box order option.</td>
</tr>
<tr>
<td>worksheet in case of multiple page</td>
<td></td>
</tr>
<tr>
<td>document.</td>
<td></td>
</tr>
<tr>
<td>Control the order in which your data</td>
<td></td>
</tr>
<tr>
<td>data is numbered.</td>
<td></td>
</tr>
<tr>
<td>Print gridlines/row column headings/</td>
<td></td>
</tr>
<tr>
<td>note etc.</td>
<td></td>
</tr>
</tbody>
</table>

3. Click OK or Clock print to display print dialog box.

To initiate Printing:
1. From the file menu, choose Print or click.

The Print dialog will be displayed.

2. Choose the desired options from the following:

<table>
<thead>
<tr>
<th>To</th>
<th>Do this</th>
</tr>
</thead>
<tbody>
<tr>
<td>Print only selected cells in the selected sheets.</td>
<td>Select Selection.</td>
</tr>
<tr>
<td>Prints the print area of each of the currently selected sheets.</td>
<td>Select Sheets.</td>
</tr>
<tr>
<td>Prints the entire print area all sheets in the active workbook.</td>
<td>Select Entire Workbook.</td>
</tr>
<tr>
<td>Specify the number of copies.</td>
<td>Type or select copies.</td>
</tr>
<tr>
<td>Print all pages in selected sheet print the range of pages.</td>
<td>Select All Type or select Pages(s).</td>
</tr>
</tbody>
</table>

3. Click OK.

Page Breaking

If a sheet is larger than one page, Excel divides it into pages for printing by automatically inserting page breaks where needed. These page breaks are based on the paper size, margin settings, and scaling options. If
automatic page breaks cause a page break to occur in an undesirable place on the worksheet, you can insert manual page breaks. Whenever you set a manual page break, Excel adjusts the automatic page breaks in the rest of the sheet.

To Insert horizontal page breaks only:
1. Select the row below the row where you want the page break to appear.
2. From the Insert menu, click Page Break.

To Insert vertical page breaks only:
1. Select the column to the right of the column to start a new page.
2. From the Insert menu, click Page Break.

To include both vertical and horizontal page break:
1. Select the cell right and bottom of the page break.
2. From the Insert menu, choose Page Breaks.

To remove a page break:
1. Select the desired cell(s)
2. From the insert menu, choose Remove Page Break.
Hands on Practice:

1. a) Open Bou.xls.
   b) Copy all the contents of 1st page to the 2nd page.
   c) Preview the worksheet.
   d) Display the next page.
   e) Close preview.
   f) Insert horizontal page break from cell B3.

2. a) Select the printer as Hp LaserJet 5p/5mp on Lp1.
   b) Print the current page of the worksheet.
   c) Select the cell contents from A1 to B5.
   d) Print the selected cell.
   e) Print 2nd page of the worksheet.
Lesson 9: Creating and Modifying a Chart

Learning Objectives

On completion of this lesson you will be able to learn:

- what a chart is
- what a ChartWizard is
- how to create a chart in Excel
- how to change chart type
- how to add more data in the chart
- how to delete data from chart
- how to change data series
- how to format chart
- how to change worksheet image plotted in a chart

Chart

A chart is a graphic representation of worksheet data. Excel 5.0 offers 15 types of charts to choose from — 9 of them are two dimensional chart types and the remaining 6 are three dimensional chart types. You may plot a chart directly on your worksheet or as a separate document. Charts and related data are interlinked. Therefore, charts are automatically updated whenever you make modifications in the chart data.
Creating a chart

Creating chart is simple in Excel. It comes with a ChartWizard tool. The ChartWizard guides you through the steps required to create a new chart or modify settings for an existing chart.

To create a new chart:

1. Select the range of worksheet cells that contain the data you want to plot.
   
   **Note:** You may select non-contiguous ranges if you wish. Do not select empty cells outside the rows and columns you want plotted.

2. From the Insert menu, select the Chart or click ✎

3. Point to where you want top-left corner of the chart located and drag and drop it onto the desired position.

Then the following ChartWizard (Step 1 of 5) dialog box will be displayed.

   **Note:** To plot a chart in a perfect square, hold down the Shift key while you drag. To align the chart to cell grid, hold down the Alt key while you drag.

4. a) Specify a worksheet range in Step 1 of 5.
   
   b) Click Next, if the range is correct.

Then the Step 2 of 5 ChartWizard dialog box will be displayed.
5. a) Select a chart type.
b) Click Next. Then the ChartWizard (Step 3 of 5) will be displayed.

6. Select the chart format and click Next.

Then the Step 4 of 5 ChartWizard dialog box will be displayed.

7. In Step 4 of 5 dialog box, you will find a preview of the chart, and it asks you to specify how the data on the chart is oriented i.e whether data series are in rows or columns. The options of this step are as follows:

**Data Series in:** **Rows**  
This means that each data series is
Spreadsheet Analysis

Columns plotted from a row of data.

Use First X row(s) This means that each data series is plotted from a column of data.

Use First X column(s) This setting lets you specify how many top rows contain X-axis labels.

Use First X column(s) This setting lets you specify how many left-hand columns contain the legend entries.

After making the required modifications/entries, click Next. Then the Step 5 of 5 ChartWizard dialog box will be displayed.

8. a) Indicate whether you want to add a legend.
   b) Type a chart title, if you want one.
   c) Type a title for each axis, if you want one.
   d) Click Finish.

Note: You may modify any of the selections made so far by clicking the Back push button up to the relevant dialog box and change the selections. Once you are decided, click the Finish button.

Modifying Chart

To Change the worksheet image plotted in a chart:

1. Open the worksheet containing the range plotted in the chart.
2. Activate the chart.
3. Click the ChartWizard button.
4. In the Range box, type or select the new range you want and click Next. Then the following dialog box will be displayed.
5. In step 2 of 2 ChartWizard dialog box, make any changes you want.
Check the sample in Sample Chart box to verify that it is plotted the way you want.
6. Choose OK button.

There are several other ways to modify a chart.

💻 Changing the Chart Type

- Method 1
  1. Activate the chart.
  2. From the Format menu, choose the Chart Type.
4. Select a new chart type.
5. Click OK.

- Method 2
  1. Activate the chart.
  2. Click the Chart type tool.
  3. Select a chart type from the drop-down palette of chart types.

- Method 3
  1. Activate the chart.
  2. From the Format menu, choose Auto Format.
  3. Select a Type from the Galleries list.
4. From the Formats options, choose a format.
5. If you are not satisfied, undo the format or select a new format.
6. OK.

Adding More Data

Once you have created a chart, you can add more data series in the chart. You have three methods:

- Method 1
  1. Select the cells containing the data.
  2. Drag and drop it onto the chart.

Excel will display a dialog box to let you specify the type of data being added.

- Method 2
  1. Select the data you are adding to the chart.
  2. From the Edit menu, choose the Copy or click .
  3. Activate the chart.
  4. From the Edit menu, choose the Paste or click .

Method 3
  1. Activate the chart.
  2. From the Insert menu, choose the New Data.

  3. In the New Data dialog box, enter the range.
  4. Click OK.

Deleting Data from Chart

A data series can be deleted directly from a chart, and there is no impact on the underlying worksheet data. To remove a data series from a chart,
1. Activate the chart.
2. Select the series you want to delete by clicking a data marker within the series.
3. From the Edit menu, choose Edit.
4. Choose clear and choose series or press Delete key.

**Changing Data Series**

After creating a chart, you may want to change the source for one of the data series.

To change data series:

1. Activate the chart.
2. Select the data series by clicking any data point in the series.
3. From the Format menu, choose Selected Data Series.
4. Click the Name and Values tab.
5. Then the following dialog box will be displayed.
6. Change the Range accordingly.
7. Click OK.

**Changing Data Orientation**

To change the orientation of the chart:

1. Activate the chart and click the ChartWizard tool.
2. Click Next on the Step 1 of 2 dialog box.
3. Use the Data Series In options to specify the orientation.
4. Click OK.

Formatting the Chart

To format individual objects in the chart:

1. Click on the object.
2. From the Format menu, choose the Object or double-click on the object.
3. In the Format object dialog box, select the desired options.
Spreadsheet Analysis

Exercise

1. Multiple Choice Questions

a. A chart is a
   i) Graphic representation of worksheet data.
   ii) Bitmap representation of worksheet data.
   iii) Character representation of worksheet data.
   iv) None of the above.

b. How many types of chart are there in Excel?
   i) 6
   ii) 9
   iii) 15
   iv) 25.

2. Analytical questions

a. What is a chart?
b. How to plot a chart in Excel?
c. How to modify the data used for plotting?

3. Hands on Practice

a) Open Bou.xls.
b) Select cell from A2 to A9 and from B2 to B9.
c) Create a chart using the selected data.
d) Change the chart type.
e) Change data orientation.

Note: If you cannot answer these questions correctly and confidently, go through this lesson once again before proceeding to the next.
Unit 8: Introduction To Database

Introduction

A database is an organized collect. This unit provides both foundation and overview of Database by exploring several definitions and classification of DBMS. This unit will familiar you with FoxPro menu structure, dialog box and windows. Besides, you will learn about creation and modification of information in a database.

Lesson 1: Understanding of Database, Record, Field and Database Management System

Learning Objectives

On completion of this lesson you will be able to learn:

- what is a Database?
- what are record, field and files?
- what is a database management system?

Data

Data are facts represented by values, member’s of character string and which carry meaning in a certain context. In other words, data is an encoded representation of information.

Database

A database is a mechanized, shared, formally defined and centrally controlled collection of data used in an organization.

Think, a shoe box full of index cards with names and addresses for a mailing list. The shoe box and its contents are a database. Every time you juggle the index cards to get them in alphabetical order, you are managing the database. The average office cabinet is a database too. It doesn't do anything; it just holds information. If you open a drawer and look up the Karim account, you are searching a database, a way of managing it.

You typically keep your every day databases in some order, either by alphabet, by date, or perhaps by zip code. You do so to structure your database, so that it is easier for you to work with.

Simple Databases
A simple database is organized in such a way that data has always been organized on paper. A typical file in an old-fashioned office was made up of a collection of identical forms, each with blank spaces where information was supposed to be filled in. A common example is a list of names kept on a collection of index cards, each of which is printed to show you where to fill out the Name, Address, Thana, District, Postcode and Telephone Number. Most data was kept on larger forms that went into file folders, but the basic principle was the same. A standard form would be preprinted to indicate the type of data that was needed, and there were blank spaces where you had to fill in the actual data. Simple databases are organized in the same way. All you need to learn are the terms that describe them once they have been computerized.

**Field:** Each blank space is called a field. In the index card database shown in Fig. 8.1, there is one filed for the name, one filed for the address, and so on.

**Record:** All the data that would appear on a single form is called a record. In the example, the name, address, and phone number of one person make up one record.

**File or table:** A collection of similar records that are used together is called a file or table. In the example, the whole box of index cards holding all the names and addresses you use together make up a file. Of course, you could also have another file with similar records—just as you could have another box of index cards where you keep another list of names and addresses.

Fig. 8.1: Index cards here fields are shown
A database management system (DBMS) consists of a collection of interrelated data and a set of programs to access that data. In other words, a DBMS is a computer-based system to manage a database, or a collection of database or files.

Functions of a DBMS

- Database definition
- Database creation (storing data in a defined databases)
- Retrieval (query and reporting)
- Update (changing the contents of database)
- Programming user facilities for system development
- Database revision and restructuring
- Database integrity control
- Performance monitoring.

The collection of data usually referred to as database, contains information about one particular enterprise. The primary goal of a DBMS is to provide an environment that is both convenient and efficient to use in retrieving and storing database information. Database systems are designed to manage large bodies of information. In addition, the database systems must provide for the safety of the information stored, despite system crashes or attempts for unauthorized access. If data is to be shared among several users, the system must avoid possible anomalous results.

The importance of information in most organizations, and hence the value of the database has led to the development of various concepts and techniques for the efficient management of data.

Exercise:

A. Questions for short answers

1. What is a database? Give three example of a simple database.
2. Explain what do you mean by (a) File, (b) Record, (c) Field
3. What is a DBMS? What are its general functions?
Lesson 2 : Getting Acquainted with FoxPro

Learning Objectives

On completion of this lesson you will be able to learn:

- an introduction to FoxPro menu structure
- an introduction to dialog boxes
- how to work with Windows.

How to start FoxPro 2.5

- type CD FoxPro and press Enter
- type Fox and press Enter.

Introduction to FoxPro menu Structure

The FoxPro menu system consists of the following parts: menu bar, menu pads, menus and menu options. The menu system allows you to communicate with FoxPro without programming. Each part of the menu system is described below.

Fig. 8.2 : Illustration of the FoxPro 2.5
Introduction To Database

Menu System

The high lighted menu across the top of the screen is called the menu bar. The menu bar displays titles for menu. These titles on the menu bar are called menu pads. The content of the menu bar changes as you access different parts of the interface. Different actions cause menu pads to be added to and removed from the menu bar.

Menu Pads

Menu pads appear on the menu bar and display the names of menus. You can use the mouse to display the menu associated with each menu pad. Sometimes, certain menu pads appear dimmed and cannot be chosen. These menu pads are disabled. To access the menu bar from the keyboard, press the Alt key (or press F10). The file menu pad appears highlighted because it is selected. Press the Right and Left Arrow keys to move from menu pad to menu pad. When you are ready to exit the menu bar, press one of the following keys: Escape, Alt or F10.

Menus

When you choose a menu pad from the menu bar FoxPro displays a menu. A menu is a list of related options. (In technical sections of the FoxPro documentation, menus are also referred to as menu popups.) When you choose an option from a menu, you are telling FoxPro what action to take. Choose means to activate a selection (highlighted option) by clicking with the mouse or pressing the spacebar.

Sometimes, certain menu pads appear dimmed and cannot be chosen. These menu pads are disabled. You can't display the menu if the menu pad is disabled.

To display a menu with the mouse, point to a menu pad and press the mouse button.

Making Menu Selections:

Using a Mouse

• click the menu pad to make the menu appear
• click the option you want on the menu.

Using the keyboard

You can use the keyboard in several ways to make a selection from the menu. Choose the one you like best.
First, you must make the right menu appear. Use one of the methods:

- Press the Alt key in combination with the underlined letter of one of the menus to make that menu appear immediately.
- Press the Alt key by itself or the F10 key by itself to move the highlighted to menu bar. The File menu is highlighted initially, but its Menu does not appear. To select the menu you want, use ← or → to move the cursor to that menu name. Then, make the menu appear by pressing Enter, ↑ or ↓.

Once a menu is displayed, you usually choose an available option. If you want to deactivate a menu without choosing an option, press Escape, Alt or F10.

**To choose a menu option**

**Using the Mouse**

- Point the menu pad and click
- Click on the desired option to choose it.

**Using the keyboard**

To use the keyboard to choose a menu option use the methods discussed in the previous section to display the menu. Once the menu you want has appeared, you can choose the menu option from within it in a couple of ways:

- Press the underlined letter of that menu option to select it immediately.
- Use ↑ and ↓ to move the highlight to the menu option you want. Once you have highlighted the option you want, select it by pressing Enter or the spacebar.

**Menu options**

Menu contain options, as shown in the illustration of the menu system. The options on each menu are logically related to the menu pad. On a single menu, options can be further grouped to indicate that they produce similar outcomes. These groups are separated by horizontal lines. When you choose a menu option, an action occurs. A window may open or close, a switch may be set, a dialog may appear or a command may be generated in the Command window. Certain menu options are followed by an ellipsis (...). An ellipsis means that more information will be required to complete the command. When you choose this type of option, a dialog appears to request the additional information. Some menu options have a
control key shortcut listed next to them on the menu. You can use a Control key combination as a shortcut to choose a menu option without displaying the menu. Sometimes, a menu option appears dimmed and cannot be chosen. This menu option is disabled.

When you use the FoxPro interface, you are actually generating commands in the Command window. You can also type commands directly in the Command window.

### Introduction to dialog boxes

#### Dialog Controls

Each dialog has its own set of controls. A dotted rectangle around a control, called a focus rectangle, indicated the current contest in the dialog.

This section explains each type of dialog control.

**Push Button** - A push button is a gray box, as shown, that contains key works or pictures that describe the action it triggers. The action associated with a push button occurs immediately when you click a push button unless it contents an ellipsis (...). The ellipsis indicates that another dialog will appear. Push buttons that contain pictures are also called picture buttons.
One push button in each dialog has a darker border than the other push buttons. This is the default push button. To choose the default push button, you can click on it with the mouse or press Enter at time in the dialog.

**Check Box** - A check box is a hollow box followed by text. Settings can be turned on and off by clicking the check box. If a check box has an X in it, the setting is on.

Some check boxes use a picture instead of text for a prompt. Picture check boxes look much like push buttons, but they stay pushed in when the setting is on. More than one box in a group can be checked at once.

**Radio Button** - A radio button is followed by text. Unlike check boxes, only one radio button in a group can be chosen at any given time. Click a radio button to choose it. When a radio button is chosen, it appears filled and the previously chosen radio button in the group becomes deselected.

Some radio buttons use a picture instead of text for a prompt. Picture radio button look much like push buttons, but they stay pushed in when chosen.

**Spinners** - A spinner control appears in dialog locations where you need to increment or decrement a numeric value. To use a spinner, click on the up or down arrow to change the value, or click in the region and edit the value.

**Popup Control** - A rectangle with an underlined arrow in it, as shown below, is a popup control that you can choose to display the associated popup.
Fig. 8.4 : Save as Dialog
To display popup

Using the Mouse

- click on the popup control
- once a popup is displayed, click on appropriate option to choose it.

Using the keyboard

- tap to the popup control.
- press spacebar, or press Alt + up Arrow or Alt + Down Arrow.
- to choose an option, press the up and Down Arrow keys to select the option, then press the spacebar.

List - This box contains a list of items like directories, files and fields that you can select. If necessary, click on the arrow at either end of the scroll bar to move through the list. Click on the desired item to select it.

To select several items anywhere in a list, Ctrl + click or Ctrl + Spacebar on the desired items. If the times you want to select are grouped together, you can Shift + click then drag with the mouse, or Shift + Up/Down Arrow with the keyboard.

Using the keyboard, once you Tab to the list, you can move through the list in the following ways:

- Press the Up and Down Arrow keys to move through the list item-by-item.
- Press PgUp and PgDn to display the previous or next window of list options.
- Press Home and End to select the first or last item in the list.

Some lists are alphabetized. To move directly to an item in an alphabetized list, type enough letters to uniquely identify the item. The letters you type don’t appear on the screen. FoxPro highlights the first item that begins with the typed letters. After a short time, FoxPro is ready to accept the next set of letters to find a different items in the list.

Text Box - This rectangular box indicates an editable text region, where you may enter text. To enter text in a text box, click on the text box to position the cursor, then type and edit as usual.

FoxPro also has descriptive text regions, where text is displayed but cannot be edited. Text in an editable text region is bold. Text in a descriptive region is not bold.
Moving in Dialogs with the Mouse

You can move in dialogs with the mouse by positioning the pointer, selecting and clicking to choose a push button, control, or text editing region.

Moving in Dialogs with the Keyboard

In a dialog, you can always use the Tab key to move from control to control. Other methods for maneuvering in dialogs also exist.

Some control have a hot key for your convenience. A hot key is an underlined letter that immediately chooses the desired control when you press the hot key. If the current dialog control is an editable field or list, press Alt in combination with the hot key.

The following keys allow you to maneuver in dialogs with the keyboard:

- Escape - Exits the dialog without taking any action.
- Enter - Chooses the default push button, on matter where the focus is in the dialog. The default push button has a darker border than the other buttons in the dialog.
- Tab - Selects the next dialog control.
  Shift + Tab - Selects the previous dialog control.
- Up/Down Arrows - When in a list, menu or popup, the Up/Down Arrow move up and down through the list, items-by-item.
- Home and End - When in a list or popup, Home and End select the first or last item in the list.
- PgUp and PgDn - When in a list or popup, PgUp and PgDn display the previous or next window of the list.

Repositioning Dialogue on the Screen

Dialogs can be repositioned on the screen. To move a dialog using the mouse, point to the title bar and drag until the dialog is in the desired location. Release the mouse button.

Controlling Windows

FoxPro windows can be manipulated in several ways. Besides opening and closing a window, you can hide, move, size, minimize, maximize and scroll most windows. Unlike dialogs, you can have many windows open at the same time, and can move from window to window freely.
Windows can be opened in a variety of ways. The Command window is automatically opened when you begin a FoxPro session. If you close the Command window, you can open it again by choosing Command from the Window menu. You can choose the View option from the Window menu to open the View window. The Debug and Trace windows can be opened by choosing their names from the Program menu.

You can open a Browse window by choosing Browse from the Database menu. You can open a browse window from the View window by clicking the Browse push button, choosing Browse from the Database menu or double-clicking on a area with an open table.

To open other system windows, choose Open from the File menu. The Open dialog appears. See the file Menu chapter for more information about the Open dialog.

When you open a window, it becomes the front most window on your screen. You can recognize the format most window because it is the only window with controls drawn on it and its title is displayed in a different color and intensity than any other window title. The names of all open windows (except FoxPro system windows, such as Command) are listed at the bottom of the Window menu.
Close

To close an open window, you can chose Close from the File menu, press Escape, or double-click the Control-menu box. The Control-menu box is located in the upper left corner of all system windows. When a window is closed, You can no longer see its contents. Pressing Escape doesn't close the Command window.

To close all open windows, hold down Shift and choose Close All from the File menu.

Cycle

Cycle refers to the process of rearranging open windows to bring successive ones forward. Choose Cycle from the Window menu (or press Ctrl + F1) as many times as necessary to bring the window of your choice to the front. You can also click on the desired window to bring it forward. You may have to move and size overlapping windows so that you can bring the desired window forward.

Hide

Hiding a window makes it invisible without closing it. To hide a window, choose hide from the Window menu.

If you want to hide or display all open windows, hold down the Shift key and display the Window menu. The Hide option is replaced with options that allow you to Hide All windows and Show All windows.

To momentarily hide all windows in front of the current output window (which may be the screen), hold down Shift+Ctrl+Alt. When you release these keys, all windows reappear.

To display a hidden window again, choose its name from the bottom of the Window menu. It the window is a memo editing window, program editing window, text editing window or Report Layout window, its contents will appear the same as when the window was hidden.

User-defined windows can be hidden by choosing Hide from the Window menu or by using the HIDE WINDOW command. If user defined window is defined is with the CLOSE option, you can also hide it by holding down the Shift key and clicking on the Control-menu box in the upper left corner of the window.

To display a hidden a user-defined window, choose its name from the bottom of the Window menu or use the SHOW WINDOW command.
Maximize

The Maximize button in the upper right corner of the window acts as a toggle between the current the current window size and full screen size. Click on the Maximize button to expand the current window to fill the FoxPro window.

You can also maximize a window by choosing the Maximize option from its Control menu, or by pressing Ctrl+F10. To restore a window to its original size see the Restore section.

Minimize

When you minimize a window, the window becomes an icon in take lower left corner of the screen. To minimize a window, click in the minimize button. You can also minimize a window by choosing the minimize option from the Control menu, or by pressing Ctrl+F9.

When the window is minimized, it appears as an icon at the bottom of the FoxPro window. To display the Control menu for a minimized window, click on the icon. To restore a window to its original size, see the Restore section.

Move

To move a window to a new location, point to the window title bar and drag the window. When the window is in its new location, release the mouse button.

You can also choose the Move option on the window's Control menu (or press Ctrl+F7) to move a window. The pointer changes to a four-headed arrow. Use the arrow keys to move the window to a new location. An outline of the window moves as you use the arrow keys. When you press Enter, the window moves to the location of the outline.

Restore

When a window has been maximized, the restore button (double-headed arrow) appears in the upper right corner of the window. Click the restore button to restore a window to its original size. You can also restore a window's size when it is maximized or minimized by choosing Restore from the Control menu, or by pressing Ctrl+F5.
Introduction To Database

Scroll

Scroll bars are located along the right edge and along the bottom edge of system windows when they contain more information than you can see. Click the arrows at either end of the scroll bar once to move through the contents of a window one line at a time. To move up or down one screen at a time, click above or between the thumb on vertical scroll bars, and to the left or right of the thumb on horizontal scroll bars.

To scroll continuously, point to one of the scroll arrow and hold down the mouse button until the information you want comes interview. You can drag the thumb to move through the window contents rapidly. The position of the thumb on the vertical scroll bar also indicates your position in the file. When the thumb is in the middle of the vertical scroll bar, the detrain your window is from the middle of your file.

You can move through a window's contents with the keyboard by using the arrow keys, PgUp, PgDn, Home and End.

Size

Most windows can be sized. To change the size of a window, click on the size control in the lower right corner of the window and drag in any direction. You can also change the size of a window by positioning the pointer in to a double-headed arrow. Hold down the mouse button and drag until the window is the desired size, then release.

To reins a window using the keyboard, choose the Size option on the Control menu, then use the arrow keys to stretch or shrink the window. Press Enter when the window is the size you want.

Command Window

The Command window is a FoxPro system window. When you choose options from a menu, you're actually generating FoxPro commands in the Command window.

You can also type FoxPro commands directly in the Command window - just position the cursor in the Command window and type. Press Escape to delete text you be typed in the Command window if you haven't pressed Enter yet. FoxPro stores all command directly in a history list so that you recall, edit and re-execute them. Command can be recalled by scrolling through the Command window until you find the command. To re-execute a command, position the cursor the anywhere on the appropriate command line and press Enter. To edit a command, scroll through the Command window until you find the appropriate command. Add, delete or change any information in the command using FoxPro's text editing capabilities.
Office Automation

Exercise

A. Questions for short answers

1. How many parts are in FoxPro menu system? Write their names.
2. Write down the steps to display popup both using the mouse and keyboard.
3. What do you mean by dialog? Write down the names of all types of dialog control.
5. What are cycle and Hide? How can you cycle and Hide the Windows?
Lesson 3: Creating and Adding Information to a Database

Learning Objective

On completion of this lesson you will be able to learn:

- data types
- how to create a new database file
- correcting mistakes
- inserting, Moving, and Deleting fields
- saving the Database structure file
- adding information to a Database file
- opening and closing a Database file
- copying and Modifying the structure of a Database file.

Data Types

When you create a database using FoxPro, you must know how the data will be stored on a field-by-field basis. You do this by assigning a data type to each field. FoxPro uses the following seven field types.

Character Fields - Character fields are used to store characters, which may include letters, numbers, symbols, or spaces. A character field has a maximum size of 254 characters.

Date Fields - Use date fields to store dates. The default format for entering dates is MM/DD/YY, but you can change this format from the command level with the SET DATE command. FoxPro automatically inserts the slashes when you enter all six digits of a date into a date field.

Numeric Fields - Enter numbers, with or without decimal places, into numeric fields. You can enter numbers up to 20 digits in length, and you can enter the minus sign for negative numbers. FoxPro is accurate to 15 decimal places.

Float Fields - Float fields are numeric fields but with a floating decimal point. As with numeric fields, you can enter number or the minus sign, and the entries are accurate to 15 decimal places.

Logical fields - In a logical, enter a single letter representing a true or false value. The letter "T" and "Y" represent true, and "F" mad "N" represent false.
Memo Fields - Memo fields are used for the storage of large blocks of text. An unlimited amount of text can be stored in a memo field (limited only by available hard disk space).

General Fields - General fields are provided for compatibility with FoxPro for Windows. When used in that environment, general fields will hold a variety of data. General fields cannot be manipulated in FoxPro for DOS unless under the influence of a program.

How to create a new database file

Creating a New Database

To get a better understanding of the methods used to create a database, you can create the personnel database that will be used throughout this chapter. The personnel database will contain the following field categories:

- Name
- Father's Name
- Social Secret Number
- Vill/House & street
- Post office / Area
- District
- Telephone
- Job Title
- Date Hired
- Emergency Contact

To create a database in the FoxPro environment you must first open a file, identifying it as a database file, and then define its record structure. [To open the file, enter the CREATE command followed by the name of the new database].

Create filename

[ ------------------- ]

And press ENTER. Because the CREATE command is only used to create database, you don't have to specify the new database name with a DBF extension. FoxPro will do this for you.

Fig. 8.6: The New Dialog Box
You can also open a file in FoxPro using the File menu. Use the mouse or ALT-F to open the File menu, and select the New option. When you do this, the New dialog box shown in Figure 8.7 appears. Select the Database option and choose the OK button or press ENTER. If you have already created a database, there will be additional options in the dialog box. Unless an existing database has already been opened for use, the Index options is unavailable, hence it is dimmed.

Let's create our personnel database using the CREATE command by entering the following:

**Create Personal**

Pressing ENTER causes the database's Structure dialog box to appear. Note that the Database, Record, Program, and Window menus in the menu bar at the top of the screen are replaced with the Structure menu. When the File menu is used to create a database, the CREATE command is generated followed by UNTITLED as the filename in the Command window. The database will be given an actual name when a structure is defined for it.

**The Database Structure Dialog Box**

There are four columns in the Structure dialog box for entering field names, field types, fields widths, and the number of decimal places for number fields. Here is the complete structure for the personnel database.

<table>
<thead>
<tr>
<th>Fields</th>
<th>Fields Name</th>
<th>Type</th>
<th>Width</th>
<th>DEC</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Name</td>
<td>Character</td>
<td>30</td>
<td></td>
</tr>
<tr>
<td>2</td>
<td>Father's name</td>
<td>Character</td>
<td>30</td>
<td></td>
</tr>
<tr>
<td>3</td>
<td>So-scce name</td>
<td>Character</td>
<td>15</td>
<td></td>
</tr>
<tr>
<td>4</td>
<td>Vill. H. S.T</td>
<td>Character</td>
<td>30</td>
<td></td>
</tr>
<tr>
<td>5</td>
<td>Post. Area</td>
<td>Character</td>
<td>30</td>
<td></td>
</tr>
<tr>
<td>6</td>
<td>Thana</td>
<td>Character</td>
<td>25</td>
<td></td>
</tr>
<tr>
<td>7</td>
<td>District</td>
<td>Character</td>
<td>25</td>
<td></td>
</tr>
<tr>
<td>8</td>
<td>Telephone</td>
<td>Character</td>
<td>15</td>
<td></td>
</tr>
<tr>
<td>9</td>
<td>Jobtitle</td>
<td>Character</td>
<td>30</td>
<td></td>
</tr>
<tr>
<td>10</td>
<td>Startdate</td>
<td>Date</td>
<td>8</td>
<td></td>
</tr>
<tr>
<td>11</td>
<td>Emergency</td>
<td>Memo</td>
<td>10</td>
<td></td>
</tr>
</tbody>
</table>

Using this as an example, type the name of the first field into the Name column. When naming a field, use a name that best describes the contents of the fields.
Fields names can consist of letters, numbers, and underscores, but must start with a letter. Spaces are not allowed. Field names can contain up to ten characters. FoxPro will not allow the entry of field names that are too long or that contain illegal characters. When ENTER is pressed, the cursor will automatically move to the Type column.

When the cursor is in the Type column of the Structure of the Structure dialog box, you can either enter the first letter of the desired field type or press ENTER to display a pulldown menu showing the available field types. When this menu is visible, you can use the first letter of the desired field type followed by ENTER, or you can use the mouse to select desired field type.

There are some interesting statistics listed at the bottom of the Structure dialog box. In the lower-right corner is the number of available bytes remaining in the current record. This number is calculated by adding the numbers in the field's Width column and subtracting the total from the maximum of 65,000 bytes (characters) per record. Memo fields count as ten spaces, but since the actual text of a memo field is stored in a different file, the 65,000 character-per-record limit will not affect the amount of text you can store in the memo fields. If you are following this example, enter the width of the first field and press ENTER. Use the same procedure to enter the remaining fields in the structure.

Correcting mistakes

If you need to correct a mistake, use the mouse or the cursor keys to the field name or field type you wish to correct and use BACKSPACE and the character keys to make to any desired corrections. You can also use the arrow keys to move left, right, up, or down in the form. To insert new characters between existing characters, place the cursor at the desired location and then type the correction. Pressing INS takes you out of Insert...
mode and into Overwrite mode. When not in Insert mode, any characters that you type will overwrite existing characters. A more complete list of FoxPro editing keys is shown in Table 8.1. These editing keys also work the Editing when eating memo fields.

Inserting, Moving and Deleting Fields

There may be times when you will want to make changes such as inserting, moving, or deleting fields within the database structure. Here are some keyboard techniques for doing so.

**Inserting Fields** - To insert a new fields, use the mouse or the TAB key to position the cursor on the row where you want to insert the new field, and then choose the Insert button (or press CTRL-I). This action causes FoxPro to create a field with the

<table>
<thead>
<tr>
<th>Key</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>LEFT</td>
<td>Move cursor left one character</td>
</tr>
<tr>
<td>RIGHT ARROW</td>
<td>Move cursor right one character</td>
</tr>
<tr>
<td>UP ARROW</td>
<td>Move cursor up one line or one field</td>
</tr>
<tr>
<td>DOWN ARROW</td>
<td>Move cursor down one line or one field</td>
</tr>
<tr>
<td>INS</td>
<td>Toggle insert mode on / off</td>
</tr>
<tr>
<td>DEL</td>
<td>Delete character at cursor</td>
</tr>
<tr>
<td>BACKSPACE</td>
<td>Delete character to the left of the cursor</td>
</tr>
<tr>
<td>ESC</td>
<td>Abort operation</td>
</tr>
<tr>
<td>TAB</td>
<td>Move cursor right one field</td>
</tr>
<tr>
<td>SHIFT-TAB</td>
<td>Move cursor left one field</td>
</tr>
<tr>
<td>CTRL-W</td>
<td>Save changes and exit</td>
</tr>
</tbody>
</table>

Table 8.1: Keyboard Shortcuts for the Structure Dialog Box

name New field, a character type, and a width of ten. You can then modify the fields name and type as desired.

**Moving Fields** - To move a field with the mouse, point to the double-headed arrow to the left of the field name, hold the left mouse button down, and drag the field to a new position. If you are using the keyboard, use the TAB key to move the cursor to the double-headed arrow and press the SACEBAR to highlight the entire field line, then use LEFT ARROW or RIGHT ARROW to move the field. When you have finished moving the field, press the SPACEBAR to complete the operation.

**Deleting Fields** - If you are using a mouse, position the pointer on the desired field, double-click, and choose the Delete button. Keyboard users can TAB the cursor to the field targeted for deletion and then choose the OK button or the fields that come after it up one position.
Saving the Database Structure File

To complete the database definition process, use the mouse or the TAB key to move to the OK button in the dialog box and press ENTER. An alternative method is to press CTRL-W. If you use the FoxPro menus to create your database structure the dialog box shown in Fig. 8.8 will appear.

Enter the name of your database in the field on the left side of the dialog box, tab over to the save button in the dialog box, and press ENTER or click on the save button. FoxPro automatically put an extension of DBF on the file. If the database contains memo fields, a corresponding file with an. FPT extension will also be created by FoxPro.

You can choose "Yes" or "No" No completes the database-definition process, while choosing "Yes" completes the process and leaves the file open for adding new records. If you are following this example on your computer, select "Yes" to enter the first record into the personnel database.

Adding Information to the Database

Now that we've defined the structure for the personnel database, it's time to enter data. In the previous section, when you completed the definition process, FoxPro prompted you with the question, "Input data records now?" If you responded with a "Yes", you should have a simple entry form, shown in Fig. 8.9, on your screen right now, with blank spaces beside the corresponding field name. The layout of the screen form should match the structure of your personnel database. If you had not just setup
this database and started adding records immediately, you will have to open existing database using commands or the FoxPro menus.

**Opening database using commands**

**Using filename**

Example: Suppose the name of our database file is personnel. The command to open personnel would be use personnel.

**Opening Database using FoxPro menu**

- open File menu
- select the open option
- choose the filename you want from the dialog box that appears. (In this case the filename is personnel).

![Data Entry Form](image)

Fig. 8.9 : A data entry form

If you are following the example on your computer, enter the following information, pressing ENTER after each enter is completed.

<table>
<thead>
<tr>
<th>Name</th>
<th>Rahim</th>
</tr>
</thead>
<tbody>
<tr>
<td>F. Name</td>
<td>Md. Mahbubul Alam</td>
</tr>
<tr>
<td>So-Scc-Name</td>
<td>525-77-7723</td>
</tr>
<tr>
<td>Vill.H.St.</td>
<td>130 Kalabagan</td>
</tr>
<tr>
<td>Post Area</td>
<td>Kalabagan</td>
</tr>
<tr>
<td>Thana</td>
<td>Dhanmondi</td>
</tr>
<tr>
<td>District</td>
<td>Dhaka</td>
</tr>
<tr>
<td>Telephone</td>
<td>869620</td>
</tr>
<tr>
<td>Jobtitle</td>
<td>Sales Manager</td>
</tr>
<tr>
<td>Startdate</td>
<td>11/02/91</td>
</tr>
<tr>
<td>Emergency</td>
<td></td>
</tr>
</tbody>
</table>
To correct mistakes made during the data entry process, use the cursor keys and the BACKSPACE to correct and retype the entry. Once you have completed the data entry process, the cursor should be at the start of the memo field.

**Adding Data to Memo Fields**

To add or edit data in a memo field, move the cursor to the memo field and press CTRL-PGDN or double-click on the memo field with the mouse. The entry form will be covered by a window, and you will be editing inside the window with the FoxPro Editor. When using the Editor, it isn't necessary to press ENTER at the end of every line the Editor will automatically move the cursor to the next line. Here also, you can use cursor keys for navigation and the BACKSPACE and DEL keys for corrections. Make the following entry in the Emergency memo field:

When you have finished editing the memo field, choose Close from the file menu or click on the close box at the upper-left of the window. You can also use the CTRL-W key combination to close a memo file.

**Exercises**

**A. Questions for short answers:**

1. Define the structure, of a database which keeps the information of student of Bangladesh Open University.
2. Create the database mentioned in lesson1.
3. Add some data into that database.
Unit 9: Editing, Sorting/Indexing And Queries

Introduction

Editing and Browsing is the most Powerful topic of FoxPro. This unit will introduces editing and Browsing. Databases generally continue records that have been entered randomly with each new record added to the end. You can use sorting and indexing to arrange your database that will be discussed in lesson 2. Searching or performing is the most important feature of FoxPro performing queries are needed in decision making, producing reports and mailing labels. The last lesson of this unit will introduce you with performing queries.

Lesson 1: Editing and Viewing the Data

Learning Objective

On completion of this lesson you will be able to learn:

- usage of Edit Mode
- usage of Browse Mode
- usage of Browse menu
- how to unlink the partitions
- displaying the Multiple database in browse mode.

Usage of Edit Mode

To enter the Edit mode, open the Record menu and choose Change. Edit (or Change) mode in FoxPro displays as much of a record as will fit on the screen. You can use the cursor keys to move the cursor to any location in the record. While in Edit mode, you can also use PGUP and PGDN to move forward or backward through the database, one record at a time.

Note: Before usage of Edit Mode, you are to open the database file. You can add records while in the Edit mode by using the Append option from the Record menu.

Let's make a change to the Job title field for the employee record for Karim in our personnel database. Since the file is already in use, enter the CHANGE Command or choose the Change option from the Record menu.
Next, use PGUP to find the record for Karim. To make the correction to the Job title field, place the cursor on the Job title field, use RIGHT ARROW to move the cursor to the front of the misspelled word and make the correction. Once you make the change, you can save it by pressing CTRL + W or by moving to another record with either the mouse the arrow keys, or PGUP and PGDN. When you have finished, save your changes and quit with CTRL + W.

Usage of the Browse Mode

Before considering Browse mode, we'll need a database containing more records than the sample one created earlier. Use the following command to create a new file based on the existing one, and copy records form the existing personnel database into the new file four times.

COPY STRUCTURE TO BIGFILE
USE BIGFILE
APPEND FROM PERSONL
APPEND FROM PERSONL
APPEND FROM PERSONL
APPEND FROM PERSONL

This will create a file enough to fill a screen while in the Browse mode. Type BROWSE to get into Browse mode now.
Editing, Sorting/Indexing and Queries

The Browse mode displays records in a tabular format, allowing you to see more than one record at a time. At any time, you can enter the Browse mode by typing BROWSE at the command level, or by opening the Database menu and choosing Browse. In the Browse mode, the large personnel database you just created.

When in Browse mode, you can use PGUP and PGDN to move up and down a screen at a time. UP ARROW and DOWN ARROW mover the cursor between records. Use TAB and SHIFT-TAB to move the cursor between fields. Mouse users can click on any desired field or record to place the cursor at the desired location.

Mouse users can also use the scroll bars to navigate within the window by clicking on the left, right, up, or down arrows in the window's scroll bars. You can click on the up and down arrows (triangular in shape) at the right edge of the screen to scroll through the database vertically. You can also drag the rectangular-shaped indicator anywhere in the scroll box, this provides a vertical movement relative to the location of the indicator. For example, if you drag the indicator halfway down the scroll bar and release it you will be positioned roughly halfway down the personnel database.

Fig. 9.2: The Browse mode displaying a large personnel file.
The scroll bar at the bottom edge works horizontally in a similar manner. Clicking on the triangular-shaped left and right arrows will move the database columns horizontally, and dragging the rectangular-shaped indicator within the scroll box provides a horizontal movement relative to the location of the indicator. Other mouse features work the same in Browse as they do in other windows: and you can zoom the window to full-screen size and back by repeated clicking on the zoom indicator in the upper-right corner.

You can resize the window by dragging on the size indicator (lower-right corner).

**Usage of the Browse Menu**

While you are in Browse mode, an additional menu, Browse, appears on the menu bar at the top of the screen.

The Browse menu options are detailed here:

**Change/Browse**: The first option on the Browse menu allows you to switch between Edit and Browse modes. When in Browse mode, Change is the first option on the Browse menu. Selecting Change on this menu is the same as

![Fig. 9.3: The Browse menu](image)
selecting Change on the Record menu. Doing so displays as much of a record as will fit in the Brows window at a time. This option changes to Browse when you're in Edit mode, and choosing it displays multiple database records in tabular format.

**Grid** Selecting Grid Off hides vertical lines that normally appear between columns. Once you select it, the name of the command changes to Grid On, and you can reselect it to display the lines. Selection Grid, it toggles between Grid On and Grid off. A tick mark appears before Grid shown in Fig. 9.3 in Grid on and all the vertical lines appear between columns. The mark and vertical lines disappears in Grid off.

**UNLINK PARTITIONS** Selecting Unlink Partitions unlinks the two portions of a window that has been split in two (see Resize Partitions), allowing independent movement in each. This choice is unavailable unless the partition has already been split.

**CHANGE PARTITION** Selecting Change Partition deactivates an active partition and activates an inactive partition of a window that has been split into two partitions. This choice is unavailable unless the partition has already been split.

![Microsoft FoxPro](image)

Fig. 9.4: Font Dialog Box.
SIZE FIELD  Selecting Size Field resize the field containing the cursor.

How to adjust the size of the field

1. Using the Keyboard
   - Select the Brows
   - Select the Size
   - Tab to the Desired field if the current field is not that you want
   - Use the Arrow keys to Change the size
   - Press enter to complete the resizing

2. Using a Mouse
   - Move the pointer to the grid line to the right of the fields name
   - Hold down the left button of the Mouse and drag left or right to make the field smaller or larger

MOVE FIELD  Selecting Move Field moves a field to a new location.

How to Move or Order the Field Position

1. Using the Keyboard
   - Select the Brows Menu
   - Select the Move Field
   - Use Tab or Shift+Tab to move the field you want if the current field is not you want
   - Use the Left Arrow or Right Arrow to relocate the field
   - Press enter to complete the Moving

2. Using a Mouse
   - Move the Mouse pointer to the field's name
   - Hold down the left button of the Mouse and drag Left or Right to reposition the column where you want it

RESIZE PARTITIONS  Selecting Resize Partitions lets you split a window into two parts. If the window is already split, this lets you change the size of the partitions. Also use this option to change a split window back to a single window.
How to split the browse window

you can divide the window into two windows by which you may look at two parts of the database file at once. Normally two patrons are linked. That is, when you scroll through the records in one partition records automatically scroll through the other partition, so the same record is visible in both. You can more around this patron in the same way you move around browse /change by using the scroll bar or the Tab, arrow, PgUp and PgDn keys.

Using the keyboard

Create resize and remove:

- Select Browse
- Select Resize Partitions
- Press → As you press →, the partition on the left becomes larger and the one on the right becomes smaller.

To resize

- Press → and until the partition are the size you want.
- To remove press the ← until one partition is closed.
Change

- Select Browse
- Select change, which moves you to the partition you are not currently in.

Using a Mouse

Create resize or remove:

- Move the pointer to the window splitter. The windows splitter is a small area in the lower-left corner of the window, immediately to the left of the horizontal scroll bar. The pointer becomes a two-headed arrow with a vertical line in its center when you put it on the window splitter.
- Drag the splitter to the right divides the window into two partitions.
- To resize the partitions, drag the partition splitter in the home way until the partitions are the size you want.
- To remove the partitions, drag the splitter until one partition is closed.

GOTO... Selecting Goto displays a dialog box that lets you move to a different record in the database. Form the dialog box, you can choose Top or Bottom (to go to the top or the bottom of the database), or you can choose Record, then enter a record number in the Recno box to go to a specific record by number. You can also choose Skip to Skip to a given number of records.

![Goto dialog box](image)

Fig. 9.6: Goto dialog box.
SEEK... Selecting Seek displays a dialog box in which you can enter search term. The database index will then be searched for the desired expression.

*Note:* The Seek option is only available if a file indexed.

TOGGLE DELETE Selecting Toggle Delete lets you mark a record for deletion while in Browse mode. Place the cursor at the desired record and choose Toggle Delete mark the record for deletion. You can use CTRL+T to select this option.

APPEND RECORD Selecting Append Record adds a blank record to the end of the database. You can select this option with CTRL+N.

### Linking and Unlinking the Partitions

Whenever the Browse window is split between a Browse display and an Edit display, both partitions display corresponding movement as the cursor is moved between records. This happens because partitions are linked (tied together) by default with respect to records.

How to unlink and link partitions:

- Select Browse
- Select link partitions.

![Fig. 9.7: Browse/Change window with unlinked partitions.](image-url)
When you have unlinked partitions, the check mark next to the link partitions option on the browse menu disappears, to indicate that the option in toggle off. When partitions are unlinked, you can switch between partitions with CTRL + W or the mouse and independently move around each partition. Select the option again to toggle it back on and to tie the partition together again.

Displaying Multiple Database in Browse Mode

FoxPro also gives you the ability to display multiple database in different windows simultaneously. For example, to display the original personnel database beside the larger database that is in use at the moment, enter the following commands:

*Note*: If larger database does not exist, create a larger database.

```
SELECT 1
USE BIGFILE
BROWSE
```

and then press CTRL-F2 to switch from the Browse window back to the Command window.

You could then use commands like:

```
SELECT 2
USE PERSONL
EDIT
```

to display the original database file in an Edit window. Before proceeding, enter CLEAR ALL to close any database currently open.

Exercise

**Questions for short answers**

1. Write how to switch between Edit and Browse modes.
2. Write the steps to display multiple Databases in Browse Mode.
3. What are the requirements of unlinked Partitions? How can you unlink the partitions?
4. Write down the steps required to adjust field size and field position.
Lesson 2: Understanding Sorting and Indexing a Database

Learning Objectives

On completion of this lesson you will be able to learn:

- sorting using FoxPro
- indexing using FoxPro

Sorting using FoxPro

When you perform a sort using FoxPro, you do not overwrite the database that you are currently working with. Instead, a new database is created containing the records in the desired order. If you were to sort a database of names in alphabetical order, the new database would contain all the records that were in the old database, but they would be arranged in alphabetical order.

From the command level, the format for the SORT command is

```
SORT TO <new File> ON <field1> [/A/C/D]
```

To sort a database from the FoxPro menus, open the Database menu, choose the sort option, and then fill in the desired fields for the sort order in the sort dialog box. A new file by the name of new file is created, sorted by the field specified. To sort in ascending order, choose the Ascending button under field options specify /A at the command level. This order places character fields in alphabetical order, numeric fields in numerical order, and data fields in chronological order, earliest to latest. If you choose the Descending button under field options or specify /D at the command level, character fields are sorted in descending order ("Z" to "A"), numeric fields from highest to lowest, and date fields in reverse chronological order, latest to earliest. You cannot sort on memo fields. If you do not specify ascending or descending order, FoxPro assumes that ascending order is your preference.

Sorts are also normally in ASCII order, with uppercase letters treated differently than lowercase letters. ASCII order ascending specifies "A" through "Z" then "W" through "z" ASCII order descending specifies "z" through "a," then "Z" through "A". If you want uppercase and lowercase letters
Selecting a sort field

A sort can be performed using the SORT command or through the FoxPro menus. From the menus, open the Database menu with ALT+ D and choose sort. Fig. 9.9 shows the contents of the sort Order dialog box, which appears next. In the upper- left part of the dialog box is the Database fields list box, which lets you choose desired fields that the sort will be based on. The center portion of the dialog box contains a field options box, which lets you select ascending or descending order and whether FoxPro should ignore case (sorting uppercase and lower cased letters together) or sort uppercase before lowercase. When you select fields from the database fields list box, they are added to the sort order box on the right side of the dialog box.

You can limit the number of records included in the sorted file by adding a scope, for or while clause, found in the bottom- center in the Input box.
Fig. 9.9: The sort order dialog box

The output box at the lower-right corner of the dialog box contains a Save As entry for the file name to be assigned to the sorted file, along with a fields option. The fields option, when chosen, lets you specify a list of fields that will be included in the sorted file. If not checked, by default, all fields are included in the sorted file.

As an example, we will sort on the employees' start date. Tab to the database fields list box and select start date with the cursor and ENTER key. Once selected, the field name, preceded by the database name PERSONL, appears in the sort order list box. Ascending order, which is the default shown in the fields option box, is fine for this example. No scope or for clauses are needed, since all records are desired. Tab to the entry space after the fields button and enter PERSONL2 as the filename. Then select OK from the dialog box. In a few moments, you'll see a message indicating the completion of the sorting process.

To see the results, enter

```
USE PERSONL2
LIST Name, startdate
```

You will then see the following:

<table>
<thead>
<tr>
<th>Record #</th>
<th>NAME</th>
<th>STARTDATE</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Gour</td>
<td>10/05/95</td>
</tr>
<tr>
<td>2</td>
<td>Jakir</td>
<td>11/01/94</td>
</tr>
<tr>
<td>3</td>
<td>Jayed</td>
<td>12/01/95</td>
</tr>
<tr>
<td>4</td>
<td>Mahbub</td>
<td>02/10/94</td>
</tr>
<tr>
<td>5</td>
<td>Keya</td>
<td>11/02/91</td>
</tr>
</tbody>
</table>
which shows that the records in this new file are arranged in the order of start date, eight the earliest dates first.

Enter USE PERSONL to close this database and reopen the original. Next we'll look at some examples using the SORT command. For an example, use the SORT command to alphabetize the personnel database by employees' names. Enter the following:

```
USE PERSONL
SORT TO PERSONL 3 ON NAME
```

To see the results of the sort operation, we must close the old database and open the new database. Try the following commands:

```
USE PERSONL 3
LIST Name
```

The results are shown below:

<table>
<thead>
<tr>
<th>Record #</th>
<th>NAME</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Gour</td>
</tr>
<tr>
<td>2</td>
<td>Jakir</td>
</tr>
<tr>
<td>3</td>
<td>Jayed</td>
</tr>
<tr>
<td>4</td>
<td>Mahbub</td>
</tr>
<tr>
<td>5</td>
<td>Keya</td>
</tr>
</tbody>
</table>

The old file, PERSONL, still exists in its unchanged form. The sorting operating has created a new file, called PERSONL3, that is in alphabetical order. Remember, the file that in use cannot be overwritten during the sort process; each time a sort is performed, a new file must be created. Enter USE PERSONL and try the SORT command with the/D option (for descending order) on the Name filed by entering:

```
SORT TO PERSONL4 ON Name /D
```

To see the results, you need to list the new file you created. Enter:

```
USE PERSONL4
LIST Name
```
The results should be

<table>
<thead>
<tr>
<th>Record #</th>
<th>Name</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Keya</td>
</tr>
<tr>
<td>2</td>
<td>Mahbub</td>
</tr>
<tr>
<td>3</td>
<td>Jayed</td>
</tr>
<tr>
<td>4</td>
<td>Jakir</td>
</tr>
<tr>
<td>5</td>
<td>Gour</td>
</tr>
</tbody>
</table>

Before going on to consider the topic of sorting on multiple fields, you may want to perform some housekeeping by deleting the example files you just created. This easily be done from the command level. First, enter USE PERSONL to close the file you are currently working with and open the original PERSONL database. (Database files must be closed before you can erase them.) Then, enter

```
RUN DEL PERSONL2.*
RUN DEL PERSONL3.*
RUN DEL PERSONL4.*
```

to erase the database and accompanying memo-field files.

A Caveat

Sorting is somewhat slower than indexing. Sorting also uses considerable disk space, since each sort essentially duplicates the original database. You can accomplish the same result of keeping databases in order and use considerably less disk space if you use index files.

Indexing using FoxPro

An index file allows you to define the order of the records in your database without changing the database. Whenever you need to arrange the information in the database for reports or mailing labels, simply build a different index file. An index file consists of at least one field from a database. The field is sorted alphabetically, numerically, or chronologically. With each entry in the field is the corresponding record number from the parent database. The record number is used to reference the record in the parent database. In effect, an index file is a virtual sort of the parent database, since none of the records in the parent database are sorted.

To get a better understanding of an index file and its use, consider the index in the of a book. If you wish to find information on a specific subject, you can hold your page and look for the subject and corresponding page number in the back of a book. Just as a book index is
a separate section that indicates where information is located, a FoxPro index file is a separate file that contains information regarding the location of individual records in the parent database. When the database file is opened along with the index file, the first record to be retrieved is not the first record in the parent database, instead, it is the first record listed in the index. The next record retrieved will be the second record listed in the index and so on. Remember, indexing does not affect the order of the parent database.

### Types of Index

FoxPro supports two different types of index file: the single index file and the compound index file.

#### Single Index Files

Version 1 FoxPro supported only one type of index, the single index file. Each index was kept in a separate file, with the extension .IDX. If you wanted the index to be kept up to date, you had to open each of these index files explicitly whenever you added data to or edited the database file.

Needless to say, opening the indexes was a bit of trouble. Often, people would forget to open all the indexes when they were entering or editing a small amount of data. Then, when they used the file later with an order determined by an index that had not been updated, the records they had added would not be visible.

#### Compound Index Files

Version 2 of FoxPro added a second type of index to eliminate this problem. Unlike IDX files, each of which can hold only one index, compound index (CDX) files can hold multiple indexes in a single file. Each index in a compound index file is called an index tag.

#### Structural Compound Indexes

One special type of compound index is called a structural compound index, which is opened automatically whenever you open the database file it applies to. A structural compound index is automatically given the same name as the database file, with the extension .CDX. (Compound indexes other than the structural compound index are called independent compound indexes, and they cannot be given same name as the file).
Editing, Sorting/Indexing and Queries

For most purposes, it is easiest to use a structural compound index file for all your indexes. All the indexes are updated automatically whenever you update the file, without your having to take the time to open them and without any danger of your forgetting to open them.

**Compact Indexes**

In addition to compound index files, FoxPro 2 adds one other major improvement in indexing: compact indexes, which take up much less disk space than the IDX indexes used by version 1. The fact that these indexes are smaller saves you disk space. It also improves performance because FoxPro spends less time reading the index from disk.

### Indexing with the INDEX Command

From the command level, the general format of the INDEX command is similar to the format of the SORT command:

```
INDEX ON <field exp>
   TO <.IDX> | TAG <tag name> [OF <.CDX file>] 
   [FOR <expL>] 
   [COMPACT] 
   [ASCENDING|DESCENDING] 
   [UNIQUE] 
   [ADDITIVE]
```

The basic format for the index command with the to clause in INDEX ON filename to index file name.

When you use the INDEX command with the TO clause, FoxPro produces a single IDX index file containing the index information. The extension IDX is added to all noncompound index files. When you use the TAG clause, FoxPro adds the index tag to the named compound index file (or, if none is named, to the structural compound index file). The basic format for the INDEX command is INDEX ON filename TAG index-file name.

The first format creates an index file based on the named field, with all records included in the index. The second format creates an index tag, and because no compound index file is named, the tag will be added to the structural compound index file (the one with the same name as the database file).

When you use the UNIQUE clause you are telling FoxPro to create an index that will exclude all duplicates. For example, if a social security
field were used to build the index, and two records contained the same social security number, the second occurrence would be omitted from the index. The FOR expression lets you build a selective index that contains only those records that meet the condition specified by the FOR clause.

To illustrate the use of the INDEX command, here we will create an index for the personnel database. As an example, use the following commands to index the personnel database by city.

USE PERSONL
INDEX ON District TAG Districts

The index you just created will arrange the personnel database in order by District.

Enter LIST Name, District and you will see the result of the new index file:

<table>
<thead>
<tr>
<th>Record #</th>
<th>NAME</th>
<th>DISTRICT</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Keya</td>
<td>Dhaka</td>
</tr>
<tr>
<td>2</td>
<td>Jakir</td>
<td>Dhaka</td>
</tr>
<tr>
<td>3</td>
<td>Jayed</td>
<td>Dhaka</td>
</tr>
<tr>
<td>4</td>
<td>Mahbub</td>
<td>Dhaka</td>
</tr>
<tr>
<td>5</td>
<td>Gour</td>
<td>Tangail</td>
</tr>
</tbody>
</table>

Notice that the record numbers that indicate the order of the records in the database itself are not in order. The command you entered creates an index containing the index information. Any index you create is automatically made active immediately after its creation. Hence, the order of the records displayed with the LIST command is now controlled by the new index.

It's good practice to give index files or tags a name related in some manner to the field that has been indexed. This helps you and others keep track of how the database file was indexed and what field was used.

Creating Simple Indexes Using the Index Dialog Box

You can create simple index using the Index Dialog box. Let's say you need to use the records of personal database in Social security number. Steps to create these indexes are given below.

1. To open database file.
   - Select File.
   - Select Open
   - Select personal dbf from the open dialog box.
Editing, Sorting/Indexing and Queries

A database must be open before you can create an index for it.

2. To create the index file.
   - Select File
   - Select New
   - Select the Index radio button in the New dialog box.
   - Select the default push button.

3. The Index dialog box appears, select so-sec-num. from the fields list:
   Either double-click it with mouse or highlight it and select the Add to Index List Push button. Note that so-sec-num. appears in the Index key box with an up ward pointing arrow to its left to indicate that you are indexing in ascending order. In the Output File box, Select the Single File radio button.

4. Finally name the index file, you would simple edit the name as so-sec-num. IDX in the text box in the right of the Save As Push button.

5. To look at the file.
   - Select database
   - Select Browse
   - Scroll right unit you can see so-sec-num. "Code order,
   - Close the Browse window.

6. Now, create an index on start-date filed, but make it a tag of the structured compound index.
   - Select File
   - Select New
   - Select Index Ration button in the index dialog box.
   - Select the default push button.
   - Select start-date from the Fields list.
   - Select the Add to Index List Push button.

   Suggested tag name are displayed. The compound index File radio button in the output box should be selected by default. Note that the name of the index is automatically displayed as C\ because the structured CDX file must have the same name as the database file.

   Select the default push button OK, to rent this index tag.

7. Look at the File Note that the records are now listed from the earliest to most recent date.
**Indexing on Multiple Fields**

The process for creating indexes based on several fields is similar to sorting on multiple fields. There is a limitation, however: You cannot directly index on multiple fields that are not of the same field type. For example, you could not index by name and start date, because start date is a date field while name is a character field. There is a way around this, and it will be discussed later in the chapter.

The technique can be used to create an index file on a number of fields, use the plus (+) symbol along with the INDEX command to combine the fields. For example, the following INDEX command.

```
INDEX ON name + So-See_num TO name-So-see.
```

In the index, records having the same name are now indexed by names and then by So-sec-num.

Now enter LIST name, So-see-num to the results:

<table>
<thead>
<tr>
<th>Record #</th>
<th>name</th>
<th>So-see-number</th>
</tr>
</thead>
<tbody>
<tr>
<td>4</td>
<td>Ballou</td>
<td>Joseph</td>
</tr>
<tr>
<td>2</td>
<td>Jackson</td>
<td>Debra</td>
</tr>
<tr>
<td>3</td>
<td>Jackson</td>
<td>Phillip</td>
</tr>
<tr>
<td>8</td>
<td>Lord</td>
<td>Scott</td>
</tr>
<tr>
<td>6</td>
<td>Murray</td>
<td>John</td>
</tr>
<tr>
<td>1</td>
<td>Saeedi</td>
<td>Maryann</td>
</tr>
<tr>
<td>5</td>
<td>Shelorson</td>
<td>Mildred</td>
</tr>
<tr>
<td>7</td>
<td>Tahan</td>
<td>Joseph</td>
</tr>
</tbody>
</table>

Multiple indexes are useful aids when you are working with large database and must organize them into comprehensible groups.

**Indexing on Fields of Different Types**

You cannot index directly using multiple fields of different type (such as character and numeric). To get around this problem, make use of the FoxPro functions to covert fields that are not character data into character data. Functions are used to perform special operations that supplement the normal FoxPro commands. For indexing you will need to use one of two functions: the DTOS () (Date-To-String) function, or the STR () (String) function. The DTOS () function converts the contents of a date field into a string of characters that follow a year-month-day format. The STR () (function converts the contents of a numeric field into a string of characters. You can use the DTOS () and STR () function in combination with your index commands to accomplish the result of
indexing on combinations of different types of fields. The normal format for an index command, when combined with these functions, would be

```
INDEX ON character fields + STR (numeric field) + DTOS (date field) TO index-file name
```

**Note**: You can also use these functions within the menus by manually entering the functions along with the field names in the index expression window.

### Using the SET INDEX and SET ORDER Commands

A database can be opened with more than one index. However, the order in which the records appear or are controlled by only one index. For an index to control the order of the records, it must be active. You can easily tell which indexes are in use at any time by using the LIST STATUS and LIST DISPLAY commands. As index that has just created is active, and the SET INDEX command makes a dormant index active. The SET INDEX command is the command-level equivalent of choosing Open from the File menu and selecting Index from the Type button in the dialog box that appears.

Suppose that you need two lists from the PERSONL database. The first list must be in order by start date and the second by name. To create the indexes from these fields, enter the following commands.

```
INDEX ON start date TO stdate
INDEX ON name TO NAMES
```

These commands create two indexes on your hard disk: stdate and NAMES. Each index file contains the appropriate field from each record and the corresponding record numbers. NAMES, for example, contains names in alphabetical order and the matching record numbers for each name. Since NAME was the last index created, it is the active index.

By using the SET INDEX command you can activate any index. For example, to activate and display the database organized by start date instead of by name, enter

```
SET INDEX TO stdate
LIST name, start date
```
The display should appear as follows:

<table>
<thead>
<tr>
<th>Record #</th>
<th>Name</th>
<th>Startdate</th>
</tr>
</thead>
<tbody>
<tr>
<td>2</td>
<td>Jackson</td>
<td>0</td>
</tr>
<tr>
<td>7</td>
<td>Tahan</td>
<td>0</td>
</tr>
<tr>
<td>1</td>
<td>Saeedi</td>
<td>1</td>
</tr>
<tr>
<td>8</td>
<td>Lord</td>
<td>1</td>
</tr>
<tr>
<td>3</td>
<td>Jackson</td>
<td>2</td>
</tr>
<tr>
<td>4</td>
<td>Ballou</td>
<td>2</td>
</tr>
<tr>
<td>5</td>
<td>Shelorson</td>
<td>2</td>
</tr>
<tr>
<td>6</td>
<td>Murray</td>
<td>2</td>
</tr>
</tbody>
</table>

The records have been indexed chronologically by startdate using the stdate index.

You can also activate an index using the SET ORDER command. With SET ORDER, you use numbers, for example, SET ORDER TO 2. The number indicates the order in which the index file was originally opened. Enter the command,

SET ORDER TO TAG tagname

where tagname is the name for the index tag. If example, you entered USE PERSONL INDEX NAME, Stdate to open the files, the Stdate index would be the second index opened; therefore, entering SET ORDER TO 2 would make Stdate the active index file.

Exercise:

Questions for short answers:

1. Write the advantages and disadvantages of sorting and indexing.
2. What is structural compound index file? why compound index is better than single index?
3. Explain in brief how index can be done on fields of different types.
4. What is the function of SET ORDER command?
Lesson 3 : Performing Queries

Learning Objectives

On completion of this lesson you will be able to learn:

- the anatomy of an expression
- how to perform queries.

The Anatomy of an expression

In FoxPro, a query must include a logical expression; that is, an expression that evaluates to either true or false.

District = "DHAKA" .OR. District = "TANGAIL"

FoxPro will first look at the District field in each record to see if it contains the characters "DHAKA". If the characters are not found, it will look at the record to see if the characters "TANGAIL" are found. If either set of characters is found, the expression is evaluated to true. Otherwise, the expression is false.

Expressions may contain one or more functions and operators. Functions are used to perform special operations that supplement the normal FoxPro commands. Operators are symbols used to indicate the performance of an operation. In the above example, the = operator is used to symbolize equivalency. FoxPro uses four types of operators: relational, logical, arithmetical, and string.

Relational Operators

Relational operators are used in expressions to make comparisons on various types of data, such as numerical, character, or date data types. For an expression to be valid, the comparison must be made on the same data type. For example, using the following expression with the numerical field Total.

Total > "SIXTY"

Would produce an error message in FoxPro, telling you that there was a type mismatch. This is because you were attempting to compare a numerical filed and a character string.
In the above expression, the > operator is used to indicate greater than. Table 1 lists the relational operators used in FoxPro.

"Jakir" $ Name

In this case you are looking for all records that contain "Rahim" in the Name field.

<table>
<thead>
<tr>
<th>Operator</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>=</td>
<td>Equal to</td>
</tr>
<tr>
<td>&lt;&gt; or #</td>
<td>Not equal to</td>
</tr>
<tr>
<td>&lt;</td>
<td>Left operand is less than right operand</td>
</tr>
<tr>
<td>&lt;=</td>
<td>Left operand is less than or equal to right operand</td>
</tr>
<tr>
<td>&gt;</td>
<td>Left operand is greater than right operand</td>
</tr>
<tr>
<td>&gt;=</td>
<td>Left operand is greater than or equal to right operand</td>
</tr>
<tr>
<td>$</td>
<td>Substring comparison</td>
</tr>
<tr>
<td>= =</td>
<td>Character string comparison (trailing blanks are significant when EXACT is ON)</td>
</tr>
</tbody>
</table>

Table 9.1 : FoxPro Relational Operators and Their meanings

**Logical Operators**

Logical operators are used to build complex expressions. For example, to determine the number of employees at least 25 years of age, you would use the following expression:

```
AGE >= 25
```

But what if you needed to determine the number of employees at least 28 years old but less than 45. The following complex expression would be appropriate.

```
AGE >= 25. AND. <=45
```

Keep in mind when using these operators that .AND. will generally narrow your search and .OR. expand it.

Table 2 contains a list of the logical operators used by FoxPro. With the exception of land () older versions of FoxPro require logical operators be surrounded by periods. In FoxPro 2.5, the periods are optional.

<table>
<thead>
<tr>
<th>Operator</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>()</td>
<td>Used to group expressions</td>
</tr>
<tr>
<td>.NOT.</td>
<td>Must not meet condition</td>
</tr>
<tr>
<td>!</td>
<td>Must not meet condition</td>
</tr>
<tr>
<td>.AND.</td>
<td>Must meet both conditions</td>
</tr>
<tr>
<td>.OR.</td>
<td>Must meet either condition</td>
</tr>
</tbody>
</table>

Table 9.2 : FoxPro logical Operators and Their meaning
Arithmetical Operators

Arithmetical operators can be used to construct numerical expressions. Here are some examples of numerical expressions.

\[
\text{WEIGHT} = 2 \times 75 \\
\text{WEEKLY} = (20 \times 160) / 4 \\
\text{Total} = ((50 + 90) / 3) \times 5
\]

Table 9.3 Shows the complete list of arithmetical operators and their meanings.

<table>
<thead>
<tr>
<th>Operator</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>()</td>
<td>Used to group expression</td>
</tr>
<tr>
<td>**</td>
<td>Exponentiation</td>
</tr>
<tr>
<td>^</td>
<td>Exponentiation</td>
</tr>
<tr>
<td>*</td>
<td>Multiplication</td>
</tr>
<tr>
<td>/</td>
<td>Division</td>
</tr>
<tr>
<td>+</td>
<td>Addition</td>
</tr>
<tr>
<td>-</td>
<td>Subtraction</td>
</tr>
</tbody>
</table>

Table 9.3: FoxPro Arithmetical Operators and Their meanings

String Operators

There are only two string operators in FoxPro, and both are used to perform string concatenation. The first operator, plus (+), joins two strings together, regardless of trailing blanks in the first string. For example, the expression

"Dhanmondi" + "Lake"

would appear as

"Dhanmondi Lake"

The second operator (-) is used to concatenate strings, removing any trailing blanks from the first string. In the above example, replacing the + with -, would produce the string: "Dhanmondi Lake."
Functions

FoxPro uses functions to perform a variety of operations, from converting data types to performing math operations. When a function is used to perform an operation it usually returns a value. For example, in lesson 2, "Sorting and Indexing a Database," the STR () function was used to convert a number field to a character string. In this case, the value returned is actually the converted data.

Functions are also used to return system information, such as the date or time. For example, enter the following into the command window:

```plaintext
? TIME ( )
? DATE ( )
```

You should be presented with the current system date and time. Note that all functions end with parentheses, but some functions do not require expressions between the parentheses. Note also the use of the? command. This command evaluates an expression and prints the result.

FoxPro uses another group of functions to test certain conditions and return a value of true (.T.) or false (.F.). They are called logical functions and can also be used at the command level. The DELETED () function is a good example. This function returns true (.T.) when a record has been marked for deletion.

Now that you are familiar with the anatomy of an expression, it is time to use some expressions with the FoxPro commands.

Performing Queries

Querying the database will usually involve one of two scenarios: the selection of a single record or the isolation of a subgroup of records (a process often followed by the printing of a report). If you wish to retrieve a single record, the Locate and Seek commands, found on the Record menu, and also accessible at the command level, are what you want. To follow along with the examples in this lesson on your computer, enter USE PERSONL in the Command window to open the personnel database.
Locate

Locate will find the first occurrence of a record. To locate a record, open the Record menu with ALT-R and choose Locate. The dialog box that appears next contains three options: Scope, For and While. The Scope option reveals yet another dialog box with four options: All, Next, Record, and Rest. The optional use of a scope lets you define a limit to the operation of Locate. You can choose All (to specify that the use of Locate should span all records; this is the default). You can choose Next and then enter a number, which specifies a group of records starting with wherever the pointer is now located (for example, entering 10 would tell Fox Pro to limit its use of Locate to the next ten records); You can choose Record and enter a number, which again selects a specific record by its record number. Or you can choose Rest, which limits the use of Locate to all records located between the pointer and the end of the file.

If you select either the For option or the While option, the Expression Builder dialog box appears. Field names, which are normally used to build search expressions, can be selected from the Field names, which are normally used to build search expressions, can be selected from the Field Names box at the lower-left corner of the dialog box. Once a name is selected, it appears in the FOR Clause or WHILE Clause window. As an alternative, you may choose to enter the field name in the FOR Clause or WHILE Clause window by typing it.

You can select an operator, such as =, by clicking on the Logical box and selecting the operator from a pulldown menu. However, it usually faster to simply type the symbol into the FOR Clause box. Note that logical functions as well as operators are listed on the menu. FoxPro groups the functions and operators on these menus by data type.

Enter the desired search value. Text expressions are always entered surrounded by quotes, numbers are entered exactly as they are stored in the numeric field, and dates may be entered using brackets ({}), the CTOD () function. For example, CTOD ("12/20/93") would be evaluated as a date value of 12/20/93. You can also use memo fields within your conditions when searching for a value.

You can check your expression for correct syntax, if desired, by tabbing to or clicking on the Verify button. If the expression is a valid one, FoxPro will display an "expression is valid" message. TAB to or click on the OK button to finish your entry. The Locate dialog box will reappear, with the For option selected. You can now TAB to or click on the Locate button to implement the search. Remember that the process only locates the record but does not display it. You can now choose the Change option of the Record menu to view the record.
To locate Rahim as an employee in personal database:

- Select File
- Select Open
- Select PERSONAL.DBF
- In order to see the pointer being moved by the commands, open the Browse window by selecting Database and then Browse
- Select Record
- Select Locate to display the locate dialog box
- Select the For push button to display the expression builder.
- To generate a logical expression in the box, first select the string pop up control, and then select UPPER () from the list that pops up. Select Name from Filed Name list Select the logical pop up control again, and select = from the list that pops up. Select the string pop up control again, and select "text" from the list that pop up. Type Rahim in the quotation marks that have appeared.

(Alternatively, you could type the expression UPPER (NAME) = "RAHIM").

- Select OK
- Select locate, the pointer moves to the next
- Record with the name of RAHIM.
- Select Record.
- Select continue to move the pointer to the next.
- Record with the name of RAHIM.

**Note**: You can also use LOCATE and COUNTING, without opening the Browse window, to move the pointer without its being visible to the user. This is off in essential in programming, when you want the user to be able to search for a given record to view or edit it but don't want to give the user access to the entire file.

**The Continue Option**

To find the next occurrence of the same search term, use the Continue option on the Record menu. This option is helpful because the first record located may not be the record desired. Choosing the Continue option will continue the search, seeking the next record that meets the condition you specified when using Locate. If no further records meet the specified condition, you will see an "End of Locate scope" message on the screen. (you will see the same error message if an initial use of Locate fails to find a record).
The Seek Option

Records can be found faster than the LOCATE command can manage if you use the Seek option. The Seek option is available from the Record menu only if an index is active. When you open the Record menu and select Seek, the Expression Builder appears, containing a Value to Seek window. You use the Expression Builder appears, containing a Value to Seek <expe> window. You use the Expression Builder in the same manner as you did with the For option: Just enter the desired expression into the Value it Seek window. However, you only need the expression itself and not the field name, if we needed to find Rahim (an employee in our database), we could first index the database by last name by entering.

INDEX ON name TO NAMES

and then opening the Record menu with ALT-R and choose the Seek option. When the Expression Builder dialog box appears, enter "Rahim" into Value to Seek window.

Note: Instead of entering name = "Rahim", as was done with Locate, you would only enter "Rahim" in the Value to Seek window, assuming the active index is based on name. Remember that since Seek is designed to work with an index, you must search for data based on the index. (You could not, for example, use Seek to search for a name if the database were indexed only by social security number).

After entering the search value, TAB to or click on the OK button, and the seek will take place. You then enter EDIT in the command window to view the desired record. Keep in mind that the Seek option finds the first occurrence in the index. If there are duplicate occurrences of that index expression, such as more than one Rahim in a file indexed on name only, you may want to use Browse to aid you in finding the desired record.

The SEEK Command

The SEEK command is similar to the seek option on the record menu it is only necessary to enter the search value. The format of the SEEK command is SEEK <expression>.

Expression can be a number, a character string or a variable. The expression can be combination constants, variables, and operators (including functions). The SEEK command will search the active index file and find the first record matching your specifications. The record itself will not be displayed, the SEEK command will simply move the record pointer to the desired record.
Exercise:

Questions for short answers

1. Write the format of the SEEK command. What is an Expression?
2. Write the function of string operators + and - o. What is the difference between them?
3. How many types of operators are? Write the names of all types of operators.
4. Why SEEK command is faster than LOCATE command?
5. What are the function of $, AND, OR, and ** operator?
Unit : 10 Designing and Printing Reports

Introduction

Generating reports is one of the most frequent operations performed with a database. In this chapter we'll focus on techniques for creating, modifying, and printing reports. This will include a detailed discussion of FoxReport, FoxPro's Report Generator.

Lesson 1 : Report - I

On completion of this lesson, you will be able to learn:

- how to examine the Report Layout
- how to create a Report
- how to enhance the Report Layout Window
- how to enlarge Bands and Moving Text Objects.

Examining the Report Layout

Report layout consists of the five major sections within the window. These are called bands and they identify placement areas for specific types of information. Within these bands you can place fields, text and simple graphics, such as boxes.

- The Title, which contains information that appears once at the beginning of the report - for example, report titles, introductory information, or a cover page.
- The page Header, the area at the top of each page, often used to display information such as report titles, dates, page numbers, and column headings.
- The Detail, which shows the data from the table file. Its contents are repeated for each record that has been selected for reporting.
- The Page Footer, which is similar to the Page Header, except that it appears at the bottom of each page and often contains page numbers or other organizational information.
- The Summary, which contains information that is displayed at the end of the report, such as bottom-line totals. This band can also be used to provide concluding remarks.
- The seven buttons down the left border of the window comprise the Report Writer toolbox. (You'll learn about this feature later).
- Horizontal and vertical rulers, as well as grid lines, are displayed as aids to place text, field, and graphic objects.
- At the left end of each separator bar, there is a move button on the vertical ruler.
Creating a Report

You can use the Report Writer's Quick Report command to instruct FoxPro to place your table fields and field labels in the Report Layout window automatically. This often is the easiest way to begin customizing a report.

Generating a Quick Report

To generate a Quick Report

1. Choose File, New; click on Report; and click on New.
3. Check the Fields option.
4. In the Field Picker dialog box, select the desired fields, and click on Move to place the selected field names in the Selected Fields list box.
5. Click on OK to close the Field Picker dialog box.
6. Click on OK to close the Quick Report dialog box.
Designing and Printing Reports

AddingAliases

An alias is a name assigned to a table. The default alias for a table is the table name (without the DBF extension). A table's alias can be used to preface field names in the Report Layout window. If you design a report that you want use later with data from another table, then you might not want to include aliases in the Report Layout window.

- To add an alias, check the Add Alias option in the Quick Report dialog box.
- If you do not want an alias in your report, uncheck the Add Alias option.

Indexing in Reports

The order in which records are displayed in report depends on how the table is sequenced. For example, if you want to display records in alphabetical order by last name, you need to create or activate the appropriate index before you print the report.

Let's generate and examine a Quick Report:

1. Open the New dialog box (choose File, New), click on Report, and click on New to create a report associated with the indexed Payroll table.

2. Maximize the window, and observe the screen: The Report Layout window in empty, except, that the three default bands - Page Header, Detail, and Page Footer - are displayed. The Report Writer toolbox is displayed at the left of the window.

3. Choose Report, Quick Report to open the Quick Report dialog box. Notice that the Field Layout option for column layout is selected.

4. Uncheck the Add Alias option, so that no table-name alias is added to field names in the Report Layout window.
5. Check Fields to open the field Picker dialog box.
6. Under All Fields, select id, and click on Move to add the Payroll.id field to the Selected Fields list box.
7. Using the same method, add the dept fields to the Selected Fields list box.
8. Select the name, hours, and payrate fields (click on name; then press and hold Ctrl, and click on the other two field names).
9. Move all three fields to the Selected Fields list box (click on Move). The total number of fields is five, and the fields are displayed in the order in which you selected them.

10. Click on OK to close the Field Picker dialog box and return to the Quick Report dialog box. Notice that the Fields option is now checked.
Designing and Printing Reports

11. Click on OK to close the Quick Report dialog box.
12. Observe the report (scroll horizontally and back again, as necessary):
   The table fields are placed in the Detail band, in the order in which
   you selected them. In the Page Header band, field names are displayed
   above their corresponding fields. The date and page number are
   displayed in the Page Footed band.
13. Preview the Quick Report in Page Preview, and zoom in for a close-
   up view of the data. Notice that the records are displayed in order first
   by department and then by last name.

![Fig. 10.4: The Quick Report in Page Preview](image)

### Enhancing the Report Layout Window

With the Page Layout window displayed, the Report menu provides you
with a number of ways to enhance the appearance of your report. Table
10.1 describes some of these options.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Ruler/Grid</td>
<td>Allows you to display or hide ruler (grid) lines, specify the desired unit of measurement, and change the size of the alignment grid.</td>
</tr>
<tr>
<td>Show Position</td>
<td>A toggle that displays the numerical coordinates of the mouse pointer and the dimensions of selected objects in the status bar.</td>
</tr>
<tr>
<td>Snap To Grid</td>
<td>When this toggle is checked, objects are automatically aligned to the nearest grid line.</td>
</tr>
<tr>
<td>Page Layout</td>
<td>Allows you to specify the number, width, and space between columns, and to set a left margin.</td>
</tr>
</tbody>
</table>

Table 10.1: Report Menu Options
To display or hide ruler lines:

- Choose Report, Ruler/Grid
- Under Ruler Lines, click on Yes to display ruler (grid) lines; click on No to hide them.
- Click on OK.

To specify a left margin setting:

- Choose Report, Page Layout.
- Select the left-margin value.
- Type the new value.
- Click on OK.

Let's enhance the Report Layout window

1. Choose Report, Ruler/Grid to open the Ruler/Grid dialog box.

2. Under Ruler Lines, click on Yes, and then click on OK to display ruler (grid) lines in the Report Layout window. The ruler lines appear in each band as dotted, vertical lines, appearing at half-inch intervals.

3. Choose Report, Show Position to display the mouse-pointer coordinates and the dimensions of selected object in the statues bar. The numbers currently represent inches.

4. Open the Report menu, and observe the Snap To Grid option: This option is checked by default. With the Snap To Grid option checked, objects are automatically aligned to the nearest grid line when you move and size them.

5. Choose Page Layout to open the Page Layout dialog box.
Designing and Printing Reports

6. In the Left Margin text box, select 0.0000 (directly below the Columns text box), and type 1 to specify a left margin of 1 inch. Notice that the graphic Page Layout image changes accordingly to show you how the margins will appear on the printed page.

Fig. 10.6 Specifying a left-marring setting in the Page Layout dialog box.

7. Click on OK to close the Page Layout dialog box.

Enlarging Bands and Moving Text Objects

You create a report by placing report objects in the report bands. These objects will appear at different places on the printed page, depending on the band in which you place them. There are three types of report objects:

- **Text Objects** are any text that you type on the report, such as titles, labels, or column headings.
- **Field objects** represent the data that will appear in the printed report. Field objects can be actual fields from a table or calculated fields resulting from calculations of the data.
- **Graphic objects** are lines and boxes that you draw to enhance a report. Graphic objects also include pictures.

After you have placed the objects in the report, you can move them to enhance your report.

To move an object:
Office Automation

- Select it by clicking on it. A selection marquee (dotted rectangle) surrounds selected objects. You can select one object or a group of objects. To select a group of objects, press and hold the Shift key as you click on the objects.
- Drag the selected object(s) to the desired location in the report.

When you move a selection, the location and dimension coordinates displayed in the Report status bar are the horizontal and vertical positions of the upper-left and lower-right corners of the selection, as well as its height and width dimensions.

You can change the size of the bands in a report. To the left of each band-separator bar is a square button called the move button. To change a band's size, drag the move button until the band is the desired size.

Another way to resize a band is to double-click on the move button. A dialog box, in which you can specify the band height, opens.

**Hands on Practice**

1. a) Create a weekly pay report by using payroll.dbf.
   b) Display ruler lines.
   c) Specify new left margin.

2. **Analytical questions**

   a. How many report menu options are there in the lesson to enhance appearance of report?
   b. How many types of report objects are there in this lesson? Describe in brief.

*If you cannot answer these questions correctly and confidently, go through this lesson once again before proceeding to the text.*
Lesson 2 : Report - II

On completion of this lesson you will be able to learn:

- a Report Writer Toolbox
- how to save a Report
- how to print a Report
- how to format a Calculated Field.

Report Writer Toolbox

The Report Writer toolbox is the column of buttons that is displayed down the left border of the Report Layout window. You can use these tools to create report and label objects. To use a tool, click once or double-click on it; then move the mouse pointer to the desired location in the report.

A single click on a tool enables you to edit a single object; when you click in another area of the report, the program automatically selects the Selection pointer, turning off the tool you just used. Double-clicking on a tool enables you to edit (or create) multiple objects without having to click on the tool again.

When you click on the Fields or Picture tool, a dialog box opens, in which you can define the objects. (You'll get to use the Fields tool shortly). To return the mouse pointer to the usual arrow, click on the selection pointer.
Editing Text Objects

To edit a text object:

- Select (click or double-click on) the Text tool.
- Click on the text object that you wish to edit.
- Use standard text-editing keys to edit the text, as necessary.

Let's edit some text objects in our report:

1. In the Report Writer toolbox double-click on the Text tool. The double-clicking technique lets us edit several text objects without having to click again on the Text tool for each text object. The mouse pointer changes to an I-beam.
2. Immediately after the letter t in the Last text object, click once to place the insertion point, and press Enter to add a new line of text.
3. Type Name to change the text to Last Name. Notice that Name is displayed in bold letters, which is how Last was formatted.
4. After the Hours text object, click once and press Enter to add a new line of text.
5. Type Worked to change the text to Hours Worked.
6. Select the text payrate. (It should be highlighted in inverse video). Type Hourly to replace with Hourly.

Adding a Calculated Field to the Report

Calculated fields can be based on any expression that you build in the Expression Builder dialog box. For example, to calculate gross pay for all employees, you could insert a calculated field called "Grosspay" with the multiplication expression Hours * Payrate.

To insert a calculated field in the Report Layout window:

1. Click on the Field tool.
2. Click in the report, at the location in which you wish to place the new field.
3. Click on Expression.
4. In the Fields list box, double-click on the desired field.
5. In the Math drop-down list box, select the desired operator.
6. In the Fields list box, double-click on the next field to be entered in the expression. (Continue in this manner, as necessary, if you need to complete the expression).
7. Click on OK.
Designing and Printing Reports

Let’s insert a calculated field in our report that will calculate the gross pay for each employee:

1. Enlarge the Detail band to \(\frac{3}{8}\) inch (drag the move button).
2. Click on the Field tool. The mouse pointer changes to a cross-hair.
3. In the Detail band, click at the 4.5-inch marker on the horizontal ruler to place a field in the Detail band and open the Report Expression dialog box.
4. Click on Expression to open the Builder dialog box.
5. In the Fields list box, double-click on hours. The Fields list displays the fields from the Payroll tables. The field Payroll.hours is displayed in the Expression box.
6. From the Math pop-up, select * (asterisk). The asterisk is displayed in the Expression box.
7. In the Fields list box, double-click on payrate. The Expression box displays the complete expression for calculation gross pay from the Payroll table:

\[
\text{Payroll}. \text{hours} \times \text{Payroll}. \text{payrate}
\]

8. Click on OK to close the Expression Builder dialog box and return to the Report Expression dialog box. The Expression text box now displays the expression you defined in the Expression Builder dialog box.

9. Click on OK to close the Report Expression dialog box.
10. Drag the calculated-field object so that it is aligned with the other fields in the Detail band (if necessary).
11. Resize the Detail band to $\frac{1}{4}$ inch to display the records closer together in the report, and then compare your screen to Fig. 10.9.

Fig. 10.9: The Calculated field inserted in the Detail band.

Adding and Formatting a Text Object

After objects are placed in your report, you can enhance their appearance by choosing commands from the Object menu. For example, you can change the appearance of text by choosing Object, Font to open the Font dialog box and then making the desired selection.

Let's add and format a text object:

1. Click on the Text tool.
2. To place the insertion point, click in the Page Header band where the horizontal 5-inch and vertical 1-inch marks intersect.
3. Type Gross, press Enter, and type Pay to add the two-line heading Gross Pay.
4. Click on the Selection pointer, and select the text object Gross Pay. A selection marquee surrounds the text object.
5. Choose Object, Font to open the Font dialog box.
6. In the Font Style box, Style Bold. The Sample box shows you sample text with the applied formatting.
7. Click on OK to make the text object boldface.
8. Deselect the text object, and compare your screen to Fig. 10.11.

Fig. 10.10 : Formatting a text object

Fig. 10.11 : The added and formatted text object
Saving the Report

To save a report for the first time:

1. Choose File, Save As.
2. Type the desired file name.
3. Specify the desired drive and/or directory in which you wish to save the report.
4. Click on Save.
5. To save environment information (see below), click on Yes; to save only the report, click on No.

You can save, or set, the working environment for a report before you display the FoxPro Report Writer by opening the appropriate tables, activating indexes, and joining tables on common fields. FoxPro enables you to save the following information pertaining to the report environment:

- Tables that are open in any work area
- The selected work area
- Index orders set on open tables
- Relationships between tables.

To save environment information, choose Report, Page Layout, Environment, and click on Save in the Environment dialog box. Report environment information is saved in a file with the extension .FRX.

To update a file that you've previously saved, choose File, Save.

Let's save and preview our report:

1. Choose File, Save As to open the Save As dialog box.
2. Type myrept1 to name the report. (FoxPro will automatically attach the .FRX extension as it saves the file).
3. Click on Save. You'll see the message
   Save environment information?
   Foxboro can save the current environment settings along with your report, including the Payroll table, which is currently open, and any indexes that have been applied to the table.
4. Click on No to save only the report; the file name myrept1.frx is now displayed in the Report Layout window's title bar.
5. Scroll through the report and observe the Gross Pay data. Notice that the Gross Pay data include three decimal places, and they do not include dollar signs.
6. Click on Zoom Out. The 1-inch left margin is visible.
7. Click on OK to return to the Report Layout window.
Designing and Printing Reports

Printing a Report

FoxPro reports are saved in two files. One file has the extension .FRX, and the other has an .FRT extension. Both files have the same first name, which you assign. As with FoxPro table files, each report file contains different information about the same report. Therefore, in order for the report to print without undue acrobatics, both files should reside in the same disk directory.

To print a report:

- With the desired report displayed, choose Database, Report to open the Report dialog box.
- Under Output Location, uncheck Page Preview; then check To Printer.
- Click on OK.

When you print a report, Text, fields, and blank spaces will print as they have been placed in each band.

Let’s print our report:

1. Choose Database, Report to open the Report dialog box. Notice that the current report and its location are displayed in the Form box.
2. Under Output Location, uncheck (click on) Page Preview (the default option).
3. Check (click on) the To Printer option.
4. Click on OK to begin printing.

Enhancing the Report

FoxPro provides you with a number of important formatting techniques for enhancing the appearance of objects in your reports. (Remember, report objects are any text, pictures, fields, lines, and rectangles in your reports).

For example, you can design a template for numeric fields that will automatically print data with dollar signs and two decimal places. You perform all these enhancements in the Report Layout window. Tables 10.2 and 10.3 list some of the formatting options for the display of character and numeric data, respectively.
Character Data Formatting Options

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Alpha Only</td>
<td>Allows only alphabet characters.</td>
</tr>
<tr>
<td>To Upper Case</td>
<td>Converts all characters to uppercase.</td>
</tr>
<tr>
<td>Edit &quot;Set&quot; Date</td>
<td>Displays data in the current date format.</td>
</tr>
<tr>
<td>Trim</td>
<td>Removes all leading and trailing blank spaces.</td>
</tr>
<tr>
<td>Right Align</td>
<td>Prints data flush right within the fields.</td>
</tr>
<tr>
<td>Center</td>
<td>Prints data centered within the field.</td>
</tr>
</tbody>
</table>

Table 10.2 : Character Data Formatting Options

Numeric Data Formatting Options

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Left Justify</td>
<td>Begins numeric data in the leftmost position within a field.</td>
</tr>
<tr>
<td>Blank if Zero (Negative)</td>
<td>Leaves the field blank if the field output is zero.</td>
</tr>
<tr>
<td>Edit &quot;SET&quot; Date</td>
<td>Displays negative numbers in parentheses.</td>
</tr>
<tr>
<td>CR if Positive</td>
<td>Displays data in the current date format.</td>
</tr>
<tr>
<td>DB if Negative</td>
<td>Displays CR (credit) after a positive value.</td>
</tr>
<tr>
<td>Currency</td>
<td>Displays BD (debit) after a negative value.</td>
</tr>
<tr>
<td></td>
<td>Displays the current currency format (as specified in the Misc portion of the View window).</td>
</tr>
</tbody>
</table>

Table 10.3 : Numeric Data Formatting Options

Formatting a Calculated Field

In this Lesson you added a calculated field to your report. However, this field was not formatted correctly. (Even though the field calculated dollar figures, it displayed three decimal places and no dollar sign). To format a calculated field:

- Double-click on the field you wish to format.
- In the Report Expression dialog box, click on Format.
- Under Edit Options, select the desired format.
- In the Format text box, type the format as desired.
- Click on Ok to close the Format dialog box.
- Click on Ok to close the Report Expression dialog box.

If you are not currently running FoxPro, Please start it now. The application window should be cleared, and the default directory should be set to foxwork.
Let's open a new report; then we'll format a calculated field:

1. Open the payroll dbf database file. The report you'll be enhancing draws its data from this file.
2. Open the reptwk2.frx report file, and maximize the Report Layout window.

3. In the detail band, double-click on the field object Payrollhours * Payroll.payrate (only Payroll.hour is currently visible) to open the Report Expression dialog box. In the Expression text box, most of the expression now visible.
4. Click on Format to open the Format dialog box.
5. Under Editing Options, check Currency to add dollar signs to the data in the field.
6. In the Format text box, type 99,999.99 to make calculated data appear with four places to the left of and two places to the right of the decimal point. FoxPro uses the leftmost 9 as a place holder for the dollar sign.
7. Click on OK to close the Format dialog box and return to the Report Expression dialog box. Notice that @ $ 99,999.99 is displayed in the Format text box. This is how FoxPro stores the formatting choices you just made.
8. Click on OK to close the Report Expression dialog box.
Hands on Practice

1. a) Format the Payrate field object with the Currency option and 999.99 in the Format dialog box.
   b) Enlarge the Payrate field object so that the entire word.
   c) Enlarge the Payrate field object so that the entire word payrate is visible.
   d) Save and preview report.
   e) Print report.

2. a) On a new line below the Hourly text object, add the text Rate.
   b) Click on the Selection pointer, and then compare your screen.

If you cannot answer these questions correctly and confidently, go through this lesson once again before proceeding to the text.
Lesson 3 : Report - III

On completion of this lesson you will be able to learn:

- how to add a Report Band and Placing a Computed Field
- how to draw Rectangles and Lines
- how to add a Title in the Page Header Band
- how to group Report Date
- how to delete Objects in the Report Layout Window

Adding a Report Band and Placing a Computed Field

You might remember that the REPTEK.FRX report, contained a Summary band. You might also have noticed that our current report does not contain one.

The Summary band can be quite useful; it contains information such as totals and averages, which serve to summarize the main body of the report. For example, bottom-line totals are a common entry in the Summary band. Appropriately enough, the Summary band is displayed at the bottom of the report. Computed fields are placed in the Summary band to perform any of the calculations listed in Table 10.4.

Computed Field Calculation Options

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Nothing</td>
<td>Makes on computations.</td>
</tr>
<tr>
<td>Count</td>
<td>Counts the number of times a report field is printed per group, column, page, or report, based on the number of times the field occurs (not on field value).</td>
</tr>
<tr>
<td>Sum</td>
<td>Keeps a running total (additive sum) of the field values for a group, column, page, or report.</td>
</tr>
<tr>
<td>Average</td>
<td>Computes the average (arithmetic mean) of the field values in a group, column, page, or report.</td>
</tr>
<tr>
<td>Lowest</td>
<td>Displays the lowest value that occurs in the field for a group, column, page, or report.</td>
</tr>
<tr>
<td>Highest</td>
<td>Displays the highest value that occurs in the field.</td>
</tr>
<tr>
<td>Std (Standard Deviation)</td>
<td>Displays the square root of the variance for the values within a group, column, page, or report.</td>
</tr>
<tr>
<td>Variance</td>
<td>Measures and displays the degree to which the field's values vary from the average of all the values in the group, column, page, or report.</td>
</tr>
</tbody>
</table>

Table 10.4 : Computed Field Calculation Options
To add a Summary band in a report:

1. Choose Report, Title/Summary.
3. Click on OK.

To place a computed field in a report:

1. Click on the Field tool.
2. Click in the desired location to place the field object in the report.
3. In the Report Expression dialog box, check Calculate.
4. Click on Count.
5. Click on OK.
7. In the Fields list box, select the field to be used in the calculation.
8. Click on OK to close the Expression Builder dialog box.
9. Click on OK to close the report Expression dialog box and place the computed field in the report.

Let's add a Summary band to our report, and create a computed field that counts the total number of employee records included in the report:

1. Choose Report, Title/Summary to open the Title/Summary dialog box. This dialog box allows you to add a title or summary to your report.

![Fig. 10.15 : Title/Summary dialog box](image)

2. Under Report Summary, check Summary Band, and then click on OK to add a Summary band to the report.
3. Drag the Summary band move button downward, until the band is 1 inch high.
4. In the Report Writer toolbox, click on the Text tool (the capital A).
Designing and Printing Reports

5. Place the l-beam in the Summary band at 3 inches vertical and 3.15 inches horizontal (check the status bar for the location), and click once to place the insertion point.

6. Type Total Employees: to add a text object.

7. In the Report Writer toolbox, click on the Field tool (the lowercase ab).

8. To the right of the Total Employees text object (at 2.85 inches vertical and 5 inches horizontal), click once to place a field object. The Report Expression dialog box opens.

9. Check Calculate to open the Calculate Field dialog box.

10. Click on Count to select the operation, and compare your screen to Fig. 10.16.

![Fig. 10.16: The selected operation in the Calculate Field dialog box.](image)

11. Click on OK to close the Calculate Field dialog box.

12. Click on Expression to open the Expression Builder dialog box.

13. In the Fields list box, double-click on id. Payroll.id is displayed in the Expression box.
Office Automation

14. Click on OK to close the Expression Builder dialog box and return to the Report Expression dialog box. Notice that the field is now listed in the Expression box.

15. Click on OK to place the computed field. If necessary, move the field (by dragging) to align it evenly with the Total Employees text object.

16. Deselect the object (click in a blank area of the window), and then compare your screen to Fig. 10.18.

Fig. 10.17: The selection field in the Expression Builder dialog box

Fig. 10.18: The computed field placed in the Summary band.
Designing and Printing Reports

Drawing Rectangles and Lines

Adding rectangles and lines to your report can make certain information stand out, either by setting it apart from other data, or by separating different types of data. For example, a line could be drawn to separate headings from the data below them; or a rectangle could be drawn to enclose important summary information.

To draw a rectangle, rounded rectangle, or line:

1. In the Report Writer toolbox, click on the Rectangle or Rounded Rectangle tool to draw a rectangle; click on the Line tool to draw a line.
2. Move the mouse pointer to the location at which you wish to begin drawing the object, and drag to draw the object.

To Change to width of a line or rectangle border:

1. Select the desired object.
2. Choose Object, Pen.
3. Choose the desired width.

Let's add a rectangle and a line to the report layout:

1. Let's add a rectangle and a line to the report layout:
2. In the Summary band, beginning above and to the left of the Total Employees text object, drag a rectangle to surround the text object and its related field object. When you release the mouse button, the rectangle object is selected.

Fig. 10.19: The selected rectangle object
3. Choose Object, Pen to open the Pen submenu. Notice that 1 point is currently selected (checked). This is a very thin line. Let's make our rectangle stand out a bit more.

![Fig. 10.20: The Pen submenu](image)

4. In the Pen submenu, choose 2 Point. Notice that the thickness of the rectangle's border has increased.

5. Click on the Line tool (the two perpendicular lines). Notice that the mouse pointer becomes a cross hair as you move it into the report design.

6. In the Page Header band, beginning at the 1.25-inch vertical and the 0.00-inch horizontal marks (below the ld text object), drag a horizontal line to the right edge of the window (approximately 6.00 inches on the horizontal ruler). When you release the mouse button, the line object is selected. (If you find this difficult to do, try drawing the line from right to left instead).

7. With the line selected, choose Object, Pen, 4 Point to thicken the line. Then compare your screen to Fig. 10.21.
Designing and Printing Reports

Adding a Title in the Page Header Band

You can create a title in your report by inserting it as a text object.

Let's add and format a title in the Page Header band of the report, and drag the Date function object from the Page Footer band. This way, the report title and date will print at the top of every report page.

1. Click on the Text tool.
2. In the Page Header band, place the insertion point at the 0.25-inch vertical mark and the 2.00-inch horizontal mark (above the gap between Last Name and Hours Worked).
3. Type Weekly Pay Report to add a title to the report, and then click on the selection pointer to deselect the title text object.
5. Choose Object, Font to open the Font dialog box.
6. Under Font Style, select Bold.
7. Under Size, select 12 to enlarge the text size.
8. Click on OK to close the Font dialog box, and then deselect the text object.
9. From the Page Footer band, drag the DATE () function object to the Page Header, and center it under the report title. (The left edge to the object should be at the 2.50-inch mark on the horizontal ruler, and bottom of the text should be at about the 0.50-inch mark on the vertical ruler).
10. Deselect the object, and compare your screen to Fig. 10.22.
11. Choose File, Save to save the modified report design.
12. Page Preview the report, and zoom in to observe the following details:

- The report title and date are displayed at the top of the page.
- The Hourly Rate and Gross Pay fields display dollar signs.
- The Gross Pay field now has two decimal places.
- A line separates the column headings from the report details.
- The summary data at the bottom of the report is a computed field that counts the number of employee records.
- The summary data is enclosed in a rectangle.
- The Page Footer includes the page number (at the bottom-right corner of the page).

13. Zoom out to full-page view, and close Page Preview.

### Grouping Report Date

After you have arranged the record display in your report by indexing the report's tables, you can further arrange records by separating them into groups. An example of a single-group report is a report in which all the records in the same department are grouped together. In FoxPro, you can have up to 20 levels of groups in a report.

You must define a group band for each level of data that you want to group together. In each band, you must define the objects that will print the desired information.
Designing and Printing Reports

Adding a Group Header and Group Footer to a Report

Each group band has its own Group Header and Group Footer, either of which can include text, simple expressions, calculated fields, and graphic objects that you define. The Group Header information helps to identify the data included in the group. The Group Footer information can summarize or subtotal data included in the group.

Let's index the report's table by department, and add a Group Header and Group Footer to the Report:

1. Choose Database, Setup to open the Setup dialog box.
2. Select Payroll: Deptlast in the Indexes box, and click on Set Order to sort the table records by department and then last name.
3. Close the Setup dialog box.
4. Choose Report, Data Grouping to open the Data Grouping dialog box.
5. Click on Add to open the Group Info dialog box.
6. Click on Group to open the Expression Builder dialog box.
7. In the Fields list box, double-click on Dept to group the Report records by department. Payroll.dept is displayed in the Expression box.
8. Click on OK to close the Expression Builder dialog box and return to the Group Info dialog box. Payroll.dept is displayed in the Group box.

![Group Info dialog box](image)

Fig. 10.23: The selection group in the Group Info dialog box

9. Click on OK to close the Group Info dialog box and return to the Data Grouping dialog box. The selected group is also listed here.
10. Click on OK to close the Data Grouping dialog box. Notice that two bands are added in the Report Layout window: one for the Group header and one for the Group Footer, labeled Group Header 1: dept and Group Footer 1: dept, respectively.

Figure 3.25: The added Group Header and Group Footer bands.

Adding a Field Object to the Group Header Band
To add an object to the Group Header or Group Footer band, use the same techniques that you used to add object to the other report bands. However, before you do so, and whenever you are confronted with a report band for which only its separator bar is visible, it's a good idea to enlarge the band.

Let's enlarge the Group Header band; then we'll add a field object to it. This object will serve to print the appropriate department-name code at the beginning of each departmental group in the report.

1. Enlarge the Group Header band until it is a half inch high (drag the Group Header band's move button, and use the vertical ruler as a guide).

2. In the Group Header band, place a field object (click on the Field tool first) at the left margin. The Report Expression dialog box is displayed.

3. Click on Expression to open the Expression Builder dialog box.

4. In the Fields list box, double-click on dept to define the field object as from the Dept fields, and close the Expression Builder dialog box (click on OK).

5. Close the Report Expression dialog box and return to the Report Layout window (click on OK).

6. In the Group Header band, select the dept field object.

7. Open the Font dialog box (choose Object, Font).

8. Under Font Style, select Bold.

9. Under Size, select 12, and click on OK to close the Font dialog box.

10. Enlarge the dept field object so that it extends from the left margin to the 1-inch mark on the horizontal ruler (drag the right border of the object's selection marquee).

11. Deselect the dept field object, and compare your screen to Fig. 10.26.
Deleting Objects in the Report Layout Window

To delete one or more objects in the Report Layout window:

- Select the Object(s).
- Press the Delete key.

In the report layout, the Dept field is represented in three different bands. Let’s delete two of these objects from the Report Layout window:

1. In the Page Header band, select the Dept text object in the Page Header band.
2. While pressing and holding down the Shift key, click on the dept field object in the Detail band. Both objects are now selected.
3. Press Delete to delete both Dept objects. Only the Dept object in the Group Header band now remains.
4. Save the report as myreptg.
5. Page Preview the report, and zoom in for a close look at its details.
6. Scroll through the report. Notice that data is grouped by department. The department code at the beginning of each group appears bold and in a larger font.

7. Zoom out to full-page view, and close Page Preview.
8. Close the report.
Hands on Practice

1. a) Add a Summary band in a report.  
b) Place a computed field in a report.  
c) Add a Summary band to your report and create a computing field.

2. a) Draw a rectangle, rounded rectangle or line.  
b) Change to width of a line or rectangle border.  
c) Add a rectangle and a line to the Report layout.

3. a) Add a Group header and Group Footer to the report.  
b) Delete two objects from the Report layout window.

*If you cannot answer these questions correctly and confidently, go through this lesson once again before proceeding to the text.*
Unit 11 : Understanding the Screen Builder

Introduction

FoxPro screen builder is one of the most powerful and flexible programming tools. It lets you customize your database environment: screens you can design screens with field, text, boxes, push buttons, radio buttons, check boxes, popup controls, and scrollable lists, look and work like a equivalent features of FoxPro itself. By designing and creating your own screens, you can completely control the way you view, add and edit data.

Lesson 1 : Creating, Generating Code and Running of a Quick Screen Layout

On completion of this lesson you will able to learn:

- how to create a quick screen layout
- how to generate code
- how to run a screen.

Creating a Quick Screen Layout

You can create easily and quickly customize screens by creating and using quick screen before you start creating the quick screen, you can create the working environment by opening the necessary database, letting the index order.

To Create a quick screen:

- Choose New from the file menu
- Select screen in the New dialog
- Choose new. An untitled screen design Window appears.

You can use the command Window to create a new screen by typing

Create screen [<file name>]

If file name is not a screen design Window appears with UNTITLED.SCX as its title. You will be prompted to name the screen the first time it is saved.
Office Automation

Note: Screen design files end with .SCX and store a screens design object placement, font and type-size specifications and so on when you have completed a screen design, you use the screen design file to create, or generate, a screen program file ends with SPR.

- Choose quick screen ovation from screen menu bar. The quick screen dialog box opens shown in Fig. 11.1 (The quick screen dialog box).

![Quick Screen Dialog Box]

- Under field layout, click on the horizontal layout button (the left-hand button).

- Verify that Titles and Add Alias are checked. (If the Titles check box is checked, the name of each field is displayed as its title, to its left. If Add Alias check box is checked, the name or alias of the database file is added to the field names).

- If you select the Fields check box, you can use the familiar Field Picker dialog box to select which fields are included in the layout. If this box is not checked, all field are included.

- Selecting the Memory variables check box automatically creates memory variables for all the fields.

- Click on OK.
Observe the screen Design Window. Quick screen has added eight fields objects to the Windows, each identified by a test object bearing the appropriate field name.

Fig. 11.2: The Screen Design Window, After Using Quick Screen

- Save your screen design as Payrolls. From the File menu, select Save. Then a dialog box will be displayed.
- Click on Yes.
- Observe the title bar. ForxPro automatically adds .SCX to the screen design file name.

Generating Code

Once you have finished designing the screens, you will also need to generate program code based on the screen’s design if you want to make actual use of the screen.

To generate code:

- From program menu
- Choose generate. (The generate dialog box appears, as shown in Fig.11.3.
- Click Generate button from Generate Screen dialog box.
Office Automation

You can see the converted program code by clicking Open from File menu.

Fig. 11.3 : Generate Screen Dialog Box.

You can generate program based on multiple screens. The screen set scrollable list at the upper left of this dialog box lists all the screen layouts that will be used to generate the code, and the four push buttons next to it let you control this screen design.

- The Edit push button calls up the Screen Design window to let you change the design of whichever screen is selected in the list.

- The Add push button displays a dialog box with a scrollable list that lets you select screen design files to add to the list.

- The Remove push button lets you remove the selected file from the list.

- The Arrange push button displays the Arrange Screens dialog box.

Models of all the screen listed in the Generate Screen dialog box are displayed in the left panel. You can change the position of these screens by clicking-and-dragging them or by selecting the name of one of the screens in the popup control and then using the position spinners to position it. Alternatively, you can use the Center check box to center the selected screen.
Apart from these four buttons to let you control the screen set, the Generate Screen dialog box lets you name the output file where the code will be stored: Select the Output File push button to select among existing screen program files, or type a file name in the text box next to this push button. By default, the name is the same as the name of the screen design, but with the extension .SPR.

The Options push button displays the Options dialog box, shown in Fig.11.4 which lets you include features in the code. As you see, you can include the make and address of the developer, which will appear as a comment at the beginning of the code. You can specify whether comments have boxes around them or are surrounded by asterisks. When you are working with an entire project, you can also specify the location of the generated code and project options, such as whether debugging information is included, whether code in encrypted, and whether a logo is displayed when the application is run.

If you select the More push button, the dialog box also includes a Generated Code Options area, which includes a series of check boxes to control certain features of the code that will be generated:

**Open Files**: Code is generated to open the database files and indexes and to set relations at the beginning of the screen program.
**Close Files**: Code is generated to close the files at the end of the screen program.

**Define Windows**: DEFINE WINDOW commands are generated to define the windows in the screen.

**Release Windows**: RELEASE WINDOWS commands are generated to remove the definition of the windows from memory at the end of the screen program.

**Modal Screens**: A MODAL clause is included in the READ command so the user cannot access windows or other interface features that are not involved in the READ.

**Cycle Through Fields**: The command READ CYCLE is generated, rather than the ordinary READ command, so the READ does not terminate when the cursor moves beyond the last GET field (or before the first one), but continues to cycle through the fields.

**Auto Lock Current Record**: Automatically locks the record that is being edited to other users on a network, to prevent conflicts that could result in loss of data.

**Execute Multiple Reads**: A READ statement is generated between the format commands for each window, instead of a single READ CYCLE for all the windows.

### Run a Screen

Once you’ve generated a screen program file, you can use the program code generated by the FoxPro a (the .SPR file) by the following ways:

To execute using Menu:

- Select Run menu

- Choose screen observe the screen to Run list box. It lists the screen program file you just generated: Payrolls .SPR.

- Double-click on payrolls .SPR. The payrolls-screen opens as shown in Fig. 11.5.
Understanding the Screen Builder

To Execute using Command

You can use the program code generated by FoxPro (the SPR file) within your own program by entering the following command.

DO <filename>

The filename will be the screen program file i.e. Payrollscre .SPR that you have just generated. So the command will be as

DO Payrollsce .SPR

Hands on Practice

1. a) Create a quick screen using payroll.dbf.
   b) Generate code
   c) Run Payroll.spr.

Analytical questions

1. Write down the steps to generate quick screen.
2. What is the purpose of generating code? Explain how to generate code?
3. How many ways the screen Program file can be executed? Describe in brief.
Lesson 2: Introduction to Screen Builder Toolbox, Push Button and Rearranging, deleting and modifying screen objects

On completion of this lesson you will be able to learn:

- how to introduce the Screen Builder Toolbox
- how to rearrange the screen objects, moving field and text objects in pairs
- how to delete and modify screen objects
- how to introduce the Push Buttons.

The Screen Builder Toolbox

The toolbox is the column of buttons at the left of the screen Design Window. These tools allow you to create screen objects. When you select a tool, a description of the tool is displayed in the status bar.

![Screen Builder Toolbox Diagram]

Fig. 11.6: The Screen Builder Toolbox.
Understanding the Screen Builder

Using the Tools

Except for the selection pointer, each button in the toolbox represents a screen object. Check the appropriate tool and move the mouse pointer to the desired location in the Screen Design windows.

- For objects that require sizing, the pointer changes to crosshairs. Click in the appropriate location and drag until the object is the desired size.
- For objects that don’t require sizing, the pointer changes to resemble the selected tool. Just click in the appropriate location.
- For text objects, click where you want the first letter of the first line to text to be and type. When you are finished entering text, click the selection pointer.

A dialog is opened so that you can define control, field and edit region objects. After you exit the dialog, the cursor automatically reverts to the arrow of the selection pointer.

To create more than one of the same kind of object, double-click the appropriate tool. Then, you can include multiple objects without having to click the tool multiple times. When you finish adding objects, click the selection pointer tool.

Manipulation Objects

Selecting Objects

To select an object in the Screen Builder, click the selection pointer then click on the object. To select multiple objects, Shift+Click on each object or drag the selection marquee around several objects.

To use the selection marquee:

1. Position the pointer outside the objects to be selected.
2. Press the mouse button and drag the selection marquee around the desired objects.
3. Release the mouse button. All objects enclosed in or partially enclosed in the marquee are selected.

If you hold Ctrl while dragging the selection marquee, only objects completely enclosed in the marquee are selected.

You can select any combination of objects. When multiple objects are selected, they act as one object when moved, edited (cut, copied, pasted) or deleted.
Office Automation

Inverting Selected Objects:

You can invert selected objects with the selection marquee. When you invert objects, selected objects become deselected and deselected objects become selected.

1. Press the shift key, then drag the mouse to draw the marquee around the objects.
2. Release the mouse button. Objects that were selected are now deselected and objects that were deselected are now selected.

Deselected Objects:

To deselect all selected objects in the Screen Design window, position the pointer off the selected objects and click.

Sizing Objects:

A selected object has handles, which are small boxes in the corners and on the sides of the object. To resize the object, drag one of the handles until the object is the desired size.

To override the grid setting when sizing an object, hold down the Ctrl key while dragging the object handle. Use Shift+Arrow key to change the size of the object in single pixel increments.

Moving Objects:

To move an object, drag it to a new location or select it and use the arrow keys. If Snap to Grid is checked, the object will move according to grid setting when you drag it. The arrow keys move the object one pixel at a time, which is useful for “fine tuning” object positions.

When moving multiple objects, be sure the pointer is positioned on any selected object in the Screen Design window. Drag the objects to the desired location.

Deleting Objects:

To delete an object, select it and press Backspace or Delete or choose Clear from the Edit menu.

Changing Object Attributes:

You can change the font, type face, fill and color of a selected object by choosing menu options from the object menu. For more information, see the section on the Object menu later in this chapter.
Understanding the Screen Builder

Editing Text

To add or edit text in your screen, click the text tool then click in the screen Design window where you want to add or edit text. Make the desired additions or changes.

You can include multiple-line text objects in your screen. Press Enter to begin a new line to text directly under the existing line or lines. You can cut, copy and paste text while editing a text object.

You can change the font and color of text by selecting the appropriate option on the Object menu. For more information, see the section on the Object menu.

Double-clicking on a text object with the selection pointer opens the Comment dialog so you can add comments to the generated screen code. Comments are entirely for your reference and are ignored when the screen program is run.

Rearrange the screen objects, moving field and text objects in pairs

1. Observe the screen Design window. No grid (ruler) lines display the help you align objects.

2. Choose screen.

3. Select Ruler/Grid. The Ruler/Grid dialog box opens.

4. Under Ruler lines, click on Yes and click on OK. Grid lines now display.

5. Open the Data Base named Payroll.dbf.

6. Create the Quick Screen.

7. Click on the comments text object (to the left of the comments field object) to select it.
8. While pressing shift, click on the comments field object and then release shift. Both comments objects are now selected.
9. Drag both objects down and to the right, positioning both objects at appropriate place.

Fig. 11.7 : The Screen Design window, after using Quick Screen.

8. While pressing shift, click on the comments field object and then release shift. Both comments objects are now selected.
9. Drag both objects down and to the right, positioning both objects at appropriate place.

Fig. 11.8 : The Screen Design window, after moving the comments objects.
In the same way, rearrange the remaining screen objects as shown in Fig. 3.8. Use the shift selection method to select and then move matching text and field objects as pairs.

Fig. : 11.9 : Payrolls.scx after rearranging the remaining screen objects.

Save your screen design as payrolls.scx

Deleting and modifying screen objects

To hide data, simply delete the appropriate object or objects from the screen design.

To provide more room for viewing memo fields, you can add a list-box field object to your screen design. To accomplish this, you can use the Screen Builder toolbox’s List tool to place and define a list-box field control. Alternatively, if your screen design already contains a regular field object for a memo field, you can easily convert the regular object to a list box by selecting the object, and then dragging one of its sizing handles to enlarge it. FoxPro will automatically convert the regular object to a list-box object, complete with its own scroll bar.
Let’s modify your screen design, removing the Payrate objects, and converting the Comments field object to a list box:

1. Select both the **Payrate** text object and the **Payrate** field object.
2. Press Delete to remove both objects from the Screen Design window.
3. Select the Comments field object.
4. Drag the selected object’s button-right sizing handle to approximately the 2-inch vertical mark and the 4½-inch horizontal mark. FoxPro automatically converts the field object into a list box as shown Fig. 3.10.

5. Save the screen design.
6. Choose Program, Generate, and click on Generate to regenerate the Payrolls.spr screen-program file.
7. Click on Yes to update Payrolls.spr.
8. Run the modified Payrolls.spr screen program. Close the screen by pressing ESC after observing the screen.

**Push Buttons**

An asterisk is the specification code for a push button. Its picture function must begin with an asterisk followed by a list of the prompts used in the push buttons being created. For examples, to create two push buttons with the prompts OK and Cancel, you can use the clause PINTURE ‘*@ OK; Cancel’ or the clause FUNCTION ‘* OK; Cancel’. FoxPro adds the angle brackets around the prompts that are listed.
If you want the push buttons to have keys, put a backslash and less-than sign (\<) before the character to be used as a hot key. For example, if you use the clause PICTURE ‘@ \<yes;\No’, the user will be able to press Y or N to select Yes or No. If you want a push button disabled, put two backslashes (\\) before it in the list. If you want a default push button, accessible by pressing Ctrl + Enter, put a backslash plus an exclamation point (!) before it in the list, and if you want to let the user select one of the push buttons by pressing the Esc key, put a backslash plus a question mark (?) before it. For example, use the clause PICTURE ‘@* !OK;? Cancel’ to make OK the default push button and to let the user select Cancel by pressing Esc. You can also combine these features.

In the basic form of the command -

@<row,col> GET <var> FUNCTION <char exp> | PICTURE <char exp>

-the row and column numbers specify the location of the first prompt in the list. The name of the variable that is specified holds the user’s choice. If you define the variable as numeric, the number of the button the user selects is stored in that variable. In the example, if the user selects OK, the variable is assigned the value 1, and if the user selects Cancel, it is assigned the value 2. You must write the code that tells the program what to do based on the value of that variable.

- Select the Push Button tool.
- Click a location in the screen layout to display the Push Button dialog box, shown in Fig. 11.11, to generate this basic command and its optional clauses.

Fig. 11.11: Push Button Dialog Box.
The Type radio buttons let you choose among the three basic types of push buttons. You are familiar with normal push buttons and picture buttons. If you select Picture, you must use the Each Picture File push button to select the files the pictures are stored in. You can also create invisible buttons, described below.

You most frequently will create Normal push buttons. Their prompts are entered in the Push Button Prompts area, one prompt to a line. These can include \ codes used to define hot keys, default push buttons, and so on, as described above. A button with a double - headed arrow displayed to the left of each one you enter lets you change the order of the list in the usual way.

In the Options area, the Horizontal and Vertical radio buttons determine whether the push buttons are arranged one next to another or one above another.

The Terminate READ on Selection check box determines whether choosing any of these push buttons terminates the READ. By default, this box is not checked, and the user can continue to select other controls or to enter and edit text after selecting a push button. If this box is checked, the program continues with the line of code following the READ after the push button is chosen. You would want to select this box, for example, for the OK and Cancel push buttons.

The Space Between Buttons spinner lets you specify the spacing between push buttons. You can also specify the spacing by resizing the buttons after they are placed.

Use the Variable text box to enter the name of the variable the user’s choice will be stored in, or use the Variable push button if you want to select an existing variable. If the variable you specify does not already exist, FoxPro creates it and gives it a default value of 0.

The Initially Disable check box generates the optional clause DISABLE, which prevents the user from accessing the push buttons. Although they are visible on the screen, they cannot be selected. They can be enabled by the program.

The When push button lets you generate the optional clause WHEN <log var>. The push buttons can be selected only if the logical variable evaluates to true; otherwise, they are dimmed.
Understanding the Screen Builder

The Valid push button lets you generate the optional clause VALID <log var>. As mentioned earlier, a user-defined function is often used as this logical variable; it includes some code that makes use of the value the user entered.

The Massage push button lets you general the optional clause MESSAGE <char exp>, which displays the character expression as a Help message when the push button is selected.

The Comment push button lets you add a comment for your own use, as always.

Exercise

Analytical questions

1. How to show Grid/Ruler in screen design window?
2. Delete id from payroll.scx.
3. Write the basic form of push button command.
Lesson 3 : Creating and Programming for Push Button, Field and Edit Region Tool

On completion of this lesson you will be able to learn:

- how to create and make program for Push Buttons
- how to create Fields Tool
- how to Edit region Tool
- how to Create Edit Region.

Placing Push Buttons

Push Buttons are multiple choice buttons that resemble those used by the FoxPro dialog boxes. You normally used push button in a screen when you want the present the user with one of the several possible options.

One chief advantage of customizable push buttons is that you can use them to design screen that are simple enough to be used by people who know little or nothing about FoxPro. You can, for example, create push buttons that help users

- Move to the to first or last record
- Move to the previous or next record
- Add or delete a record
- Close a screen.

Placing a Quit Button

In almost any screen you create, you will probably want to add some sort of button that enables users to close screen. You can name the button practically anything you want for example. Quit, Close screen, just as long as the people who will use your screen will understand the buttons purpose.

To create, name, and place a push button

1. In the Screen Builder toolbox, click on the Push Button tool. (If you are planning to create multiple push buttons, you can double-click on the Push Button tool to select the lock the tool.)
Understanding the Screen Builder

2. On the Screen design, click where you want to place new push button. The Push Button dialog box will open.

3. In the Push Button Prompts list box, type the text that you want to display on the push button’s face; for example, Quit or Close Window.

4. In the Variable text box, type any number or single word. FoxPro uses this variable name for internal processing when it runs the screen. You variable name does not need to match your push-button prompt; for simplicity’s sake, though, you might want to keep the prompt and variable names similar. Do not use the same variable name for two push buttons on the same screen.

5. Click on OK. The push button will display where you first click bearing the prompt you typed.

To create and program a Quit button

1. Open the Payrolls.scx.
2. Click on the Push Button tool (the fifth tool from the top of the Screen builder toolbox).
3. Move the mouse pointer into the screen design. The pointer now looks like the Push Button tool.
4. Position the mouse pointer at approximately position.
5. In the Push Button Prompts list box, type Quit. This text will display on the push button’s face.
6. In the Variable text box, type Quit. FoxPro will use this name for its own internal-processing purposes when running the screen.
7. Under Option, check Terminate READ On Selection. This will instruct FoxPro to close the screen whenever the Quit button is clicked.
8. Click on OK to return to the Screen Design window.
9. Save your screen design.
10. Regenerate the MYSCRN.SPR screen-program file, replacing the existing MYSCRN.SPR
11. Run the new MYSCRN Screen.
12. Click on Quit. This time, the screen closes, returning you the Screen Design window.
13. Close the Command window.
To create and program prior button

To create a push button that moves you to the previous record:

1. Open Payrolls.scx
2. Click on the Push Button tool.
3. On the screen design, click where you want to place the new push button. The Push Button dialog box will open.
4. In the Push Button Prompts list box, type the text that you want to display on the button’s face; for example, Next record or Previous Record.
5. In the Variable text box, type a variable name.
6. Click on Valid to open the Code Snippet dialog box.
7. In the Valid list box, type:

```
IF NOT BOF() && If not the beginning of file.
SKIP -1 & &To program the button to move to the previous record.
ENDIF & & End of if.
SHOW GETS & & to refresh the screen and show you the contents of the new record.
```
8. Click on OK to close the Code Snippets dialog box.
9. Click on OK again to close the Push Button dialog box.
Understanding the Screen Builder

**In same way, create and program Next, Top and Bottom push buttons.**

Mark the following things for Next push button:

**Push Button Prompts:**
- **Next**
- **Variable** : Nt

**Valid Code Snippet**:

```
IF NOT EOF() && If not end of file.
    SKIP && Move the record pointer to.
    && the next record.
    ENDIF && End of if.
    SHOW GETS && Show the contents of new.
    && record.
```

Mark the following things for Top push button:

**Push Button Prompts:**
- **Top**
- **Variable** : Tp

**Valid Code Snippet**:

```
GO TOP && Move record pointer to the first.
    SHOW GETS && Show the contents of new.
```

Mark the following things for Bottom push button:

**Push Button Prompts:**
- **Bottom**
- **Variable** : Bt

**Valid Code Snippet**:

```
GO BOTTOM && Move the record pointer to last record.
    SHOW GETS && Show the contents of new record.
```

- Save your screen design.
- Regenerate the Payrolls.spr screen-program file, replacing the existing payrolls.spr.
- Run the new Payrolls Screen.
Fig. 11.13: The Completed Payrolls screen.

To place a field:

1. Click the filed tool
2. Click a location on the screen in FoxPro for Window to display the Field dialog box, shown in Fig. 11.14.

Fig. 11.14: Field dialog box.

This dialog box lets you place fields, field expressions, or memory variables on the screen and control their features.
Understanding the Screen Builder

Typically, the Input Field (Get) radio button is selected, and this dialog box generates the ordinary \@ \text{... GET <var>} command with a field name as the variable that is displayed. This field can be edited when the READ command is executed.

When the Output Field (Say) radio button is selected, most options in the dialog box are disabled. You can use the Output push button to select the variable to be displayed, and you can use the Comment push button and Refresh check box. The other options are dimmed, as they do not apply when a variable is just being displayed and cannot be edited.

Edit Regions

To add an edit region, select the edit region tool and then click-and-drag on the screen layout to place the edit region. When you release the mouse button, FoxPro displays the Edit Region dialog box, shown in Fig.11.15.

![Edit Region dialog box]

The selection generates the command \@ \text{... EDIT <var>}, which lets the user scroll through the data entry area to edit data that is larger than the area itself. This is particularly useful for editing Memo fields.

As you can see from Fig. 11.14 the push buttons in this dialog box are all the same as the push buttons included in the Fields dialog box, and it also has some check boxes in common with the Field dialog box.

The Scroll Bar on Edit Region check box places a scroll bar at the side of editing regions that at least two lines deep, to, make it easier for the user to scroll through the contents of the field.
Office Automation

The Allow Tabs in Edit Region check box lets the user enter the tab character within the edit field. If this box is not checked, pressing Tab moves the user to the next field; if it is checked, the user must press Ctrl + Tab to move to the next field.

To Create Edit Region

Edit region lets you change the information of database. It also allows you to add record into the database.

1. Open the database file named payroll.dbf.
2. Click on Field Tool.
3. Click on the screen where you want to place the field.
4. Click on Input ... push button.
5. Double click on the field ID.
6. Click on OK push button.
7. Click on OK push button.
8. Add NAME, DEPT, HIRTED, HOURS by repeating step 3 to step 7 and double clicking on the required field on step 5.
9. Click on Edit region tool.
10. Click on the screen where you want to place the Comment field.
11. Click on Input ... push button.
12. Double click on the field Comment field.
13. Click on OK push button.
14. Click on OK push button.
15. Arrange the Screen as shown in the Fig. 11.16.

Fig. 11.16 : Ed.sce after arranging the fields.
Understanding the Screen Builder

16. Create Add push button

Use the following settings to create Add push button

- Push Button Prompt: Add
- Variable: Ad
- Valid code snippet: APPEND BLANK SHOW GETS.

18. Create Top, Bottom, Prior, Next, Quit push buttons in same way you have created before
19. Save your screen design as Ed.scn
20. General Ed.Spr screen program
21. Run the Ed.spr. screen.

![Image](image.png)

Fig. 11.17: The completed Ed screen.

Exercise

**Analytical questions**

1. What are the chief advantages of customizable push button?
2. What helps the users may get from push buttons?
3. How to create a Quit button?
4. How to create a prior button?
5. What are steps of creating edit region?
Office Automation
Answers to MCQS :

Unit 1 :

Lesson 1 :
a). ii, b). ii, c). i
Lesson 2 :
Lesson 3 :
a). i, b). ii, c). ii

Unit 2 :

Lesson 1 :
a). ii, b). ii, c). iii, d). iii,
e). iv, f). i, g). ii
Lesson 2 :
Lesson 3 :
a). ii, b). iv, c). iv
Lesson 4 :
Lesson 5 :
Lesson 6 :

Unit 7 :

Lesson 1 :
a). i, b). ii, c). iii
Lesson 2 :
a). ii, b). iv
Lesson 4 :
a). i, b). i
Lesson 7 :
a). iii, b). ii
Lesson 9 :
a). i, b). iii
Office Automation
Appendix - A

List of the keyboard shortcuts

Changing font and font size

<table>
<thead>
<tr>
<th>To</th>
<th>Press</th>
</tr>
</thead>
<tbody>
<tr>
<td>Change the font</td>
<td>CTRL+SHIFT+F</td>
</tr>
<tr>
<td>Change the font size</td>
<td>CTRL+SHIFT+P</td>
</tr>
<tr>
<td>Increase the font size the next available</td>
<td>CTRL+SHIFT+&gt;`</td>
</tr>
<tr>
<td>Decrease the font size to the previous available</td>
<td>CTRL+SHIFT+&lt;</td>
</tr>
<tr>
<td>Increase the font size by 1 point</td>
<td>CTRL+]</td>
</tr>
<tr>
<td>Decrease the font size by 1 point</td>
<td>CTRL+[</td>
</tr>
</tbody>
</table>

Table : Font

Changing text formatting

<table>
<thead>
<tr>
<th>To</th>
<th>Press</th>
</tr>
</thead>
<tbody>
<tr>
<td>Change the case of letters</td>
<td>SHIFT+F3</td>
</tr>
<tr>
<td>Create all capital letters</td>
<td>CTRL+SHIFT+A</td>
</tr>
<tr>
<td>Make text bold</td>
<td>CTRL+B</td>
</tr>
<tr>
<td>Underline text</td>
<td>CTRL+U</td>
</tr>
<tr>
<td>Underline single words</td>
<td>CTRL+SHIFT+W</td>
</tr>
<tr>
<td>Double-underline words</td>
<td>CTRL+SHIFT+D</td>
</tr>
<tr>
<td>Apply hidden text format</td>
<td>CTRL+SHIFT+H</td>
</tr>
<tr>
<td>Italicize</td>
<td>CTRL+I</td>
</tr>
<tr>
<td>Create small capital letters</td>
<td>CTRL+SHIFT+K</td>
</tr>
<tr>
<td>Apply subscripts (automatic spacing)</td>
<td>CTRL+EQUAL SIGN</td>
</tr>
<tr>
<td>Apply superscripts (automatic spacing)</td>
<td>CTRL+SHIFT+EQUAL SIGN</td>
</tr>
</tbody>
</table>
Remove formatting applied by using shortcut keys or menu commands | CTRL+SHIFT+Z
---|---
Create symbol font | CTRL+SHIFT+Q

### Setting line spacing

<table>
<thead>
<tr>
<th>To</th>
<th>Press</th>
</tr>
</thead>
<tbody>
<tr>
<td>Create single-space lines</td>
<td>CTRL+1</td>
</tr>
<tr>
<td>Create double-space lines</td>
<td>CTRL+2</td>
</tr>
<tr>
<td>Create one-and-a-half spaced lines</td>
<td>CTRL+5</td>
</tr>
<tr>
<td>Add one line of space preceding text</td>
<td>CTRL+0 (zero)</td>
</tr>
<tr>
<td>Remove space preceding text</td>
<td>CTRL+0 (zero)</td>
</tr>
</tbody>
</table>

### Setting paragraph alignments and indents

<table>
<thead>
<tr>
<th>To</th>
<th>Press</th>
</tr>
</thead>
<tbody>
<tr>
<td>Center a paragraph</td>
<td>CTRL+E</td>
</tr>
<tr>
<td>Justify a paragraph</td>
<td>CTRL+J</td>
</tr>
<tr>
<td>Left-align a paragraph</td>
<td>CTRL+L</td>
</tr>
<tr>
<td>Right-align a paragraph</td>
<td>CTRL+R</td>
</tr>
<tr>
<td>Indent a paragraph from the left</td>
<td>CTRL+M</td>
</tr>
<tr>
<td>Remove a paragraph indent from the left</td>
<td>CTRL+SHIFT+M</td>
</tr>
<tr>
<td>Create a hanging indent</td>
<td>CTRL+T</td>
</tr>
<tr>
<td>Reduce a hanging indent</td>
<td>CTRL+SHIFT+T</td>
</tr>
<tr>
<td>Remove paragraph formatting applied by using shortcut keys or menu commands</td>
<td>CTRL+Q</td>
</tr>
</tbody>
</table>
Understanding the Screen Builder

Applying styles

<table>
<thead>
<tr>
<th>To</th>
<th>Press</th>
</tr>
</thead>
<tbody>
<tr>
<td>Apply a style name (Formatting toolbar displayed)</td>
<td>CTRL+SHIFT+S</td>
</tr>
<tr>
<td>Open the style dialog box (Formatting toolbar not displayed)</td>
<td>CTRL+SHIFT+S</td>
</tr>
<tr>
<td>Start Auto Format</td>
<td>CTRL+K</td>
</tr>
<tr>
<td>Apply the Normal style</td>
<td>CTRL+SHIFT+N</td>
</tr>
<tr>
<td>Apply the Heading 1 style</td>
<td>ALT+CTRL +1</td>
</tr>
<tr>
<td>Apply the Heading 2 style</td>
<td>ALT+CTRL +2</td>
</tr>
<tr>
<td>Apply the Heading 3 style</td>
<td>ALT+CTRL +3</td>
</tr>
<tr>
<td>Apply the List style</td>
<td>CTRL+SHIFT+L</td>
</tr>
</tbody>
</table>

Table : Style

Deleting text and graphics

<table>
<thead>
<tr>
<th>To</th>
<th>Press</th>
</tr>
</thead>
<tbody>
<tr>
<td>Delete one character to the left of the insertion point</td>
<td>BACKSPACE</td>
</tr>
<tr>
<td>Delete one word to the left of the insertion point</td>
<td>CTRL+BACKSPACE</td>
</tr>
<tr>
<td>Delete one character to the right of the insertion point</td>
<td>DELETE</td>
</tr>
<tr>
<td>Delete one word to the right of the insertion point</td>
<td>CTRL+DELETE</td>
</tr>
<tr>
<td>Cut (delete) selected text</td>
<td>CTRL+X</td>
</tr>
<tr>
<td>Undo the last action</td>
<td>CTRL+Z</td>
</tr>
<tr>
<td>Cut to the Spike</td>
<td>CTRL+F3</td>
</tr>
</tbody>
</table>

Table : Delete
Office Automation

**Copying and pasting**

<table>
<thead>
<tr>
<th>To</th>
<th>Press</th>
</tr>
</thead>
<tbody>
<tr>
<td>Copy text or graphics</td>
<td>CTRL+C</td>
</tr>
<tr>
<td>Copy formats</td>
<td>CTRL+SHIFT+C</td>
</tr>
<tr>
<td>Move text or graphics</td>
<td>F2</td>
</tr>
<tr>
<td>Paste text or graphics</td>
<td>CTRL+V</td>
</tr>
<tr>
<td>Paste formats</td>
<td>CTRL+SHIFT+V</td>
</tr>
</tbody>
</table>

Table: Copy and Paste

**Inserting text and graphics**

<table>
<thead>
<tr>
<th>To</th>
<th>Press</th>
</tr>
</thead>
<tbody>
<tr>
<td>A field</td>
<td>CTRL+F9</td>
</tr>
<tr>
<td>Spike contents</td>
<td>CTRL+SHIFT+F3</td>
</tr>
<tr>
<td>An Auto Text entry</td>
<td><em>Auto text entry name</em> + ALT+CTRL+V</td>
</tr>
<tr>
<td>A line break</td>
<td>SHIFT+ENTER</td>
</tr>
<tr>
<td>A page break</td>
<td>CTRL+ENTER</td>
</tr>
<tr>
<td>A column break</td>
<td>CTRL+SHIFT+ENTER</td>
</tr>
<tr>
<td>An optional hyphen</td>
<td>CTRL+HYPHEN</td>
</tr>
<tr>
<td>A non breaking hyphen</td>
<td>CTRL+SHIFT+HYPHEN</td>
</tr>
<tr>
<td>A copyright symbol</td>
<td>ALT+CTRL+C</td>
</tr>
<tr>
<td>A registered trademark symbol</td>
<td>ALT+CTRL+R</td>
</tr>
<tr>
<td>A trademark symbol</td>
<td>ALT+CTRL+T</td>
</tr>
<tr>
<td>An ellipsis</td>
<td>ALT+CTRL+PERIOD</td>
</tr>
</tbody>
</table>

Table: Insert
Understanding the Screen Builder

**Extending a selection**

<table>
<thead>
<tr>
<th>To</th>
<th>Press</th>
</tr>
</thead>
<tbody>
<tr>
<td>Select the nearest</td>
<td>F8+character</td>
</tr>
<tr>
<td>Extend a selection</td>
<td>F8</td>
</tr>
<tr>
<td>Reduce the size of a selection</td>
<td>SHIFT+8</td>
</tr>
</tbody>
</table>

Table: Extend

**Selecting text and graphics**

<table>
<thead>
<tr>
<th>To extend a selection</th>
<th>Press</th>
</tr>
</thead>
<tbody>
<tr>
<td>One character to the right</td>
<td>SHIFT+RIGHT ARROW</td>
</tr>
<tr>
<td>One character to the left</td>
<td>SHIFT+LEFT ARROW</td>
</tr>
<tr>
<td>To the end of a word</td>
<td>CTRL+SHIFT+RIGHT ARROW</td>
</tr>
<tr>
<td>To the beginning of a word</td>
<td>CTRL+SHIFT+LEFT ARROW</td>
</tr>
<tr>
<td>To the end of a line</td>
<td>SHIFT+END</td>
</tr>
<tr>
<td>To the beginning of a line</td>
<td>SHIFT+HOME</td>
</tr>
<tr>
<td>One line down</td>
<td>SHIFT+DOWN ARROW</td>
</tr>
<tr>
<td>One line up</td>
<td>SHIFT+UP ARROW</td>
</tr>
<tr>
<td>To the end of a paragraph</td>
<td>CTRL+SHIFT+DOWN ARROW</td>
</tr>
<tr>
<td>To the beginning of a paragraph</td>
<td>CTRL+SHIFT+UP ARROW</td>
</tr>
<tr>
<td>One screen down</td>
<td>SHIFT+PAGE DOWN</td>
</tr>
<tr>
<td>One screen up</td>
<td>SHIFT+PAGE UP</td>
</tr>
<tr>
<td>To the end of a document</td>
<td>CTRL+SHIFT+ END</td>
</tr>
<tr>
<td>To the beginning of a document</td>
<td>CTRL+SHIFT+ HOME</td>
</tr>
<tr>
<td>To include the entire document</td>
<td>CTRL+A</td>
</tr>
<tr>
<td>To a vertical block of text</td>
<td>CTRL+SHIFT+F8</td>
</tr>
<tr>
<td>To a specific location in a document</td>
<td>F8 +arrow keys</td>
</tr>
</tbody>
</table>

Table: Select
### Selecting text in a table

<table>
<thead>
<tr>
<th>To</th>
<th>Press</th>
</tr>
</thead>
<tbody>
<tr>
<td>Select a column</td>
<td>Hold down ALT while you click the left mouse button</td>
</tr>
<tr>
<td>Extend a selection (or block)</td>
<td>CTRL+SHIFT+F8, and then use the arrow keys</td>
</tr>
<tr>
<td>Select an entire table</td>
<td>ALT+5 on the numeric keypad</td>
</tr>
</tbody>
</table>

Table: Select (table)

### Move to a Character, Word, Paragraph, Column, Line, Page and Screen

<table>
<thead>
<tr>
<th>To</th>
<th>Press</th>
</tr>
</thead>
<tbody>
<tr>
<td>One character to the left</td>
<td>LEFT ARROW</td>
</tr>
<tr>
<td>One character to the right</td>
<td>RIGHT ARROW</td>
</tr>
<tr>
<td>One word to the left</td>
<td>CTRL+LEFT ARROW</td>
</tr>
<tr>
<td>One word to the right</td>
<td>CTRL+RIGHT ARROW</td>
</tr>
<tr>
<td>One paragraph up</td>
<td>CTRL+UP ARROW</td>
</tr>
<tr>
<td>One paragraph down</td>
<td>CTRL+DOWN ARROW</td>
</tr>
<tr>
<td>To the previous frame or object</td>
<td>ALT+UP ARROW</td>
</tr>
<tr>
<td>To the next frame or object</td>
<td>ALT+DOWN ARROW</td>
</tr>
<tr>
<td>One column to the left</td>
<td>CTRL+UP ARROW</td>
</tr>
<tr>
<td>One column to the right</td>
<td>CTRL+DOWN ARROW</td>
</tr>
<tr>
<td>Up one line</td>
<td>UP ARROW</td>
</tr>
<tr>
<td>Down one line</td>
<td>DOWN ARROW</td>
</tr>
<tr>
<td>To the end of a line</td>
<td>END</td>
</tr>
<tr>
<td>To the beginning of a line</td>
<td>HOME</td>
</tr>
<tr>
<td>Up one page</td>
<td>ALT+CTRL+PAGE UP</td>
</tr>
</tbody>
</table>
Understanding the Screen Builder

<table>
<thead>
<tr>
<th>Down one page</th>
<th>ALT+CTRL+PAGE DOWN</th>
</tr>
</thead>
<tbody>
<tr>
<td>Up one screen</td>
<td>PAGE UP</td>
</tr>
<tr>
<td>Down one screen</td>
<td>PAGE DOWN</td>
</tr>
<tr>
<td>To the bottom of a screen</td>
<td>CTRL+PAGE DOWN</td>
</tr>
<tr>
<td>To the top of a screen</td>
<td>CTRL+PAGE UP</td>
</tr>
<tr>
<td>To the end of a document</td>
<td>CTRL+END</td>
</tr>
<tr>
<td>To the beginning of a document</td>
<td>CTRL+HOME</td>
</tr>
<tr>
<td>To a previous revision</td>
<td>SHIFT+F5</td>
</tr>
</tbody>
</table>

Table : Move

**Moving around in a table**

<table>
<thead>
<tr>
<th>To move to the</th>
<th>Press</th>
</tr>
</thead>
<tbody>
<tr>
<td>Next cell in a row</td>
<td>TAB</td>
</tr>
<tr>
<td>Previous cell in a row</td>
<td>SHIFT+TAB</td>
</tr>
<tr>
<td>First cell in a row</td>
<td>ALT+HOME</td>
</tr>
<tr>
<td>Top cell in a column</td>
<td>ALT+PAGE UP</td>
</tr>
<tr>
<td>Last cell in a row</td>
<td>ALT+END</td>
</tr>
<tr>
<td>Last cell in a column</td>
<td>ALT+PAGE DOWN</td>
</tr>
<tr>
<td>Previous row</td>
<td>UP ARROW</td>
</tr>
<tr>
<td>Next row</td>
<td>DOWN ARROW</td>
</tr>
</tbody>
</table>

Table : Move (table)

**Paragraphs and tab characters**

<table>
<thead>
<tr>
<th>To</th>
<th>Press</th>
</tr>
</thead>
<tbody>
<tr>
<td>Insert new paragraphs into a cell</td>
<td>ENTER</td>
</tr>
<tr>
<td>Insert a tab characters in a cell</td>
<td>CTRL+TAB</td>
</tr>
</tbody>
</table>

Table : Paragraph
Working in outline view

<table>
<thead>
<tr>
<th>To</th>
<th>Press</th>
</tr>
</thead>
<tbody>
<tr>
<td>Promote a paragraph</td>
<td>ALT+SHIFT+LEFT ARROW</td>
</tr>
<tr>
<td>Demote a paragraph</td>
<td>ALT+SHIFT+RIGHT ARROW</td>
</tr>
<tr>
<td>Demote to body text</td>
<td>CTRL+SHIFT+N</td>
</tr>
<tr>
<td>Move selected paragraphs up</td>
<td>ALT+SHIFT+UP ARROW</td>
</tr>
<tr>
<td>Move selected paragraphs down</td>
<td>ALT+SHIFT+DOWN ARROW</td>
</tr>
</tbody>
</table>

Table : Outline

Working with Word Fields

<table>
<thead>
<tr>
<th>To</th>
<th>Press</th>
</tr>
</thead>
<tbody>
<tr>
<td>Insert a DATE field</td>
<td>ALT+SHIFT+D</td>
</tr>
<tr>
<td>Insert a PAGE field</td>
<td>ALT+SHIFT+P</td>
</tr>
<tr>
<td>Insert a TIME field</td>
<td>ALT+SHIFT+T</td>
</tr>
<tr>
<td>Insert a BLANK field</td>
<td>CTRL+F9</td>
</tr>
</tbody>
</table>

Table : Field

Moving windows and menu

<table>
<thead>
<tr>
<th>To</th>
<th>Press</th>
</tr>
</thead>
<tbody>
<tr>
<td>Go to the next pane</td>
<td>F6</td>
</tr>
<tr>
<td>Go to the previous pane</td>
<td>SHIFT+F6</td>
</tr>
<tr>
<td>Go to the next document window</td>
<td>CTRL+6</td>
</tr>
<tr>
<td>Go to the previous document window</td>
<td>CTRL+SHIFT+F6</td>
</tr>
<tr>
<td>Move a document window</td>
<td>CTRL+F7</td>
</tr>
</tbody>
</table>

Table : Move (window)
Understanding the Screen Builder

**Changing window size**

<table>
<thead>
<tr>
<th>To</th>
<th>Press</th>
</tr>
</thead>
<tbody>
<tr>
<td>Maximize an application window</td>
<td>ALT+F10</td>
</tr>
<tr>
<td>Maximize a document window</td>
<td>CTRL+F10</td>
</tr>
<tr>
<td>Change the size of a document window</td>
<td>CTRL+F8</td>
</tr>
<tr>
<td>Restore a document window to its previous size</td>
<td>CTRL+F5</td>
</tr>
<tr>
<td>Restore an application window to its previous size</td>
<td>ALT+F5</td>
</tr>
<tr>
<td>Split a window</td>
<td>ALT+CTRL+S</td>
</tr>
</tbody>
</table>

Table : Window size

**Menu**

<table>
<thead>
<tr>
<th>To</th>
<th>Press</th>
</tr>
</thead>
<tbody>
<tr>
<td>Make the menu bar active</td>
<td>F10</td>
</tr>
<tr>
<td>Cancel a menu</td>
<td>ESC</td>
</tr>
<tr>
<td>Display a shortcut menu</td>
<td>SHIFT+F10</td>
</tr>
<tr>
<td>Add a command to a menu</td>
<td>ALT+CTRL+EQUAL SIGN</td>
</tr>
<tr>
<td>Remove a command from a menu</td>
<td>ALT+CTRL+MINUS SIGN</td>
</tr>
<tr>
<td>Assign an action to a shortcut key</td>
<td>ALT+CTRL+PLUS SIGN</td>
</tr>
</tbody>
</table>

Table : Menu

**File Menu command**

<table>
<thead>
<tr>
<th>Command</th>
<th>Press</th>
</tr>
</thead>
<tbody>
<tr>
<td>New</td>
<td>CTRL+N</td>
</tr>
<tr>
<td>Open</td>
<td>CTRL+O</td>
</tr>
<tr>
<td>Close</td>
<td>CTRL+W</td>
</tr>
<tr>
<td>Save</td>
<td>CTRL+S</td>
</tr>
</tbody>
</table>
### File menu commands

<table>
<thead>
<tr>
<th>Command</th>
<th>Press</th>
</tr>
</thead>
<tbody>
<tr>
<td>Save As</td>
<td>F12</td>
</tr>
<tr>
<td>Print Preview</td>
<td>CTRL+F2</td>
</tr>
<tr>
<td>Print</td>
<td>CTRL+P</td>
</tr>
<tr>
<td>Exit</td>
<td>CTRL+F4</td>
</tr>
</tbody>
</table>

Table: File menu

### Edit menu commands

<table>
<thead>
<tr>
<th>Command</th>
<th>Press</th>
</tr>
</thead>
<tbody>
<tr>
<td>Undo</td>
<td>CTRL+Z</td>
</tr>
<tr>
<td>Repeat</td>
<td>CTRL+Y</td>
</tr>
<tr>
<td>Clear</td>
<td>DELETE</td>
</tr>
<tr>
<td>Cut</td>
<td>CTRL+X</td>
</tr>
<tr>
<td>Copy</td>
<td>CTRL+C</td>
</tr>
<tr>
<td>Paste</td>
<td>CTRL+V</td>
</tr>
<tr>
<td>Select All</td>
<td>CTRL+A</td>
</tr>
<tr>
<td>Find</td>
<td>CTRL+F</td>
</tr>
<tr>
<td>Replace</td>
<td>CTRL+H</td>
</tr>
<tr>
<td>Go To</td>
<td>CTRL+G</td>
</tr>
<tr>
<td>Bookmark</td>
<td>CTRL+SHIFT+F7</td>
</tr>
<tr>
<td>Update Link</td>
<td>CTRL+SHIFT+F7</td>
</tr>
</tbody>
</table>

Table: Edit menu

### View menu commands

<table>
<thead>
<tr>
<th>Command</th>
<th>Press</th>
</tr>
</thead>
<tbody>
<tr>
<td>Normal</td>
<td>ALT+CTRL+N</td>
</tr>
<tr>
<td>Outline</td>
<td>ALT+CTRL+O</td>
</tr>
<tr>
<td>Page Layout</td>
<td>ALT+CTRL+P</td>
</tr>
</tbody>
</table>

Table: View menu
Understanding the Screen Builder

**Insert menu command**

<table>
<thead>
<tr>
<th>Command</th>
<th>Press</th>
</tr>
</thead>
<tbody>
<tr>
<td>Page Numbers</td>
<td>ALT+SHIFT+P</td>
</tr>
<tr>
<td>Annotation</td>
<td>ALT+CTRL+A</td>
</tr>
<tr>
<td>Date And Time</td>
<td>ALT+SHIFT+D</td>
</tr>
<tr>
<td>Footnote</td>
<td>ALT+CTRL+F</td>
</tr>
<tr>
<td>Endnote</td>
<td>ALT+CTRL+E</td>
</tr>
<tr>
<td>Mark Index Entry</td>
<td>ALT+SHIFT+X</td>
</tr>
<tr>
<td>Mark Citation Entry</td>
<td>ALT+SHIFT+I</td>
</tr>
<tr>
<td>Mark TOC Entry</td>
<td>ALT+SHIFT+O</td>
</tr>
</tbody>
</table>

Table: Insert menu

**Format menu command**

<table>
<thead>
<tr>
<th>Command</th>
<th>Press</th>
</tr>
</thead>
<tbody>
<tr>
<td>Font</td>
<td>CTRL+D</td>
</tr>
<tr>
<td>Change Case</td>
<td>SHIFT+F3</td>
</tr>
<tr>
<td>Auto Format</td>
<td>CTRL+K</td>
</tr>
<tr>
<td>Style</td>
<td>CTRL+SHIFT+S</td>
</tr>
</tbody>
</table>

Table: Format menu

**Tools menu command**

<table>
<thead>
<tr>
<th>Command</th>
<th>Press</th>
</tr>
</thead>
<tbody>
<tr>
<td>Spelling</td>
<td>F7</td>
</tr>
<tr>
<td>Thesaurus</td>
<td>SHIFT+F7</td>
</tr>
</tbody>
</table>

Table: Tool menu
Office Automation

**Table menu command**

<table>
<thead>
<tr>
<th>Command</th>
<th>Press</th>
</tr>
</thead>
<tbody>
<tr>
<td>Select Table</td>
<td>ALT+5 on the numeric keypad</td>
</tr>
<tr>
<td>Auto Format Update Look</td>
<td>ALT+CTRL+U</td>
</tr>
</tbody>
</table>

Table : Table menu

**Window menu command**

<table>
<thead>
<tr>
<th>Command</th>
<th>Press</th>
</tr>
</thead>
<tbody>
<tr>
<td>Split</td>
<td>ALT+CTRL+S</td>
</tr>
</tbody>
</table>

Table : Window menu

**Help menu command**

<table>
<thead>
<tr>
<th>Command</th>
<th>Press</th>
</tr>
</thead>
<tbody>
<tr>
<td>Contents</td>
<td>F1</td>
</tr>
<tr>
<td>Context-sensitive help</td>
<td>SHIFT+F1</td>
</tr>
</tbody>
</table>

Table : Help menu
Answers to MCQs

Answers to MCQs:

Unit 1:

Lesson 1:
- a. ii) b. ii) c. i)

Lesson 2:
- a. ii) b. iii) c. iv) d. iii) e. i)

Lesson 3:
- a. i) b. ii) c. ii)

Unit 2:

Lesson 1:
- a. ii) b. ii) c. iii) d. iii) e. iv) f. i) g. ii)

Lesson 2:
- a. iv) b. ii) c. iii) d. ii)

Lesson 3:
- a. ii) b. iv) c. iv)

Lesson 4:
- a. iii) b. ii) c. ii) d. ii)

Lesson 5:
- a. iii) b. i) c. i) d. iii) e. ii) f. ii) g. i)

Lesson 6:
- a. ii) b. ii) c. ii) d. ii) e. i)

Unit 7:

Lesson 1:
- a. i) b. ii) c. iii)

Lesson 2:
- a. ii) b. iv)

Lesson 4:
- a. i) b. i)

Lesson 7:
- a. iii) b. ii)

Lesson 9:
- a. i) b. iii)